Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 0

Virtual thermostat manual control


Jellee
 Share

Question

Hi All,

 

I am using the HC3 with firmware 5.111.48.

I am making a quick app device to control the OpenTherm Gateway over Ethernet:

Please login or register to see this link.

 

At the moment I have a quick app that can communicate with the OpenTherm gateway directly and read the room temperature from the room thermostat.

The quick app is creating a child device of type "com.fibaro.temperatureSensor" which I can set to the room temperature.

 

Now I try to create a child device from the quick app to get a thermostat that I can manually control. The new setpoint from the user in Fibaro I want to receive in the Quick App so I can send a command to the OpenTherm gateway.

I have already tried to use the "com.fibaro.hvacSystemHeat" and with that I was able to write the actual room setpoint from the OpenTherm gateway into the child device thermostat. Inside the Yubii app the thermostat shows what I have set.

Now the problem is that I am not able to to control the thermostat as a user. Does anyone have an idea for a possible solution?

 

Please login or register to see this image.

/monthly_2022_06/image.png.a7dfc98ee92824881abe99885468bb81.png" />

 

image.png.ece4dbe9e2fceba0af68720f85cac945.png

 

Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 1

Hello Jellee,

You may want to double check that it isnt the 5.111 Beta Firmware that is causing the issue.

I just made a new QuickApp just to check and i still have temperature control on the new QA, but i am on 5.110.

 

It might be worth changing back to Production firmware.

Or give the attached file a try, its just the default QuickApp file from Version 5.110.

 

Hopefully this helps.

 

Please login or register to see this attachment.

Link to comment
Share on other sites

  • 0
  • Inquirer
  • Hello TechPigeon,

     

    Thanks for your support. I have tried to import your default thermostat file and it worked fine for me without changing firmware version.

    I checked your code and I took from that I was missing something in the Init for creating a child device. I added the following line into my "function OTGWdevice:__init(device)":

     

    Please login or register to see this code.

     

    This created support for the virtual thermostat to be able to fill in a setpoint for the heating which I finally sent to the physical room thermostat over OpenTherm. Beside that I am also able to update the virtual thermostat with the actual room setpoint that is finally set in the physical thermostat.

    Edited by Jellee
    Strange HTML outlining
    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Answer this question...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

     Share

    ×
    ×
    • Create New...