Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 0

Shenzhen iSurpass Keypad on HC3


ErikP
 Share

Question

Did anyone tried to get Shenzhen iSurpass Keypad working on HC3?
I could add it sync and add keys bit it seems the keypad does not sent an unlock state to HC3. Though it does work the other way around.

I have someone make it to work on HC2 though. Keypad seems nice also with Rfid tag but in this state its not usable unfortunately. Tips or advice? I use s0 as I did not rebooted HC3 yet to go to z-wave 3.

Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0
  • Inquirer
  • Ok, so I guess I need to elaborate some more on this in the hope someone can help"

     

    So It seems to be nice because it has a z-wave keypad as well as an Rfid reader. I have HC3,  thought but thought it will work on that as well. I added it to my Fibaro HC3. Inclusion went fine and I can unlock and lock from within Fibaro but its seems the device is not communicating back. So then (admin)pin is entered device unlocks but Fibaro does not seem to get a zwave signal of the unlock and stays locked in the fibaro device preview settings.

     

    I tried also catching keypad input by a small lua script:

     

    Declarations:

    {

      conditions = { {

          id = 669,

          isTrigger = true,

          operator = "anyValue",

          property = "accessControlEvent",

          type = "device"

        } },

      operator = "all"

    }

    Action:

    local sa = json.encode(sourceTrigger.value.userId)

    -- fibaro.debug("keypad", sa)

     

    if (sa == '1') then

    fibaro.debug("keypad", "TempKey")

    end

     

    if (sa == '2') then

    fibaro.debug("keypad", "Torr")

    end

     

    But also in console I see nothing happening.

    Is it possible that I need to catch the activation of the keypad another way? But anyway when I use the unlock code in the keypad in the preview on Fibaro I should be able to see the device being unlocked, but that does not happen. In HC2 at least this guy got it to work: 

    Please login or register to see this link.

     

    Hope you can help me figure out how to get this to work.

    Link to comment
    Share on other sites

    • 0

    These guy use HC Lite not HC2.

    I try in HC2 but the ADD-DEVICE function do not work!

     

    After many attempts I have discovered that the ISURPASS instructions was wrong.

    In my case the right sintax to start the pairing is:  RESET+password+enter+0+0  (TWO ZERO and not one)

     

    Anyhow, after the inclusion, I find myself in agreement with ErikP.

    Nothing happen when I use the unlock code in the keypad.

    Edited by gigelai
    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Answer this question...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

     Share

    ×
    ×
    • Create New...