Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 0

Somfy TaHoma Box V2


Liquidchild

Question

Hi, i did try to search first to see if i could see the answer to this one, so apologies if it has already been covered...

 

I have a Somfy TaHoma Box V2 (not the new switch) - is there any way to integrate it to an HC3 to allow the control of the blind through Fibaro?  I had previously read some forums that the Somfy API was locked down and couldn't be accessed, i think you can now integrate the new Somfy switch, but i really don't want to have to buy it just to allow integration.

Link to comment
Share on other sites

Recommended Posts

  • 1

As I said, this is an encoding bug. In the supported version this doesn't exist. I have to fix it in the Marketplace version anytime soon.

  • Thanks 1
Link to comment
Share on other sites

  • 0

I'm almost finished with a Somfy Quick App for the TaHoma switch box. If you login on somfy.com and select your device. Is it possible to enable developer mode on the box? If yes you can integrate between now and some time with my QA, else you have bad luck.

Link to comment
Share on other sites

  • 0
  • Inquirer
  • 41 minutes ago, Joep said:

    I'm almost finished with a Somfy Quick App for the TaHoma switch box. If you login on somfy.com and select your device. Is it possible to enable developer mode on the box? If yes you can integrate between now and some time with my QA, else you have bad luck.

     

    Hi, yes i can access developer mode

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • Please note however, as above i do not have the new switch box, i have the older smart hub, looks like an upside down V

    Link to comment
    Share on other sites

    • 0

    Please send me a DM with your mail adres, I want to send you some test QA to check if it's compatible. ;)

    Link to comment
    Share on other sites

    • 0

    Hi Joep,

     

    im getting:

    01.06.2023] [17:25:08] [DEBUG] [QUICKAPP740]: {"headers":{"X-Content-Type-Options":"nosniff","Vary":"Origin, Access-Control-Request-Method, Access-Control-Request-Headers","X-Frame-Options":"DENY","Cache-Control":"no-cache, no-store, max-age=0, must-revalidate","X-XSS-Protection":"1; mode=block","Expires":"0","Transfer-Encoding":"chunked","Date":"Thu, 01 Jun 2023 15:25:08 GMT","Strict-Transport-Security":"max-age=31536000 ; includeSubDomains","Content-Type":"application\/json;charset=UTF-8","Pragma":"no-cache","Server":"overkiz"},"status":401,"data":"{\"errorCod"}[01.06.2023] [17:25:08] [ERROR] [QUICKAPP740]: QuickApp crashed

     

    what am i doing wrong?

     

    thanks in advance.

    Link to comment
    Share on other sites

    • 0

    @TSN2did you use the Marketplace version? And the latest (uploaded yesterday)?

     

    You get an error 401, that is Unauthorised, so wrong password.

    Link to comment
    Share on other sites

    • 0

    Hi Joep,

     

    i downloaded the 1.3.1 version. 

    and made my Somfy account yesterday. so password shoud be wright. ill check it anyway.

    Thx   

    Link to comment
    Share on other sites

    • 0

    If the password has an & char it can fail. I fixed this in the official version. Not sure if I fixed it in this version. Maybe that is your problem. 
     

    Also check for copy and paste errors. Sometime you get an extra space.

    Link to comment
    Share on other sites

    • 0

    Hi Joep,

     

    i downloaded the 1.3.1 version. 

    and made my Somfy account yesterday. so password shoud be wright. ill check it anyway.

    Thx   

     

    edit:

    Op mijn telefoon werkt de inlog wel maar via internet niet.

    Als ik op wachtwoord vergeten druk krijg ik een mailtje met een reset password knop, dan wordt er weer om mijn email gevraagd, en krijg ik weer een reset password knop toegestuurd.????!? 

    Gaat dus een eindeloze cirkel worden zo...

    Link to comment
    Share on other sites

    • 0

    Found the solution.

    I had a !@ and a % in my password. When i removed those it worked.

    So 1 of these 3 is not allowed to

    Edited by TSN2
    Link to comment
    Share on other sites

    • 0

    No worries.

    It works and looks great so many thanks.👍

    • Like 1
    Link to comment
    Share on other sites

    • 0

    Hello, 

     

    Beginner into this.... Can anyone help me with the Tahoma API?

    I'm able to connect and get device's states like DeploymentState.

    But I can't find out how to send an order to the API, like setPosition to 50.

    The following doesn't work....

     

     

    Please login or register to see this code.

     

    Link to comment
    Share on other sites

    • 0

    hello @Joep @TSN2 

    can you please confirm that TaHoma V2 can be added to the HC3 thanks to your QA ? 
    i looking for adding my blinds (Profalux Zigbee 1.2 into TaHoma V2 (seems to be the only way…) and then include the tobama box Into the HC3. 
    Merci ! 

    Link to comment
    Share on other sites

    • 0
    15 minutes ago, SakkhhoID said:

    can you please confirm that TaHoma V2 can be added to the HC3 thanks to your QA ?

     

    V2 should work. I didn't test it myself with the Profalux Zigbee 1.2 to be honest. 

    Note that I'm speaking about the QA sold by JDK.

    Link to comment
    Share on other sites

    • 0
    23 minutes ago, SakkhhoID said:

    so you are using Jdk QA with TaHoma switch ?

    I wrote the QA that JDK sells. And developed it with a TaHoma switch. But it should work with a v2 too. 

    Link to comment
    Share on other sites

    • 0

    excellent thanks @Joep

    i bought the QA, and a Tahoma Switch because i thought that my new home is equipped with Zigbee 3.0 blinds but it is the older version in Zigbee 1.2

    i will buy now a V2 and Zigbee 1.2 dongle and test the QA again ...

    may i ask you for "light" support in case of it doesnt work ?

    Link to comment
    Share on other sites

    • 0
    1 hour ago, SakkhhoID said:

    i thought that my new home is equipped with Zigbee 3.0 blinds but it is the older version in Zigbee 1.2

    Can't you add them to the HC3 directly?

     

    1 hour ago, SakkhhoID said:

    may i ask you for "light" support in case of it doesnt work ?

     

    You can request support via JDK. 

    Link to comment
    Share on other sites

    • 0

    Did not try but zigbee is not that well supported … 

    ok Will ask support through SDK but hard to get fast answers…

     

    Thanks. 

    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Answer this question...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

    ×
    ×
    • Create New...