Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,


as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.


As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!



Smart Home Forum by FIBARO Team

  • 0

Can't add Danalock V3 to Fibaro Home Center 3 Lite





I am having a hard time adding my Danalock V3 Z-Wave. 


I am on the latest firmware, as of today, 5.140.17 Danalock firmware is 0.21.7 updated yesterday. I have tried every settings combination in advanced, but noting works. 

I have tried to add it without adding it in the Danalock APP, and with having it in the Danalock APP, no lock.


This is what i see in the console.



[2023-08-15] [15:56:32] [TRACE] [ZWAVE]: Waiting for adding process to start.

[2023-08-15] [15:56:33] [TRACE] [ZWAVE]: Put device into learn mode (adding) according to instruction provided by manufacturer and wait.

[2023-08-15] [15:57:33] [TRACE] [ZWAVE]: Adding device process failed, try again.


Is this a known issue, or do I have a dead Danalock?

Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Hi @phillsky,


Reset lock and add it into Home Center 3 Lite via Z-Wave. I recommend to fully factory reset Danalock and then add it first via Z-Wave. In past there were some issues if Danalock app was used to get Z-Wave working.




Link to comment
Share on other sites

  • 0

I had several reports about Danalock here in the forum, and directly to Danalock and Fibaro support for years.

The cooperation between Fibaro and Danalaock is a horror. Mostly if you running on zwave engine 2 (as you probably are, because engine 3 is only in beta version)

First of all, don't forget to select the "Adding in secure " option, while including the lock. It is a 'must be done' option. Without security based inclusion it will never work.

On the other hand, try to reset Danalock as @jakub.jezek mentioned.

Try to add (if possible) Danalock into system, while the system is not too big. Best to add it on first place.

Try mor times..I had some installations where i have been trying for hours...Then it somehow got included, but always lost connection.

So i tried to reconfigure the device's mesh in ZWAVE section of the gateway.


I can assure you, Danalock is an unreliable device when it comes to Fibaro..Several times it fails while security bootstrapping is happening, many times it doesn't report the lock's state correctly..so it is a nightmare for me..I am not gonne blame one side or the other. 

I was talking about it with some really nice guys from FIbaro, like @m.roszak, or @Kacper Klensporf, and the conclusion is the same..I can quote some part from it if you are interested in some details.


When the device is not added on a clean control panel, after it is added to the system and begins configuration it does not respond to the Security Scheme Get command, the control panel will not add the device in Security if it does not get a response to this GET.
Here a sample snippet from the logs we analyzed of what the process looks like:
1. 14:27:43 - new NodeId detected -> protocol neighbor search process started.
2. 14:28:55 - the process of querying for neighbors is completed, device configuration begins (this took more than a minute by the large number of devices in the network).
3. 14:28:56 - gateway sends Security Scheme Get command (it repeats it until it gets response) to start Security class configuration and perform Bootstrapping (Security key exchange).
4. 14:30:05 - the control panel aborts the add operation by not getting a response to Security Scheme Get

The order in which the device is added (what we see above) is imposed on us by Silabs - there is nothing we can do about it. I suspect the device has implemented Timers in a wrong way or Silabs didn't anticipate that the device would take so long to add itself. In theory, it allows the key to be replaced within 10s of being added to the network, this time cannot be extended (security).
On the first Network Inclusion graph, the time that limits adding to the network is not marked ("Network Inclusion" at the very top of the graph).
On the other hand, it says that the key exchange is to take place immediately after being added to the network (underlined in red).

According to Silabs, it can take a maximum of 10 seconds from the time of addition to when Gateway receives the Security Scheme Report.
From our perspective, the addition process ends after more than a minute, which is when this timer theoretically starts.
Apparently, the device starts timing at a different point (right after the nodeId is assigned).
We suspect there is a problem with the device's firmware or a bug in the ZW protocol itself.



But because there is not any other ZWACE lock in the market, i was forced to go for it, and hope for the best...

There is a pretty decent non zwave lock with Fibaro support (TEDEE)..If you don't mind to use a WIFI based lock, than definitely go for it, otherwise it wiil never be full reliable, until the ZWAVE 3 got its stable version.



Edited by Neo Andersson
Link to comment
Share on other sites

  • 0
  • Inquirer
  • Thanks everyone who have responded. It's finally in Fibaro, I don't know exactly how, but it's added, and it works.


    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Answer this question...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

    • Create New...