Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 0

Dimming LED on RGBw2


BallaBooYeaH

Question

I must have an issue with my wiring.  Connecting directly to a powee supply - the white strip works fine.  I am wanting to use a RGBw2 module to be able to dimm the LED strip.

 

I looked like it is wired correctly but I cant get anything to work.  Not sure if it is a settling or incorrect wiring. 

 

Open to suggestions as to what else to try. I have used 2 different RGBW2 modules to check it is not the module

 

Also with this wiring trying to do a RGB strip, I can only get 1 colour Red. this is with one push button Mech and using the PC to change colour, I still can only get one colour to work.

 

 

Please login or register to see this attachment.

Please login or register to see this attachment.

Edited by BallaBooYeaH
edit
Link to comment
Share on other sites

11 answers to this question

Recommended Posts

  • 0

The RGBW2 Controller does NOT switch ON or OFF, with push-buttons connected.
This is a KNOWN bug for years!!
Only remote control via Z-Wave connection is posible

But as far as I can see, you switch is also not connected to the right input.
if you wanted to switch a channel than it should be connected to the right input:

Please login or register to see this image.

Notes for diagrams:

P – 12/24V DC power supply connector

GND – ground connector

IN1 – input connector for controlling OUT1 output

IN2 – input connector for controlling OUT2 output

IN3 – input connector for controlling OUT3 output

IN4 – input connector for controlling OUT4 output

OUT1 – output connector controlled by IN1 input (red LED color recommended)

OUT2 – output connector controlled by IN2 input (green LED color recommended)

OUT3 – output connector controlled by IN3 input (blue LED color recommended)

OUT4 – output connector controlled by IN4 input (white LED color recommended)

B – service button (used to add/remove the device)

 

By the way, the

Negativ of the LED strip has to connect to the "W" connector ( or any of the other outputs)
Positiv goes direct from the PSU to the strip
cheeers

 

Link to comment
Share on other sites

  • 0

I have this working without any problem. I have 3 different white-only ledstrips in 3 rooms connected to 3 different colours of thr rgbw controller. Every room has an on/of switch connected to 3 different inputs and that all works fine.

Parm 20-23 are set to 3, check other parms if they fit your setup

Link to comment
Share on other sites

  • 0

@

Please login or register to see this link.

do you have the RGBW or RGBW2?

 

I had lots of the old RGBW controllers and they worked as you describe.
But I had lots of other problems with the old RGBW controller!

... and after almost a year with fibaro support, I recently had to replace 30 of them with the new RGBW2
and  none of the connected switches do switch the LED strips "ON"


This was already discovered in 2020!
Read about it here:

the related part is :
 

4) Brightness disassociated from RGBW channels
a) This makes little sense to me. With the RGBW 1, when you changed the RGB or W channel the brightness moved with it. It worked well for me. At a minimum it should be a user option to revert back to this functionality. As you would have seen, with the RGBW2 you have to select a colour AND a brightness to get the light to turn on... It's counterintuitive to me when different combinations of a channel colour and brightness result in the same level of output.
 
cheers
Edited by pflugj
correction
Link to comment
Share on other sites

  • 0

Hi

Can you try this in your setup:
Disable the "brightness" channel from the GUI and then try to switch the lights, with the connected switches?
Does it work?
 

In my case , with  the "brightness" channel turned "off":  the connected switches do not switch the outputs on.
One can see that in the GUI as well. The color slider move but the "brightness" stays off.

The same is true when moving a color slider in the GUI.
One has to move the "color" AND the "brightness" slider.

The GUI "Turn off" /  "Turn on" buttons in the GUI switch the "Brightness"on/off.

 

So when the light is switched "off" via the GUI,

one can not switch them "on"  again, with the connected switches!
 

Link to comment
Share on other sites

  • 0

I never tried openHab :-(
 

I just tried homeassistant 1st and things got a lot easier!

For data collection I use InfluxDB and Grafana to the display

 

Cheers :-)

Link to comment
Share on other sites

  • 0

data collections as in sql, I use MariaDB and also Grafana to display. Openhab does all the API interfacing to all sources like solar panels, climate/dust/weather sensors, heatpump, energie measurements and lots more.

Link to comment
Share on other sites

  • 0
  • Inquirer
  • Ok heard bck from Fibaro support and I have this all operational.

     

    At first the button wont work,  When you start it on the app - it then opperates.

     

    Lets hope it works after a long time running.

     

    Pics of final below,  

    Here is the response from Fibaro support

     

    <snip>

    You have the button connected to IN1, which corresponds to OUT1 (R).

    Please connect your button to IN4, which corresponds to OUT4 (W) or connect the LED strip to OUT1 (no difference when using only white LED strips)

     

    Please login or register to see this attachment.

    Please login or register to see this attachment.

    Please login or register to see this attachment.

    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Answer this question...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

    ×
    ×
    • Create New...