Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 0

sporadic movement of roller shutters


kandetvara
 Share

Question

Hi there,

 

I have the following issue:

 

I set up all my roller shutters with fibaro actors. The installation and set up was more than easy. I have not set up any Scenes so far - i just use the HC2 as a remote control. The Problem is the following - I let down the roller shutters via "PC" will say - I Close them via being logged into the HC2 remotely.

 

The next morning I do open them "manually" via the toggle Switches. Once I hit the "up" toggle the roller shutter will go up completely BUT then will go down immediately again - until it is completely shut again. You can then manually open it again without any Problems. This happend at different blinds to me several times.

I just don't get it - any solution?

 

kandetvara    

Link to comment
Share on other sites

Recommended Posts

  • 0
  • Inquirer
  • Hi there,

     

    in some instances I can reproduce this - but not every time. I try to describe it again:

     

    I have toggle Switches.

    I open the blinds manually with the toggle Switches.

    I close the blinds with the HC2 (not with a Scene just remotely through the HC2)

    Now the toggle Switches (one for down / one for up) are logically in the wrong Position.

    I now want to open them manually with the toggle Switch.

    For this I have to bring the Switches in the right Position (on / off / on)

    Now the blind goes completely up but goes immediately down again and then goes automatically up again. So one movement - up / down / up

     

    I can not reproduce this every time. It seems to be dependent on how Long the System was idle. Will say I only see this behaviour after the System / blinds have not been moved for a couple of hours.

     

    It happens with several Units (I have >12 of them) - it is not isolated to one roller shutter.

     

    If this continous to go on I have to send everything back, since I can not spend  >1500€ for a System which does that.

     

    @Fibaro & All others: do you know this issue and is there a fix to it? I am running on HC2 4.049 with roller shutters 222 Version 22.22

     

    Thoughts?

     

    Best

     

    kandetvara

    Link to comment
    Share on other sites

    • 0

    Something similar is happening to me as well. I also have toggle switches (if that matters) and for me it's the other way around. I close my blinds manually, then at some point HC2 opens them by scene, then when I close them manually again and perform the double switching up-down (since the position of switch is already down) the blinds go down, then up and again down. As if another calibration was taking place...

    It's not happening 100% of time and it seems like one of my modules is more prone to this than others (although I use this one most often)

     

    Does anyone have any suggestions for us?

    Link to comment
    Share on other sites

    • 0

    Are these switches casual toggle ones or are these blind switches? You know, the ones that can not be enable two at a time.

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • Hi J,

     

    it is the one which "block" each other and do not allow the use of both at the same time. I shot of video of this problem (attached) From this you should be able to see what I use and what happens...

     

    if you need more info - just let me know. It really looks like it would go into calibration....

     

    kandetvara

    Please login or register to see this link.

    Link to comment
    Share on other sites

    • 0

    I use these ones:

    Please login or register to see this link.

    And I tested yesterday that it doesn't matter if I toggle UP/DOWN or OFF/ON - same erratic behavior

    Link to comment
    Share on other sites

    • 0

    Tried to reproduce the error but did not managed to... I just have one question: why do you click the 2nd button on this movie? Why not just change state of the 'up' button? Is the state of device not updated in controller?

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • Hi J,

     

    that is a valid and good question

    Please login or register to see this image.

    /emoticons/default_icon_smile.gif" alt=":-)" />

     

    I am right now in the office - I can not tell you why. I assume that I hit the 2nd button since just hitting the first button "up" and then "down" doesn't trigger any reaction.....

     

    But now that you are asking I am quite surprised as well. But like I said - I guess just hitting button number one (left) to up and down does not do the trick.

     

    But I will check tonight again an let you know. For what it's worth - I attach the circuit diagrams for my switches - not sure if that helps.

     

    Thanks for your support and I keep you posted!

     

    kandetvara

    Please login or register to see this attachment.

    Please login or register to see this attachment.

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • Hi J,

     

    I tested it and you are right - I do not need the right / 2nd switch. I checked with my wife and showed her as well the Video. She is doing it like I was - both switches. So it must be something you do "logically" (at least as a German

    Please login or register to see this image.

    /emoticons/default_icon_wink.gif" alt=";-)" />). I asked her as well why she is doing it - same answer - it seemed logical.

     

    So we are using only one switch from now on and let you know if it happens again. I tested it three times today just with one switch and it worked prefectly.

     

    I keep you posted if it happens again...

     

    I think with hitting three times S1 (1*) /S2 (2*) I really triggered the auto calibartion. But I am not sure, I am not the technician.

     

    I will let you know if I stumble with the new procedure into similiar Problems.

     

    All the best to Poznan

     

    kandetvara

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • Hi

     

    me again. I was too fast. This morning I only used the left toggle switch after I lowered the blinds last night with the HC. Same behaviour. Roller shutter goes up then down then up again.

     

    As Zaba19 says it seems to be eratic but some switches seem to be more prone to this error than others. I have the feeling as well that this happens only after a longer idle time of the module - e.g. over night. And it only seems to happen to the first blind which is opened in th emorning. But this is a feeeling and no proof.

     

    Any further sugestions?

     

    kandetvara

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • I have not received any solution so far. Today it happened again. So I think I can add some more info.

     

    It definitely only happens if the following conditions are met:

     

    1. Blind was closed via HC2 while toggle switch is in position “open”
    2. Blind is opened vi toggle switch. To get it in the right position you have to do: “down” and the “up”
    3. The blind goes completely up then automatically down again and then completely up again.
    4. According to my observation this only happens with the first blind which is opened manually in the morning (the rest the works ok) and if the system was idle a couple of hours Today I closed the blinds via remote access at 14.00 and opened it manually at 20.00 and it went through the cycle of up down and up.
    5. This happens as well to the first blind opened in the morning (again couple of hours idle)

    So at the Moment i would not recommend to anybody to use the roller shutters 2 in my Kind of Setup (gira wippen mir gegenseitiger Blockierung)

     

    kandetvara

    Link to comment
    Share on other sites

    • 0

    Hi, kandetvara,

     

    I think I had experienced similar problem once, but only for short time and I'm not sure if it wasn't just me messing up with some scenes, settings or so...

    Anyway, I can see you have toggle switches (not momentary switches - the ones that keep returnig to the initial position).

    Having venetian blind (not a roller blind) I had that problem when I set parameter 14 to toggle switch, which indeed I have (not Gira but Jung).
     

    I've ended up with momentary switch setting (parameter 14) in HC2 and each time I want to move the blind up manually I click the switch down-and-immediately-up-again.

    When I want to move the blind down I click the respective switch down-and-immediately-up-again as well.

    Having venetian blind, when I click the switch once only (down-but-not-immediately-up-again) the lammellas change their position.

     

    You could give it a try if you wish, but at the same time please double check your scenes settings - you wrote you don't have any, I know

    Please login or register to see this image.

    /emoticons/default_wink.png" alt=";)" srcset="https://forum.fibaro.com/uploads/emoticons/[email protected] 2x" width="20" height="20" />

     

    I find it quite strange that you cannot always reproduce the problem, what makes me think that maybe you have some electricity shortages - that for some reason some parts of equippment have no electricity (HC2 or actors) and they have to re-calibrate something. Do you have different electricity rates maybe? (Nachttarif oder so?)

    Link to comment
    Share on other sites

    • 0

    I have also been observing this behaviour last couple of weeks (not testing various scenarios like you have, just trying some things whenever I was manuipulating the blinds which is 1-2 times a day). I came up with the conclusion that it only might happen when I make a quick switch from ON to OFF and ON again or from UP to DOWN and UP again (so once HC2 changed position and the wall switch remains in the position I want to switch now to).

     

    What works for me is to either:

    - wait a couple seconds before doing 2nd switch so from ON to OFF (wait 2-3s) and ON again

    - my blinds are scheduled to open in the morning so after I wake up I change the position to OFF and in the evening when I want to close them again I normally change the position to ON

     

    Maybe our toggle switches cause sometimes some unsteady position at toggling that the module interprets them as 3 consecutive switches starting calibration? It's the only thing that makes sense to me. I got used to toggling with a couple seconds wait between and can live with that. The alternative would probably be replacing the switches with push switches but I prefer the toggle switches actually so I don't have to hold them down.

    Link to comment
    Share on other sites

    • 0

    hi zaba19,

    you don't actually have to hold the switch down. The momentary switch would work perfectly well when you push it once - pushing the second time would just stop the blind half way down.

     

    I don't actually get why do you have to push it up and down again? if the parameter 14 is set to "toggle" wouldn't it be enough to push the button once only regardless the physical position of the switch?

     

    The blind switches (mit gegenseitigen Blockierung) are not good as toggle switches, as to push "open" you have sometimes to push "close" to release the other button. That's (among others) the reason why I'm using the toggle switches as momentary switches - I just move it down-and-immediately-up-again.

    It seems to me that at least one of you guys have the parameter 14 set to "momentary" and is using the "toggle" switch. I cannot say which of you, though

    Please login or register to see this image.

    /emoticons/default_wink.png" alt=";)" srcset="https://forum.fibaro.com/uploads/emoticons/[email protected] 2x" width="20" height="20" />

    Please check the different settings of parameter 14 and report, as it really attracted my attention.

    I hope it is as easy as that

    Please login or register to see this image.

    /emoticons/default_wink.png" alt=";)" srcset="https://forum.fibaro.com/uploads/emoticons/[email protected] 2x" width="20" height="20" />

    cheers.

    Link to comment
    Share on other sites

    • 0

    All my modules have the parameter 14 set to toggle switches.

     

    As to your question why I have to push up and down again... The swich has two buttons UP/DOWN and ON/OFF. I usually close the blinds manually so the position is DOWN and ON. Then usually my HC2 opens them (scene) so the blinds are open but the buttons are still DOWN and ON. So when I want to close them again I have to trigger status change. Only two options: go UP and DOWN or OFF and ON.

    Link to comment
    Share on other sites

    • 0

    ok. what is the on/off button for? If you had no roller shutter connected would you still need to push two buttons to move the blind? to open: first on, then up?

    And when do you push off? after the blind is all up? That means you have to wait till it moves completely and then power it off?

    Sorry for these questions, but I just don't get the logic of those buttons. I got used to blind switches like on the kandetvara's video: one button for up and one for down.

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • Hi,

     

    thanks for your support in this matter. It is definitely not a settings issue – at least not parameter 14 – see attached screenshot.

    Like homee stated – I still have no scenes at all – so that can not be the problem either. I have roller blinds or roller shutters whatever one will call them.

    It is not electricity shortages either. I have (well the electrician) renovated the whole house inclusive the electric wiring 7 years ago. It is brand new. I have on every storey / level a separate independent fuse box. I have fibaro roller shutters 2 on different floors. There are no shortages. I have different electricity rates (Nachtstrom) but only for my heat pump. But within the setup the heat pump has a separate meter. So the normal electricity is not connected to the heat pump and has a separate meter.

    It is like zaba19 says. It is the “up-down-up” combination which triggers the same behavior as I would calibrate. I can interrupt it if I want by just switching again and then it works absolutely normal. But this can not be the solution. I have not tried to let some seconds go by after hitting the “up” like zaba said. That might do the trick but questions the WAF. Same applies to the manual change in the morning you described. A work around I have not thought of – but by installing the automatic blinds I wanted to avoid the running around

    Please login or register to see this image.

    /emoticons/default_icon_wink.gif" alt=";-)" />

    The interesting part is that the system has to be idle for a couple of hours. I can not reproduce it once it happened or if any other shutter / blind in the house went up normal – which might be the case if you dot have to do the “up down up” motion.

    @ home: zaba has different toggle switches than I have (I guess but I am not sure). He might have  one for “on off” an one for up down. Or he just has the following:

    Please login or register to see this link.

     But only he can know. I have one for “up” and one for “down”. Why do you have to do the “down up down” move? Rather simple. Let’s assume you close the shutters at night via the HC2 or remotely. You opened them manually in the morning the day before. Now your switch is in the wrong Position. You switched it to “up” in the morning. Then in the evening you are closing the blinds via HC2: Now the blinds are closed but the switch is still in the “up” position. In order to open the blinds manually you have to switch the switch to “on off”or “up down up”. Complicated to explain, but perhaps the video I attached recently explains it.

     

    For me it is just confusion….Like homee said – I really guess that I am triggering for some reason the calibration scheme….

    Hey guys – thanks for your interest and willingness to help – much appreciated!

     

    kandetvara

    Please login or register to see this attachment.

    Link to comment
    Share on other sites

    • 0

    @kandetvara

    I am rather doer than thinker, so if I were you I would do one or both of the following:

     

    - with the parameter 14 set to toggle (as it is), after having closed the blind in the evening with HC2, in the morning press the up button ONLY ONCE (nevermind in which position it is) and wait (press nothing else). If nothing happens than something's wrong or I'm stupid

    Please login or register to see this image.

    /emoticons/default_wink.png" alt=";)" srcset="https://forum.fibaro.com/uploads/emoticons/[email protected] 2x" width="20" height="20" />

     

    - with the parameter 14 set to momentary (you'd have to change it in HC2) try to imitate the momentary switch by pushing it down-and-immediately-up-again, so you leave the button always in good position (neutral = allowing you to press any button). If you can reproduce this strange behaviour, that would mean that there is some problem either with the actor (roller shutter 2 in your case) or with HC2 or with power supply (interruptions, power plant outages?). If you can't reproduce that behaviour, it would mean you involuntary (re)calibrated the system every morning

    Please login or register to see this image.

    /emoticons/default_wink.png" alt=";)" srcset="https://forum.fibaro.com/uploads/emoticons/[email protected] 2x" width="20" height="20" />

     

    Explanation:

    As I said I have the same switches as you have: blind toggle switches (wippen mit gegenseitiger Blockierung).

    To avoid a possible "wrong position" of any of two buttons I chose to use a "momentary" setting of parameter 14. (In my case it is even better, as I have venetian blinds, which allows me to change the lamellas position by single click). I know it can be a little more inconvenient for you, but it will avoid having the "wrong position" at any time.

    BTW I was even looking for Jung momentary blind switches but apparently they don't do it and I don't want to have other ones if all remaining switches are from Jung. Obviously I don't want to change all the switches at home

    Please login or register to see this image.

    /emoticons/default_wink.png" alt=";)" srcset="https://forum.fibaro.com/uploads/emoticons/[email protected] 2x" width="20" height="20" /> although I had to buy some, cause using toggle switches for dimmers was really a no go.

     

    @zaba19 I overlooked the link you supplied - I think it's the diagram on the left you're using. I'm wondering what would happen if you let the on/off button always on and set the parameter 14 to "single momentary switch" (that could possibly require rewiring)...

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • Ok Homee

    Here are the results of the German Jury. After I moved them up manually I lowered them via the HC2. Then I only hit the “up” button once. And… Nothing. Does not move up or anything. When I hit it a second time it moves up.

    Setting them to momentary is not a real option either. It works but it is awkward to handle, since you have to press the switch for any action double. This is anything but comfortable and not really feasible with small children. They don’t get the logic. Particularly if you want to stop them half way, which we do often to reduce the sunlight in the living room this is a real show stopper. I am with you if it is plain up and down and leave them in neutral – then it works logically. But not if you stop them in between…

    At the moment I can not reproduce the issue. Since the system was not idle for long enough….I can not reproduce it for scenario 1 or 2.

    Again Homee – thanks for your support – it is really appreciated.

    Let’s assume it is recalibration going on – wouldn’t I see that in the upper text field of the Webbrowser of the HC2 where all the changes are shown? Or is this just displaying commands issued by the HC2 and not commands done by the actor?

    If that would be the case it would not be a software bug in the HC2 but in the actor itself….

     

    Kandetvara

    Link to comment
    Share on other sites

    • 0

    Thanks for experimenting Kandetvara

    Please login or register to see this image.

    /emoticons/default_wink.png" alt=";)" srcset="https://forum.fibaro.com/uploads/emoticons/[email protected] 2x" width="20" height="20" />

    The blind switches seem to work a little different than I thought. I'm sorry that we haven't found a solution....

    You are probably right saying that those switches are not the best choice for roller shutter 2 (or the other way round). Perhaps (but only perhaps) you would be better off with normal double wall switch (like normal interruptor, double toggle switch), than with those blind switches (blocking each one another). but again, that would require replacing switches, so for me it's not even worth a try.

     

    I don't know whether the actor-triggered calibration is displayed in the browser, but if it appears randomly on different roller shutters it seems more probable that it's HC2's fault.

    cheers & good luck

    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Answer this question...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

     Share

    ×
    ×
    • Create New...