Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 0

Global Variable changes after HTTP PUT Json, but scene not triggered


Go to solution Solved by mvdkallen,

Question

Dear Fibaro team,

 

In my HC2 I use many global variables which offer me full flexibility with this great controller  :->

 

Lately I noticed that if you change a global variable on HC2 through a HTTP command then the global variable on HC2 will change, but Scenes that are dependent of this global variable change (.. trigger) are not being executed.

 

For testing purpose I then created a new scene within HC2 which changes the same global variable, and now I notice that the other Scenes (.. that are dependent of this global variable change by trigger) are being executed. So it looks like it only works when the job is executed from within the box, and not from external.

 

Is it normal that it doesn't work this way, or is it maybe a minor SW bug?

Or, am I doing something wrong here?

 

Thanks for your valuable support.

 

Best regards,

Mark van der Kallen
Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0
  • Inquirer
  • Hi Jakub,

     

    Thanks for your swift reply.

    Your REST body code seems not to work, but after checking and trying I managed to get it working by using the below code instead:

     

    {"value":"xxx","invokeScenes":true}

     

    Thanks a lot!

     

    Best regards,

    Mark

    Link to post
    Share on other sites
    • 0

    When you send an command try to send with it invokeScene:true in the body. InvokeScenes is hidden parameter, that needs to be set to TRUE.

     

    So REST body should look like: {"value": XXX, "invokeScenes":true}

     

    If you using LUA:

    Please login or register to see this code.

    Link to post
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Answer this question...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

    ×
    ×
    • Create New...