Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 0

Alexa doesn't Discover Devices after successful account link


JohnnyC
 Share

Question

After the release of the official Alexa skill for Amazon Echo, a number of us are unable to "Discover Devices" after successfully setting up the skill and connecting the Amazon account to Fibaro ID

 

I wanted to open a thread to specifically debug this issue, as I accept that Amazon currently only supports (officially) US, UK and EU, and I was expecting that some restriction of cloud to cloud service maybe implemented from the multiple data extraction points involved in the layers of this integration... . However a number of UK forum users have also experienced the same. 

 

Therefore, I list the following steps I have undertaken to date without success in the hope that we can identify a fix/workaround, or simply discover that we should stop trying as it is possible that certain unsupported (officially) use cases won't allow (in the hope that this is the reasoning behind the "Custom Skill"

 

Hardware

- I am in New Zealand and also have a setup on a bench in Australia

- Echo devices (both "Echo" model - Not Dot) Software version 5264

- Both using HC2 on v 4.120

- I use the remote access via Fibaro ID as designed - No Port forwarding or alternative setup

 

With the above in mind, there are no setup configurations that are outside of what would be considered "correct" in terms of system design. The following is a list of steps i have taken to try and remedy the issue.

 

- Reboot everything in various order (Network, HC2, Echo )

- Remove multiple layer network structure (disconnect access points and only use router) reconnect everything from scratch including forgetting known networks

- Reduce Fibaro ID remote access to a single HC2 (rather than multiples) as the "Alexa tell/ask Fibaro to list Home Center Devices" appeared to not function

- Fresh install of Alexa app (have to use device with US iTunes account)

- Full reset (deregister AND reset button) of Echo

- Checked Discover Devices still worked with other skill - (Logitech Harmony had no issues)

 

To this point no success. I read in another post that a user found "alexaProhibited:true" somewhere in the REST API - I couldn't find it in mine.

 

Things left to investigate:

 

Potentially there are some port (UDP/TCP) access issues as Alexa is largely driven through outside communication

Will send this detail to support to see if the developers can let us know if it is, in fact, due to restrictions driven from the Amazon build requirement

If the above is the case, can we expect a workaround in the "Custom Skill" ?

 

So now we open up the floor.. Let everyone know what you have experienced and add some value to see if we can debug effectively as a community.... Keep the thread clean and relevant to the task... pages of "+1's" are annoying to work through and voicing general dissatisfaction or opinion, while valued, is not what this thread is for   :D

 

 

 

Link to comment
Share on other sites

Recommended Posts

  • 0

Hi - I am also in Australia and have the opposite problem - I can see all Devices but can't see any Scenes.  I didn't do anything different to what you have tried above......

Link to comment
Share on other sites

  • 0
1 hour ago, sitaylor said:

Hi - I am also in Australia and have the opposite problem - I can see all Devices but can't see any Scenes.  I didn't do anything different to what you have tried above......

Such inconsistency smacks of insufficient QA testing by Fibaro. Disappointing. Hopefully there are others out there who can assist both of us.

Link to comment
Share on other sites

  • 0
Guest fat

I am also in Australia and I found the Fibaro skill very poor. I am now running HA Bridge which works perfectly with all of my Echos

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...