Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 0
Mandala1

Problem Manual scene activate lights motion sensors

Question

I am a beginner, but despite that I feel like an idiot.

Can't get a scene to work that should be straight forward.

I wanted to have a Manual scene that i turn on when I leave the house, see picture.

The idea is that if either of the two motion sensors are breached, the scene that turns on the lamps should be run.

The problem is that as soon as I run this scene the lamps go on.

In other words, the scene seems to ignore the conditions with the motion sensors.

I have even tried to put different conditions, e.g. motion sensors=armed and motion sensors=disarmed. It does not seem to matter what I put, the scene that lights all lamps is run anyway.

If I turn the scene to automatic it works - then the lamps are only lit when the motion sensors are breached.

Any tip on what's wrong and how I should build it instead?

Thanks /Lars

Please login or register to see this attachment.

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

It works as it should be.

The reason behind that it makes sense. In automatic it waits for motion sensors, but if the trigger is manual then ignore the sensors and perform "then" condition.

Why you need to run this scene manually? It should wait for triggers.

What you expect to happen when you triggered manually?  

Doesn't make sense to trigger the scene manually, you can turn On/Off the device directly from UI.

In any case that's the way the scenes work.

According to my understanding you need to activate the scene when you leave the house, it's done by disable/enable the scene and not by running it manually (it doesn't turn the scene to automatic).

You do not "turning on" the scene by triggering it manually.

Please login or register to see this image.

/monthly_2018_07/Capture.PNG.a9ffa3bf8c091ac807a1908ec39c44eb.PNG" style="width:372px;height:auto;" />

 

Edited by cag014

Share this post


Link to post
Share on other sites
  • 0
  • Inquirer
  • Thanks,

    Then I understand. The issue I have then is that I don't know how to activate/deactivate the scene when I leave the house /arrive home.

     

    I would like to activate it from my Iphone and the Fibaro app, but when I go to scenes on my Iphone, the only option I see is to run the scene.

     

    Thanks

    Share this post


    Link to post
    Share on other sites
    • 0

    Yeah, no way as far as I know too.

    In this case you have two options:

    1. Write LUA scene that every time you run it will activate/deactivate the scene

    2. Create Virtual Device with two buttons: Activate and Deactivate this or any other scenes

    Share this post


    Link to post
    Share on other sites
    • 0
  • Inquirer
  • I am afraid both options are beyond my novice level of competence.

     

    Anybody who has a LUA script for activates/deactivates a scene that could be shared?

     

    Thanks 

    Share this post


    Link to post
    Share on other sites
    • 0

    I think I can help you, but this is a VD (Virtual Device)

    Do you interesting? If yes please post scene ID.

    Edited by cag014

    Share this post


    Link to post
    Share on other sites
    • 0
  • Inquirer
  • I would love to try a virtual device, thank you. Right now I have a problem, though, as I cannot get in to my homecenter from the computer and therefore I can't see the scene ID.

     

    No Idea what has happened, this is the first time.

     

    I had some Internet issues during the day, but Internet is now working again and  I  have tries to turn off and turn on the homecenter module (homecenter 2)

    /lars

    Share this post


    Link to post
    Share on other sites
    • 0
    17 minutes ago, Mandala1 said:

     

    Has probably changed ip address with router restart

    try re searching for a different ip address

    Edited by Jamie mccrostie

    Share this post


    Link to post
    Share on other sites
    • 0
  • Inquirer
  • I was on to that, but can't find it. I ran Ipconfig and this is what I got:

    Please login or register to see this image.

    /monthly_2018_07/image.png.8cc0372266347f2a7af47af32afe9263.png" alt="image.png.8cc0372266347f2a7af47af32afe9263.png" />

    Share this post


    Link to post
    Share on other sites
    • 0
  • Inquirer
  • Found the software on Fibaro Support to locate the IP adress. But the Homecenter module shows no Internet connection. No idea what to do. Suspect that the telecom provider changed something in my router when they fixed it.

    Share this post


    Link to post
    Share on other sites
    • 0

    So the LED of Internet on HC2 (the third from right) is OFF?

    Let me know when you'll have the scene ID

     

    Share this post


    Link to post
    Share on other sites
    • 0
  • Inquirer
  • Puuhh.. Finally it works again. The ID of the scene I would like to control is 56.

    /Lars

    Share this post


    Link to post
    Share on other sites
    • 0

    OK,

    Attached you'll find virtual device.

    In addition to buttons, there is a main loop that runs every minute to get the scene status (activated/deactivated), the reason is to monitor scene status in case the scene has been activated or deactivated by other tools (like from UI)

     

    Please login or register to see this attachment.

    Edited by cag014

    Share this post


    Link to post
    Share on other sites
    • 0
  • Inquirer
  • Thanks!! It seems to work great.

    Really appreciate it. Hope to develop so I can contribute back...

    /lars

    Share this post


    Link to post
    Share on other sites
    • 0

    hi there

    i have 4 scenes in mij HCL:

    scene 1: when temperature <12 degrees, switch off the powerplug (ID: 15)
    scene 2: when temperature >16 degrees, switch on the powerplug (ID: 17)
    scene 3: when temperature >22 degrees, switch off the powerplug (ID: 18)

    scene 4: when temperature <18 degrees, switch on the powerplug (ID: 16)

     

    i use scene 1 and 2 for an boiler when there is nobody in the house
    I use scene 3 and 4 when there is somebody in the house.

    I see that i can make a VD as an button ON/OFF, but i don`t know what a string must contain to activate scene 1&2 or scene 3&4

    can somebody help me with this issue?

    Share this post


    Link to post
    Share on other sites
    • 0

    Create a global variable (e.g. "atHome").

    In VD change by buttons this variable to true/false.

    Use this variable as a condition in scenes

    scene 1: when temperature <12 degrees and "atHome" == false, switch off the powerplug (ID: 15)
    scene 2: when temperature >16 degrees and "atHome" == false, switch on the powerplug (ID: 17)
    scene 3: when temperature >22 degrees and "atHome" == true, switch off the powerplug (ID: 18)

    scene 4: when temperature <18 degrees and "atHome" == true, switch on the powerplug (ID: 16)

    Edited by cag014

    Share this post


    Link to post
    Share on other sites
    • 0

    Hi cag14

    thank You for the quick respons

     

    I have  made a VD with 2 buttons
    Button "afwezig" and "aanwezig"

     

    In the string for Button 1,  i put:

    GET /api/sceneControl?id=15&action=start HTTP/1.10x0D0x0AHost: 192.168.178.410x0D0x0AAuthorization: Basic am9obnNjaGVwZW5zQGhvdG1haWwuY29tOlNqb25uaWUzMiE=0x0D0x0A0x0D0x0A
    GET /api/sceneControl?id=17&action=start HTTP/1.10x0D0x0AHost: 192.168.178.410x0D0x0AAuthorization: Basic am9obnNjaGVwZW5zQGhvdG1haWwuY29tOlNqb25uaWUzMiE=0x0D0x0A0x0D0x0A

     

    In the string of Button 2, i put:

    GET /api/sceneControl?id=16&action=start HTTP/1.10x0D0x0AHost: 192.168.178.410x0D0x0AAuthorization: Basic am9obnNjaGVwZW5zQGhvdG1haWwuY29tOlNqb25uaWUzMiE=0x0D0x0A0x0D0x0A
    GET /api/sceneControl?id=18&action=start HTTP/1.10x0D0x0AHost: 192.168.178.410x0D0x0AAuthorization: Basic am9obnNjaGVwZW5zQGhvdG1haWwuY29tOlNqb25uaWUzMiE=0x0D0x0A0x0D0x0A

     

    but it doesn`t work

    when i push 1 of the 2 options, there is nothing responding

     


     

    Please login or register to see this attachment.

    Edited by johnschepens

    Share this post


    Link to post
    Share on other sites
    • 0

    It's not exactly what I meant. You need to change global variable by VD..  and to add global variable as condition in scenes.

    Scenes should continue to be triggered by temperature change (depends on "atHome" variable)

    Please create global variable "atHome" and download attached VD as an example. (If it doesn't work your probably need to add correct  Authorization )

    In block scenes  add condition of "atHome" variable.

    Please post your block scenes if you need help to add condition.

     

    Please login or register to see this attachment.

    Edited by cag014

    Share this post


    Link to post
    Share on other sites
    • 0

    I have imported your script in VD, but I don`t know where I add condition of "atHome" variable block scenes.

     

    You`ll see in my Blocks: Temperature 1 is activate the switch 1 when it`s below 18 degrees.

    Please login or register to see this attachment.

    Share this post


    Link to post
    Share on other sites
    • 0

    Here is an example of block scene with variable

    Please login or register to see this spoiler.

     

    Share this post


    Link to post
    Share on other sites
    • 0

    Thank You for the screenshots of the settings
    I made the folowing scenes:

    athome: with a scene for activate the power <18 degrees and a scene for deactivate power at >22 degrees
    away:  with a scene for activate the power <12 degrees and a scene for deactivate power at >16 degrees

     

    I have now 2 Global variables: atHome an away


    I also put the authentication in the VD and the IP and port ( 127.0.0.1 and 11111)

     

    but something goes wrong.......the scenes are not responding

     

    is it perhaps strings in the VD?

    i paste the screenshots of my settings

    Please login or register to see this attachment.

    Please login or register to see this attachment.

    Please login or register to see this attachment.

    Please login or register to see this attachment.

    Please login or register to see this attachment.

    Please login or register to see this attachment.

    Share this post


    Link to post
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Answer this question...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.


    ×
    ×
    • Create New...