Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 0

FIBARO Smart Home Bot - feedback


T.Konopka
 Share

Question

Users!

 

We're happy to announce FIBARO Smart Home Bot integration.

The integration allows users to control FIBARO Home Center with Facebook Messenger .

A user simply send commands as messages in a conversation, just like the ones you send to your friends on Facebook Messenger.

 

Useful links:

FAQ:

Please login or register to see this link.

Configration:

Please login or register to see this link.

Commends:

Please login or register to see this link.

Link to comment
Share on other sites

9 answers to this question

Recommended Posts

  • 0

It works for me. It's shame it does not support CZ, since i see main use-case to control home, while on chat with Friends. Everything in one app. Atleast for me it is advantage.

 

@T.Konopka, can you ask team responsible for this Bot, if it is possible to send some notification through Messenger? Now we practically must connect Fibaro to inernet to use it properly, then this could substitude SMS.

Link to comment
Share on other sites

  • 0

When you do 'List scenes' - does it list your LUA scenes? Anyone?

Link to comment
Share on other sites

  • 0
13 minutes ago, Ros said:

When you do 'List scenes' - does it list your LUA scenes? Anyone?

Just says “sorry something went wrong.....” for me

Link to comment
Share on other sites

  • 0

Hmmm interesting. It list only one scene in my case. I have about 15 scenes and 5 of them in blocks.

Link to comment
Share on other sites

  • 0
  • Inquirer
  • The BOT lists scenes properly, but:

    1. It does not include special characters in the names of the scenes - it simply omits the special character

    2. Does not list LUA scenes, only Magic and Block. @jakub.jezek , all of them were listed for me.

     

    Devices are listed properly as well, including special characters.

    Devices that may not be listed are remotes such as The Button.

     

    All of this will be reported by me.

     


    On 8/7/2018 at 2:51 PM, drboss said:

    I have the problem if two or more controllers added to one cloud account. It's possible to chose only first controller.

     

    1. Sending fist command:
    > List Home Center devices.
    2. Answer:
    >2 home center devices found. Please choose the number from the list. Number 1. HCL-023923,  Number 2. HC2-025252.
    3a. Command for select first controler:
    >Set home center device to the number 1
    4a. Result
    >Home center selected. How else can I help you?

    3b. Same 1, 2 for second controller and:
    >Set home center device to the number 2
    4b. Result
    >I wasn’t able to select Home Center. How else can I help you?

    I checked this on my account. Two gateways: one on 4.510 one on 4.180. I selected them properly using only numbers, so the command looked like this:

    1. List home center devices

    > 2 home center devices found. Please choose the number from the list. Number 1. HC2-032929, Number 2. HC2-022377.

    2. 2

    > Home center selected. How else can I help you?

    3. List devices

    > Here you go, available devices: switchable: 190 thermostats: None cameras: None dimmers: 190 door or window: None programmable devices: 190

     

    Link to comment
    Share on other sites

    • 0

    hi all,

    @T.Konopka

    what do you think about this,

    I have same issue with IFTTT "options unavailable"

    and with smart home bot

     

    connexion bitween IFTTT, fibaro id OK, internet ok

    connexion bitween smart home bot, fibaro id OK

    it liste my device but can't discover any device ....

     

    regards,

    Lahoucine.

    Please login or register to see this attachment.

     

    ADMIN'S NOTE: Please, add the image as in the guide

     

    Edited by T.Konopka
    https://forum.fibaro.com/topic/30009-how-to-properly-attach-images-and-clips-to-your-posts/
    Link to comment
    Share on other sites

    • 0

    @T.Konopka, sorry but for me didn't work.

    1. List Home Center devices

    > 2 home center devices found. Please choose the number from the list. Number 1. HCL-023923, Number 2. HC2-025252.

    2. 2

    > I wasn’t able to select Home Center. How else can I help you?

    the same if I answer like in manual: Set home center device to the number 2.

     

    but for:

    1 or  "Set home center device to the number 1."

    work fine

     

    I deleted and added my HC's to fibaro cloud account, any positive results.

     

     

     

    Update!

     

    @T.Konopka I founded place of problem. It is not possible to select HC2 in BOT  if is the master of two HC. In my case device 2 (HC2) is master and device 1 (HCL) is slave (it's clear ;))  After delete the link in HC2 configuration panel  all  work fine, but after devices was linked the master device disappears.

    It's acceptable that slave device disappears but why is possible to select slave and not select the master???

     

     

    Update 2!

    I was happy 10 minutes.
    The problem has returned. I can not choose device 2 again.
    As I choose 1 it does it quickly. If I choose 2, it waits 30 seconds or more and returns an error: I wasn’t able to select Home Center. How else can I help you?

    Edited by drboss
    Link to comment
    Share on other sites

    • 0
  • Inquirer
  •  

    @Lahoucine , can you try logging in to the BOT while in local network? And then try using the BOT. It's just a guess.

     

    @drboss , to sum up:

    1. You have to Home Centers - HC2 as Master and HCL as Slave. Both are linked to the same FibaroID. First is HCL that works as a slave, the second one i HC2 working as a master.

    Please login or register to see this spoiler.

    No issues. I checked this on Facebook with 2 different languages: English (USA) and Polish. Works on both. Checked on computer in local WiFi and on smartphone on LTE. Works as well :/

     

    I'm honestly out of ideas :(

    I'll report it anyway, but without reproduction on my side. Maybe the dev or QA team will be able to reproduce it.

    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Answer this question...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

     Share

    ×
    ×
    • Create New...