Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 2

Netatmo - Fibaro HC2


FELIPE
 Share

Question

I'm having a problem linking my weather station to my HC2.

Following the tutorials found I have performed the following procedures;

1- Creation of the app (netatmo), as seen in the image netatmo 01 and netatmo 02.01
2- Install the plugin in the HC2
3- Copy the client id and secret in the requested fields.
4- Complete the username and password of my netatmo account in the other requested fields.

When recording the data does not connect from my weather station.

What am I doing wrong? I need some more step?

When creating the app and being activated, I receive emails every 10 minutes of netatmo indicating that the app is trying to access my account with incorrect data and that the account will be temporarily blocked for 10 minutes. This may have something to do?

Only by deactivating the app in the option as seen in the image netatmo 02.01, I stop receiving the alert emails.


Thanks in advance to those who can help me with this problem

 

Please login or register to see this spoiler.

 

Link to comment
Share on other sites

Recommended Posts

  • 0

I have also “not connected”

I removed the plugin

created a new app in dev.netatmo.com

installed the and configure the plugin 

still “not connected”

HC2 version 4.511 Beta

Link to comment
Share on other sites

  • 0

I have the same Pb: not connected. I've checked the API and it works, I can get some logs, etc. One remark: the Netatmo plug-in of Fibaro could connect and recover station's data while I was in Fibaro release 4.510. I'm in 4.511 and I wonder if the beta update is not the cause. I will try to reload 4.510 and see what happends. Cheers

Hi,

I just installed the back-up in 4.510 and Netatmo plug-in restart and collect data from the station and I have the message: your account is connected. So, maybe there is a bug in 4.511 Beta regarding the Netatmo plug-in connection via API.

I'll keep you updated if the plug-in stops. No news, good news. Cheers

Link to comment
Share on other sites

  • 0

Hi there!

 

We have identified some issues with the Netatmo plugin in our latest firmware version.

 

It is to be fixed in the upcoming beta releases.

 

 

Link to comment
Share on other sites

  • 0

Sorry to inform you but the plug in not totally functional. For thermostat is not working and I do not know way. Please do something in order, first, to read and change in real time parameters and, second, to be used also in various scene

Link to comment
Share on other sites

  • 0

Hi,

 

I have to inform that in 4.512 Netatmo plugin starts working except for the wind gauge. The wind gauge data may be very helpfull in various scenes. Thank you in advance

Link to comment
Share on other sites

  • 0

I updated to 4.520. Netatmo plugin works. however, rain gauge data are not collected and anémomètre is not even seen.

Netatmo api works fine and I can see my station with all modules working in Weather Pro.

I have no netatmo thermostat so I cannot give a feedback on this item. cheers

Link to comment
Share on other sites

  • 0

I still have the problem.

For me it was not with the version 4.510, 4.511, 4.512 and currently not with the 4.520.

can someone help?

Link to comment
Share on other sites

  • 0

Hi,

 

I confirm, Netatmo plug-in works partially for the weather station in 4.520 release. You have to create a related API in dev.netatmo.com and copy/paste the id and the code in Fibaro plug-in. Do not miss the activation of the API - click "ACTIVATE" button in APP status menu. You shall get "your account is connected" for Netatmo plug-in in Fibaro.

Something in addition, I touch base with Netatmo support center and they provide some firmware  update for weather station. I have now the following frimware version:

- Ext module - 46

- Int module - 44

- Rain gauge - 8

- wind gauge - 19

- Int base (big) module - 137

Not sure if that has an impact over plug-in communication but, it worth checking. Still, rain and wind gauges data are not recoverd in Fibaro plug-in

Again, I don't have Netatmo thermostat so, I cannot state about. cheers

Link to comment
Share on other sites

  • 0

Hi Guys,

 

the problem was probably due to my Netatmo password. As a special character I had in the password a +
Fibaro can not handle that. After changing the special character into a ! I had a connection immediately.
Maybe that can be a test if the connection is then gone to confirm that. The special character was at the last place of my password.

 

I am happy.

 

my english is bad, so translated with google

 

greeting
Tucher

Link to comment
Share on other sites

  • 0

HI,

 

Some  know how to add Netatmo wind controller to Fibaro Center lite 4.530 ?

Station works good :)

Link to comment
Share on other sites

  • 0

hi,

No, I couldn't have the wind gauge recognized either. The rest of the station works with the exception of rain gauge. The plugin included it but no data collection. 

I took advantage of a VD Netatmo published in this forum and this works fine for me. I still need to exercise the data recovery for some scene but that's the fun.  I think I'll drop the plugin soon.

 

cheers

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...