Jump to content
Guides for the Forum Read more... ×
Poradniki na Forum Read more... ×
FIBARO Home Center App 1.0.0 - release Read more... ×
FIBARO Home Center App 1.0.0 - wydanie Read more... ×
  • 0
cyrilphoenix

Roller Shutter 3 calibration and working issues

Question

Hello,

I'm starting to use fibaro modules with my first FGR-223 Rolling Shutter 3 and I've some problems.

 

- Zwave integration in Jeedom OpenZ-wave plugin is OK, I can reed or set all parameters/values

- Calibration is done, by setting 150 to force calibration, move up, down, up, calibration success and value come in parameters 156 and 157

- Full opening/closing working by physical button and zwave command

- Electrical configuration is Toggle switch

- Zwave stop command is working

 

but 

 

- Position always return 0 or 99, never 50 for example

- Zwave commande class 38 with "type=setvalue&value=50" to open shutter at 50% not working, it goes always to full opening or closing

- Physical button neutral position don't stop the shutter

 

> all is like calibration is not good 

 

Can you help me ?

Share this post


Link to post
Share on other sites

11 answers to this question

Recommended Posts

  • 0

Dear users,

 

  I also be confronted to a level position problem like described on my post : 
 

  

 

 

It's same than yours my problem ?

 

Share this post


Link to post
Share on other sites
  • 0

I am having the same issue. Install and calibration seen to work fine but I am unable use any position but 0 or 99. I am using this device with the HC2.

Share this post


Link to post
Share on other sites
  • 0

@lharmon the topic starter does not use a HC2 so he will have a totally different view and different issues...

 

But I don't mind.

 

We have to start somewhere..Check parameter 150

 

0 – roller blind (without positioning)

1 – roller blind (with positioning)
2 – Venetian blind (with positioning)

3 – gate (without positioning)

4 – gate (with positioning)
5 – roller blind with built-in driver
6 – roller blind with built-in driver (impulse)

 

Also check 

156. Time of up movement

157. Time of down movement

 

Be careful, time is multiples of 0.01 so 600  means 6 seconds.

 

 

 

Share this post


Link to post
Share on other sites
  • 0
  • Inquirer
  • Thanks for your response so :

    - parameter 150 is in the good value (roller with positionning)

    - parameter 156 and 157 have correct value with your conversion and theses values was set automaticly by calibration 

     

    calibration is write as done but I can't move my shutter directly to 44% for example and the feedback return always 0 or 99

    to finish, release my physical toggle button don't stop the shutter

    Share this post


    Link to post
    Share on other sites
    • 0
    9 minutes ago, cyrilphoenix said:

    All same :(

     

    Thank's for trying.

     

    I'll do my best to help you but I'll tell you upfront... This is the first time I'm trying to help someone with new FGR-223 - so it is also quite new to me. I do know the module quite well but I have not done any remote diagnosis yet, so please bear with me... :unsure:

     

    I'm going to think out loud to see if I have missed something.

     

    • You run calibration. I expect it to have worked. You do not say you saw it do up, down, and up again but the parameters make sense so that should have worked.
    • The switch cannot be the problem, it is not connected anymore.
    • It does appear to go in the right direction, or is it reversed? You do not mention that
    • There was an issue with templates... I think you might need to update to 4.530 then do "soft reconfigure" of that module.

     

    Let's pick something.

     

    Right... Are you running HC FW 4.530?

    Share this post


    Link to post
    Share on other sites
    • 0
  • Inquirer
  • Don't worry I appreciate your help ;)

    So calibration run good up, down, up and parameter 150 goes after that to is calibrated 

    I have value in 156 and 157 like 2600 so 26s is right

    I don't now exactly which wire of motor is up or down so with my connection I change the parameter for inverse the output

    Now switch is disconnected 

     

    For firmware update I can't to it because my domotic system is not HC is Jeedom

    Share this post


    Link to post
    Share on other sites
    • 0
    2 minutes ago, cyrilphoenix said:

    because my domotic system is not HC is Jeedom

     

    Ah, sorry, got confused by post of @Funmsa

     

    Controller might have a problem with up/down meaning and what 0 - 99 on the slider means.

     

    3 minutes ago, cyrilphoenix said:

    I don't now exactly which wire of motor is up or down so with my connection I change the parameter for inverse the output

    That is one of the nice features of the FGR-223 compared to the older model, you can swap both outputs and inputs to mean the right thing.

     

    One last try for remote operation: try mode "5 – roller blind with built-in driver" - it uses timer mode exclusively (no load == no end switch detection). No calibration, just changing that mode.

     

    If that does not work, let's try to get the switch(es) working then. Question: 

    On 1/5/2019 at 4:13 PM, cyrilphoenix said:

    Physical button neutral position don't stop the shutter

     

    So it has 3 positions, does it have a spring to return to the middle position. Does "up" really move "up" and "down" moves downward? I assume everything is OK because you say you have selected toggle switches (p 20: 1 – toggle switches).

     

    Is it possible that the "middle" connection of that switch is actually connected to S1 or S2, so one of the connections got swapped? Can you check with a multimeter?

     

     

    Share this post


    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

    ×