Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 1

RGBW Controller 2 problems with Smartthings


Sglauberman
 Share

Question

I recently purchased a Fibaro RGBW controller 2 along with a power supply and an RGBW light strip to work with my SmartThings hub. I wired everything up and I got it to work but not very well. Here are the problems:

 

1. When I tried to add it to my Smartthings hub, I had to press the Service button three times several times before the device was found. However, the device that it thought was found was the Aeon LED Bulb. Is that correct? Should it not see something called Fibaro RGBW Controller?

 

2. When it pairs the “Aeon LED Bulb” to Smartthings, it initially says the device is of even though it is off. It never seems to get the correct off/on status and when I try to turn it on or off it will usually work but the status always says “Turning off/on” and never updates to off or on. I did this with the device literally 5 feet from the hub. I have a whole house full of z-wave devices attached to my Smartthings hub from various manufacturers and they all work fine.

 

3. I updated the device driver with the Fibaro device driver for the RGBW Controller and I also tried a third party device handler, and while I can kind of get the led strips to turn on/off and change color, it is typically very slow and the on/off status is never correct.

 

So, is there something I am doing wrong? Is the controller defective? My hub is a V2 and has up-to-date firmware. I reset the Fibaro controller several times (after removing the device) and tried to add it again but I always have the above problems. Any help would be greatly appreciated.

Link to comment
Share on other sites

6 answers to this question

Recommended Posts

  • 0

Well this is timely. I just purchased the exact same controller and have the same experience. I haven't tried any other handlers but my Fibaro also shows up a "Aeon LED Bulb" and the On/Off doesn't appear to work, I can't even get my light string to light up. I have removed/reset the device a couple times now. I guess I will try to use a different handler but I am very confused as I bought this device because it said it had SmartThings support. I also have v2 hub.

Link to comment
Share on other sites

  • 0

Ok I was able to get everything working I used the

Please login or register to see this link.

. I tried the

Please login or register to see this link.

and I was able to get my lights to work but Alexa couldn't set the lights to blue. If I ask it to change the lights to blue it turns them red instead. (Asking it do Green or red works fine). This seems to be a

Please login or register to see this link.

. You might find it to be "slow" but that because by default the handler wants to "fade" to the new color over 3 seconds (you can change this from within the SmartThings, Classic at least, app). I also attempted to use the 2 default Fibaro RBGW handlers (the ones that show up in the IDE) but those didn't work for me.


In summary

 

Official Fibaro: Works with ST and Alexa, I can make it fade faster by changing the "10" to "1" (The first setting when you edit the device in the Classic app)  OR you can find "SCALE" in the options and change it to "SET" (sidenote: why don't people add labels‽‽....)  That didn't work, if someone finds a way to make it instant I would love to know.

 

Codersaur: Works with ST but Alexa can't turn them blue. I was able to make it change colors instantaneously by switching the option from "scale" to "set"

 

2 Fibaro handlers that show up in the IDE: Couldn't get them to do anything

 

Default Aeon LED: Couldn't get this to even turn on my strip

Edited by joshstrange
Link to comment
Share on other sites

  • 0
On 1/22/2020 at 7:46 AM, joshstrange said:

Ok I was able to get everything working I used the

Please login or register to see this link.

. I tried the

Please login or register to see this link.

and I was able to get my lights to work but Alexa couldn't set the lights to blue. If I ask it to change the lights to blue it turns them red instead. (Asking it do Green or red works fine). This seems to be a

Please login or register to see this link.

. You might find it to be "slow" but that because by default the handler wants to "fade" to the new color over 3 seconds (you can change this from within the SmartThings, Classic at least, app). I also attempted to use the 2 default Fibaro RBGW handlers (the ones that show up in the IDE) but those didn't work for me.


In summary

 

Official Fibaro: Works with ST and Alexa, I can make it fade faster by changing the "10" to "1" (The first setting when you edit the device in the Classic app)  OR you can find "SCALE" in the options and change it to "SET" (sidenote: why don't people add labels‽‽....)  That didn't work, if someone finds a way to make it instant I would love to know.

 

Codersaur: Works with ST but Alexa can't turn them blue. I was able to make it change colors instantaneously by switching the option from "scale" to "set"

 

2 Fibaro handlers that show up in the IDE: Couldn't get them to do anything

 

Default Aeon LED: Couldn't get this to even turn on my strip

Did any one get a working DH for this RGBW controller 2

Link to comment
Share on other sites

  • 0
On 1/21/2020 at 9:46 PM, joshstrange said:

Ok I was able to get everything working I used the

Please login or register to see this link.

. I tried the

Please login or register to see this link.

and I was able to get my lights to work but Alexa couldn't set the lights to blue. If I ask it to change the lights to blue it turns them red instead. (Asking it do Green or red works fine). This seems to be a

Please login or register to see this link.

. You might find it to be "slow" but that because by default the handler wants to "fade" to the new color over 3 seconds (you can change this from within the SmartThings, Classic at least, app). I also attempted to use the 2 default Fibaro RBGW handlers (the ones that show up in the IDE) but those didn't work for me.


In summary

 

Official Fibaro: Works with ST and Alexa, I can make it fade faster by changing the "10" to "1" (The first setting when you edit the device in the Classic app)  OR you can find "SCALE" in the options and change it to "SET" (sidenote: why don't people add labels‽‽....)  That didn't work, if someone finds a way to make it instant I would love to know.

 

Codersaur: Works with ST but Alexa can't turn them blue. I was able to make it change colors instantaneously by switching the option from "scale" to "set"

 

2 Fibaro handlers that show up in the IDE: Couldn't get them to do anything

 

Default Aeon LED: Couldn't get this to even turn on my strip

 

That's strange, the DH in the official documentation is for Fibaro RGBW Controller (FGRGBW-441), NOT for Fibaro RGBW Controller 2 (FGRGBW-442). The DH code clearly only has the fingerprint identification for the  441. I also installed that DH as it is the best we have so far, but it really doesn't work for me. I cannot change color, the color picker tool jumps randomly after I set a value, worst of all the whole device seems to just stop working after like 5 minutes and I have to unplug it. I am very disappointed, I expected it to work out of the box, or at least I expected I could get it work with a little fiddling. I certainly did not expect it to be unusable with ST...

Link to comment
Share on other sites

  • 0

Hi guys! I have the same problem - not able to change colors. Did anyone resolved this in the mean time?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...