Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 0

103 devices and full stop...


tortho
 Share

Question

HC3 FW. 5.020.60

 

Well managed to get to 103 devices.

Unit got slower and slower for the last 10-20 devices.(Same as my old HC2)

Slow to get HC into inclusion mode

Failures when including (not configured or not initiated at all)

Now it is at a full stop. Not able to include, not able to exclude and not able to delete.

 

Any advice except fibaro support which might take time?

@A.Socha

Edited by tortho
Link to comment
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Hi @tortho ,

 

Sorry to hear that you have problems with both HC2 and HC3. I have HC2 with firmware 4.580 and included 109 z-wave devices. My HC2 system is running 80 virtual devices with main loop running all the time and 30 and more scenes of which one is running while the rest as needed. Sometimes have up to 10 Very Smart Light scenes running at the same time and still all is responsive and without delays. Also many of VD's and scenes communicate with internet servers and with many devices on my local network.

 

Here is CPU usage when everything is running:

Please login or register to see this spoiler.

 

Ah, yes, my

Please login or register to see this link.

for HC2 can be easily stopped and restarted when needed. I do stop everything when adding/deleting devices from z-wave to have more resources left for inclusion, deleting and/or reconfiguration of devices. Those actions are then executed fast and reliable even if there are more than 80 devices already included.

 

Notice short peaks on CPU usage when no code is running. That peaks are caused by HC2 software most probably related with z-wave. They appeared after I included around 60 z-wave devices. I try to to find out what is causing them, but I didn't manage. Despite those spikes in CPU usage system still works perfectly fine when everything is up and running.

 

I suggest that you definitely read following post from @amilanov

Please login or register to see this link.

 

Also some knowledge about z-wave networks is highly recommeded! Knowing how z-wave works can help in building relatively big network that will work reliable and without problems. Also, then you will know what to expect and won't be disappointed, but will quickly find solution. I consider all z-wave networks with more than 80 included devices as big ones where fine tuning of device parameter settings is needed to reduce unnecessary traffic. Also having Zniffer is highly recommended for big networks. In my opinion when building home automation with z-wave users have only one of this two choices:

  • to learn about z-wave before start expanding system above 50 devices and also get Zniffer
  • or to get help from installer to build and tune up z-wave network

BTW This is valid not only for Fibaro system but for all systems that use z-wave.

 

Regarding help, I have already suggested where to look and what to read. Asking Fibaro support also is an option, but I would not expect any miracles. Anyway new HC3 firmware update should be released soon.

 

As you can see my post is much longer than yours and it is you who have problems not me :-) Since you were short on words I would normally have tons of questions first, before even trying to help, but since I'm busy coding UHAS will skip that this time.

 

Link to comment
Share on other sites

  • 0

I had the exact same problem as you. I was literally wasting hours to add 2-3 devices. Going mad in the process. When the devices finally added they were more likely than not corrupted and then I had to waste hours deleting and readding. In the end I couldn't add or delete any devices any longer.

 

I was about to throw out both my HC2 and move to something else, fortunately some of the forum users came to the rescue. Yes, you can reach out to support, but based on my experience you will not get any answers that you need. Still try it, maybe it's just long time users of Fibaro that have bought over 200 Fibaro modules that are ignored, perhaps you haven't reach that mythical spot yet and they will help you out... perhaps.

 

Until then, do what @Sankotronic said, read the post I wrote. Also, bite the bullet and buy a zwave sniffer ASAP. 

 

I am pretty confident that if you follow the post your system will be back up and running smoothly. I'd be surprised if not and would like to understand more of what is not working once you have lifted the lid and seen what's actually happening inside.

Link to comment
Share on other sites

  • 0
  • Inquirer
  • Thank you both for the replies :-)

     

    I have Fibaro support on the case and it seems to be 2 parts:

    Sent this to fibaro today:

    "

    1. Unresponsiveness of the UI (slower the more devices added)
    It seems that it does not pop-up the message panel in the bottom when pressing inclusion/remove and/or sometimes it does not write any messages.
    Example: I can press exclude, nothing happens on the screen, I can tripple click one device. After a while I will see the green popup message in the bottom left which says device has been removed.
    During this whole period no message section in the bottom has appeared.
     
    2.HC3 end up with several Unconfigured devices. 
    Reconfigure does not work, either stalls and stay there forever or fails.
    Exclude and re-include gives the same initial "broken" state.
     
    This is for example:
    Several Fibaro universal binary sensors appearing unconfigured and as motion sensor
    Fibaro door sensor appearing inconfigured and as motion sensors
    Aeotech doorbell 6 appearing as just main device and unconfigured
    Aeotech Siren 6 appearing as just main device and unconfigured
     
    Attached picture of device excluded and included today. Ends up as unconfigured motion whilst the device is old type fibaro door sensor

    "

     

    From the years of HC2 I had the following experience

    Little to not noticeable zwave lags (maybe a few occasionally)

    Very occasionally had a light or 2 which did not turn on as expected (triggered by motion or door sensor)

    Had a few occasional HC2 Freezes but not too many (Not more than expected when installing every update)

     

    But I had HC2 lags (UI), when looking at cpu, ram etc all was "fine", that means not peaking as it did on 2-3 bad firmwares during the years.

    Multiple attempts to include / exclude devices was normal when I got more devices

    The issues with inclusion/exlusion etc has been fixed twice on the HC2 by Fibaro support but have no idea what they have done.

     

    On the HC2 I had the sanity check script and did use that in combination with several of the tips like global polling, checking state prior to changing state in scenes/VD's, sleeps in main loops and other places where relevant, turnign off temperature reporting and other not used in some devices etc

     

    I used something from believe it was 10der to look at the network topology on the HC2 and it seems that most devices just had direct links to the HC2.

     

    Now all devices has been excluded from the HC2 and I could notice the UI and the responsiveness got quicker the less devices I had left.

     

    All devices (almost) now included in the HC3 starting from center and expanding to the outer edges.

    I have a Aeotech Zstick which I have now included and had a look on the network topology map and that was pretty red.

    I have installed 3 Aeotech range extenders in what I believe is strategic places.

    As far as I recall the network will build itself over time or do I have to use the rebuild mesh function?

     

    Purchased a zwave.me stick today and will then try to build the sniffer when it arrives...

     

    Assume here firmware of HC3 + possibly some db issues will fix this....

     

    Link to comment
    Share on other sites

    • 0

    OK, I take back what I said above. 

     

    I have not experienced what you have. My BUI didn't freeze up. My BUI worked fine, it was the actual physical inclusion / exclusion process that didn't work and it was due to too much traffic on the network. 

    Good luck! 

     

    And also didn't realise that you are using HC3. Missed it at the top of your post. 

     

    You may get support from Fibaro given its a HC3 related issue. I'm sure HC2 support is dead based on factual experience with them over the past 5 months. 

    Edited by amilanov
    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • Thanks, your post is useful and I will most probably get the zwave.me uzb to setup a sniffer today.

    I have read your lengthy post with loads of useful stuff earlier and have managed to reduce some traffic already.

     

    Fibaro came back yesterday and asked me to hold any more inclusion as there will be a firmware update at the end of this week which will solve many issues.

     

    Believe there is some issues in the background as well since I had same issues on both HC2 and HC3 when reaching high number of devices.

    (Some trash building up over time of inclusion and exclusion??)

     

    Anyway, it partly works now but slow and sometimes not respond.. half probably due to buggy UI

     

    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Answer this question...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

     Share

    ×
    ×
    • Create New...