Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 0
minsad79

Weatherflow HC3?

Question

Are there any examples of integration into Weatherflow HC3?

Or a quick app?

Share this post


Link to post
Share on other sites

19 answers to this question

Recommended Posts

  • 0

Hi @minsad79,

I didn't see your message earlier. Currently i'm working on a QA for WeatherFlow, but it's not ready yet to share.

Please login or register to see this image.

/monthly_2020_05/afbeelding.png.e02122331ae3273d3b872ada93c46674.png" />

I will post it when ready. :-)

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0
  • Inquirer
  • On 5/23/2020 at 5:09 AM, Bodyart said:

    Hi @minsad79,

    I didn't see your message earlier. Currently i'm working on a QA for WeatherFlow, but it's not ready yet to share.

    Please login or register to see this link.

    I will post it when ready. :-)

    hi Bodyart

    I saw your post

    This is a very nice solution.

    Thanks for your answer

    I'll wait for the post

    Share this post


    Link to post
    Share on other sites
    • 0

    Hi guys,

     

    My QA is working good too, but for internal use for now.

    I made virtual devices - for me it's more convenient.

    Also I'm using non-standard way to receive data.

    Standard way - get http requests from WeatherFlow cloud.

     

    Non-standard - to install UDP listener on RaspberryPi - it transfer all data locally to MQTT and I receive in QA from MQTT broker.

    wind data updates every 3 sec, other data - usually 60 sec, i't limitation of weatherstation itself.

    --

    Please login or register to see this link.


     

     

    Please login or register to see this attachment.

    • Thanks 1

    Share this post


    Link to post
    Share on other sites
    • 0
  • Inquirer
  • 3 hours ago, afendikov said:

    안녕하세요.

     

    QA도 제대로 작동하지만 현재는 내부 용으로 사용됩니다.

    나는 가상 장치를 만들었습니다. 더 편리합니다.

    또한 데이터를 수신하는 비표준 방법을 사용하고 있습니다.

    표준 방식-WeatherFlow 클라우드에서 http 요청을받습니다.

     

    비표준-RaspberryPi에 UDP 리스너를 설치하기 위해 모든 데이터를 로컬로 MQTT로 전송하고 MQTT 브로커에서 QA로 수신합니다.

    바람 데이터는 3 초마다 업데이트되며 다른 데이터는 일반적으로 60 초이며 기상 관측소 자체의 제한은 없습니다.

    Please login or register to see this link.

    :

    Please login or register to see this link.


     

     

    Please login or register to see this attachment.

    Can you post QA?

    There is a weatherflow connected to HA

    Share this post


    Link to post
    Share on other sites
    • 0

    @minsad79 are you ready to be betatester?

    do you have raspberry pi to install UDP listener or prefer http update?

     

    I'll try to prepare for release in a few days...

    Share this post


    Link to post
    Share on other sites
    • 0
  • Inquirer
  • 2 hours ago, afendikov said:

    @minsad79 are you ready to be betatester?

    do you have raspberry pi to install UDP listener or prefer http update?

     

    I'll try to prepare for release in a few days...

    Beta tester of course

    I have a nuc

    weatherflow install UDP listener install

    ready to release in a few days ...

    Share this post


    Link to post
    Share on other sites
    • 0
    Posted (edited)

    so, guys, could you please test it.

     

    I prepare short instruction and icons.

     

    BTW rain icons are great - they shows in mobile app and there is always knows what rain intensity at station.

     

    After testing I will upload it to Fibaro Marketplace.

     

    Thanks

     

    Please login or register to see this attachment.

    Edited by afendikov
    • Like 1
    • Thanks 1

    Share this post


    Link to post
    Share on other sites
    • 0
  • Inquirer
  • Posted (edited)

    Hi Ah Fendikov

    I tested your quick app

    udp or http

    Both work perfectly

    Perfect icon

    Weatherflow integration is perfect

    The manual is also perfect ....

    Thank you for your dedication

    Best fast app


    small problem

    Battery value is not displayed

     

     

     

     

    No it was my NUC problem

    Now the price comes out well

    sorry

    Please login or register to see this attachment.

    Please login or register to see this attachment.

    Edited by minsad79

    Share this post


    Link to post
    Share on other sites
    • 0
    Posted (edited)

    Hi all!

    Posting my test version of WeatherFlow QA.

    It's a different approach than @afendikov, without child devices, saving the values in global variables to be used as triggers elsewhere.

    Feel free to try :-D

    afbeelding.png.637b5e742dee3861a6f08d94ecdb35ed.png

     

    Please login or register to see this attachment.

    Edited by Bodyart
    New version of QA
    • Like 1
    • Thanks 1

    Share this post


    Link to post
    Share on other sites
    • 0
    12 minutes ago, Bodyart said:

    Hi all!

    Posting my test version of WeatherFlow QA.

    It's a different approach than @afendikov, without child devices, saving the values in global variables to be used as triggers elsewhere.

    Feel free to try :-D

    Please login or register to see this link.

    Please login or register to see this attachment.

    Nice work!

     

    Jim

    • Like 1

    Share this post


    Link to post
    Share on other sites
    • 0
  • Inquirer
  • 1 hour ago, Bodyart said:

    Hi all!

    Posting my test version of WeatherFlow QA.

    It's a different approach than @afendikov, without child devices, saving the values in global variables to be used as triggers elsewhere.

    Feel free to try :-D

    Please login or register to see this link.

    Please login or register to see this attachment.

    Bodyart

     

    Nice integration

     

    thanks

    • Like 1

    Share this post


    Link to post
    Share on other sites
    • 0
  • Inquirer
  • Posted (edited)
    4 hours ago, Bodyart said:

    Hi all!

    Posting my test version of WeatherFlow QA.

    It's a different approach than @afendikov, without child devices, saving the values in global variables to be used as triggers elsewhere.

    Feel free to try :-D

    Please login or register to see this link.

    Please login or register to see this attachment.

    Quick app doesn't work

     

    What mistake i made

    Can you advise?

     

     

    Please login or register to see this attachment.

    Please login or register to see this attachment.

    Edited by minsad79

    Share this post


    Link to post
    Share on other sites
    • 0
    Posted (edited)

    Hi @minsad79,

     

    sorry in a hurry to post this test version i didn't managed to make a manual yet. 😟
    The QA searches automatically for your station number it's not needed for user to configure. Your QA variable stationNo should be set to 1 for the first WeatherFlow station, 2 for the second etc. Btw. the current version supports only 1 station, but working on more stations and also on new Tempest.

    Thank you for asking :-D
    Please let me know if it works now :-)

     

    Edited by Bodyart

    Share this post


    Link to post
    Share on other sites
    • 0
  • Inquirer
  • 11 hours ago, Bodyart said:

    Hi @minsad79,

     

    sorry in a hurry to post this test version i didn't managed to make a manual yet. 😟
    The QA searches automatically for your station number it's not needed for user to configure. Your QA variable stationNo should be set to 1 for the first WeatherFlow station, 2 for the second etc. Btw. the current version supports only 1 station, but working on more stations and also on new Tempest.

    Thank you for asking :-D
    Please let me know if it works now :-)

     

    In the way you advised me

    Does not work

    Please login or register to see this attachment.

    Please login or register to see this attachment.

    Share this post


    Link to post
    Share on other sites
    • 0
    3 hours ago, minsad79 said:

    n the way you advised me

    Does not work

    Hi, @minsad79, I apologize for the nasty bug.
    The bug is corrected and original posting has new file.
    Just to prevent confusion posting the file here as well

     

    Please login or register to see this attachment.

    Share this post


    Link to post
    Share on other sites
    • 0
  • Inquirer
  • 3 hours ago, Bodyart said:

    Hi, @minsad79, I apologize for the nasty bug.
    The bug is corrected and original posting has new file.
    Just to prevent confusion posting the file here as well

     

    Please login or register to see this attachment.

    I installed a new QA as your advice.

    Some values do not appear

    Temperature, battery, etc. are not displayed

    Please login or register to see this attachment.

    Please login or register to see this attachment.

    Share this post


    Link to post
    Share on other sites
    • 0
    Posted (edited)

    Hi @minsad79,

     

    please, check your QA variable Api_key; your key seems to be too short (22 characters) - mine is 36 characters long. Probably is part of your Api Key missing...

    Your Api Key should look like: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx

    Let me know :-)

    Edited by Bodyart

    Share this post


    Link to post
    Share on other sites
    • 0
  • Inquirer
  • 15 hours ago, Bodyart said:

    Hi @minsad79,

     

    please, check your QA variable Api_key; your key seems to be too short (22 characters) - mine is 36 characters long. Probably is part of your Api Key missing...

    Your Api Key should look like: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx

    Let me know :-)

    My API key is 36 words

    I deleted the latter part to hide the information.

    Share this post


    Link to post
    Share on other sites
    • 0

    Hi @minsad79,

    i've checked and double checked the QA installed many times and it runs flawless out of the box. Also tested today on another HC3 machine :-)

    Still trying to figure out, what the problem at your side is. Maybe i can create a QA with extra debugging info to check the running on your system and send it in a PM to you.

    Share this post


    Link to post
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Answer this question...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.


    ×
    ×
    • Create New...