Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 0

Do OTA firmware updates work reliability enough to use


theuksbest
 Share

Question

Looking for the wisdom from the brave and experienced - i have loads of Fibaro device firmware updates to do, but not confident with using the OTA (over-the-air) function to run them. Also from a practical perspective the devices are spread all throughout the house so it’s not so easy to bring them all within a few meters of HC3.

 

  1. Has anyone had reliable results running firmware updates using HC3 OTA?
  2. Do the devices really need to be within a few meters of HC3?
  3. And what’s the worst that can happen if it fails?
  4. Any tips to consider if I’m going to try it?

 

Thanks!

 

Link to comment
Share on other sites

10 answers to this question

Recommended Posts

  • 0
5 hours ago, theuksbest said:

Has anyone had reliable results running firmware updates using HC3 OTA?

Yes,

Have a look here.

 

5 hours ago, theuksbest said:

Do the devices really need to be within a few meters of HC3?

Normaly not, but occasionally it can happen.

 

5 hours ago, theuksbest said:

And what’s the worst that can happen if it fails?

You get another shot at it.the device keeps working with the old firmware. I didn't have a broken device yet.

 

5 hours ago, theuksbest said:

Any tips to consider if I’m going to try it?

Click one update at the time. wait a few seconds after finishing the update. Go to the device, check if new firmware is displayed. Go to next update.

 

 

 

Link to comment
Share on other sites

  • 0
  • Inquirer
  • @Flash thanks for your thoughts. So I tried it, and actually couldn’t get it to work - it just sat at zero percent after pressing the update button. I tried a few different devices and different Device types but same experience.

     

    I even tried waking the devices up and making sure a couple of them were close to HC3 too. 


    anyone else had a similar experience to that?

     

     

     

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • Still not able to get OTA to work -> anyone have any other tips to try?

     

    It just stays like that forever, I tried pinging the device and pressing the "configure now" button under the device settings, plus a triple click from the switch, but with no luck.

     

    Please login or register to see this attachment.

    Link to comment
    Share on other sites

    • 0
    10 hours ago, theuksbest said:

    anyone have any other tips to try?

    Did you include them non secure??

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • @Flash I don’t remember now actually, and not sure how i find out now. I thought that might only matter for security devices, but not devices like Blinds? 

    Edited by theuksbest
    Link to comment
    Share on other sites

    • 0
    22 minutes ago, theuksbest said:

    and not sure how i find out now

    If you have an device you know its not included in security mode, then you could go to associations of that non security mode included device, and find the the device you want to upgrade.

    You can check the box devices with the same security level. If you don't find you're device you want to upgrade firmware, then its included in security mode.

    You don't set an association, but you can check if it's not included in secure mode.

    If you don't know for sure if you're device that you choose is included in  non security mode, you better exclude the device an include again without the security mode.

     

    Did you try to reboot the HC3?

    Are you logged in localy?

    Tried a softreconfiguration of the device wich you want to upgrade?

     

     

    Edited by Flash
    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • @Flash slow reply sorry!

     

    On 11/15/2020 at 12:52 AM, Flash said:

    Did you try to reboot the HC3?

    Yes i tried rebooting, didn't help

     

    On 11/15/2020 at 12:52 AM, Flash said:

    Are you logged in localy?

    Yes, is that the right way of doing it, i see the IP in the address bar so i'm assuming i am anyway.

     

    On 11/15/2020 at 12:52 AM, Flash said:

    Tried a softreconfiguration of the device wich you want to upgrade?

    Yep just tried that, no joy.

     

    so should the device be in security mode for it to work or not?

    And do i need to press the B button on the switches for example, as that would mean i need to remove the panel from the wall which would be a pain. I did try pressing the switch a few times to wake it up.

     

    any more tips would be great?

    Link to comment
    Share on other sites

    • 0
    21 minutes ago, theuksbest said:

    any more tips would be great?

    It seems that there are some issue's with the latest HC3 firmware and updating device's firmware.

    If you have the latetst firmware on you're HC3 you could downgrade, or wait for a new release.

    Link mentions a Heat Controller. But I see similar posting on other devices.

    Did some Black Friday shopping had some problems adding some devices. Had to try 3 or 4 times.

    Scene's do behave strange after reboot. Scene's executed even if Conditons of scene's not met. Problem dissapears if the HC3 is online for a few hours.

     

     

     

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • Ok - so actually i've been able to get it to work, thanks for pointing me to the "firmware update forum" i didn't realise there was one.

     

    However, although i got it working it's not as it should be!!

     

    I had to press the update button, the progress bar doesn't work, and watch out for the Current Version status to change to latest version. Then Cancel the update process, go to the device and run the soft re-configure. The it works in updating the version. If I don't cancel the update and run the soft re-configure, then when i try the next one it queues it instead, presumably because the system still thinks its running the last upgrade still, then i have to reboot.

     

    Get these are all bugs, glad i was able to find a work around for now though.

     

    thanks for you help

    Link to comment
    Share on other sites

    • 0
    11 hours ago, theuksbest said:

    thanks for you help

    You're welcome, I'm happy it worked out for you, even if I ddin't provide a complete solution, on  to the next challange .?

    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Answer this question...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

     Share

    ×
    ×
    • Create New...