Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 0

Configuring devices via HC3


Bernhard Stockman
 Share

Question

I am tryinbg to configure a Qubino Smart Meter via HC3->Devices->Device Configuration.

There are three options possible

 

Read configuration

Reconfigure Device

Soft reconfiguration.

 

If you do a "read configuration" the HC3 answers: "Device configuration read successfully" but does not show the configuration at all.

Is it stored somewhere? The same goes for the configuration options just telling me that the device was successfully configured 

but does not give any possible way of doing the configuration myself.

 

I also asked Qubino about this and they showed me how this is done using the HC2 sending a gif (see below).

Is there something similar in HC3 or is this, as so many other features in HC2, for future releases in HC3?

 

Please login or register to see this attachment.

Link to comment
Share on other sites

12 answers to this question

Recommended Posts

  • 0

To associate a device with one or more other devices as your example shows, do so under its Associations menu.

But if I understood you correctly, you wanted to know how to configure your Smart Meter.


If you do not find any parameters under the device's menu "Parameters", it means that Fibaro has not entered a template for that particular device. 
If there are no parameters, you can add them yourself with "Add parameter".

You then enter the parameter number, specify the size (number of Bytes) and what value the parameter should have and press "Save". Leave the other settings as they are.
The parameters can be found on the device data sheet.


Once you have entered the parameters you want, you can then change them if necessary.
The "Read configuration" command under the "Device configuration" menu only works if you have some parameters entered and can then retrieve the value the device is configured with.

Link to comment
Share on other sites

  • 0
  • Inquirer
  • The parameter section of this device is empty. Before adding any parameter I would like to read the parameters to

    se what they are set to before starting to change them. But, as mentioned above, clicking the tab "Read parameter configuration"

    under Device -> Device Configuration gives you the happy message "Device configuration read susscessfully" whithout showing

    any of these results.

     

    Same thing with Parameters. Clicking the "Pull parameters values" result in nothing.

     

    I assume that Fibaro will continue to develop the HC3. Is there any official plan for this development?

    Link to comment
    Share on other sites

    • 0

    (from API point of view) you can't read not yet defined parameters, you have to define them first (normally "read only", in real rare case as "default value" first before "read only" can be used). You can't set as well (e.g. from scene) not yet defined parameters, sometimes one have modules with templates (like Aeotec MS6) which covers whole range of firmware versions, but it does not support all available parameters (in such canse one need to unselect "use template", add the extra parameter, set value and save).

     

    Pull parameters is zwave specs extra feature, which need to be supported by the module itself, which is only valid for really very few products with latest zwave SDK.

    Edited by tinman
    Link to comment
    Share on other sites

    • 0

     Qubino .. yeah, the never ending story with "exclude a bit to change device functionality" :P 

    Edited by tinman
    Link to comment
    Share on other sites

    • 0

    These are the parameters for Qubino Smart Meter GOAEZMNHTD1
    If you add your parameters without entering any value, the value must be updated with the value of the unit when you save each individual parameter.

     

    Parameter 7: Size: 1 Byte, Default Value: 4
    Parameter 10: Size: 2 Byte, Default Value: 255 Only for older Version!
    Parameter 11: Size: 2 Byte, Default Value: 0
    Parameter 12: Size: 2 Byte, Default Value: 0
    Parameter 13: Size: 2 Byte, Default Value: 0
    Parameter 14: Size: 2 Byte, Default Value: 0
    Parameter 40: Size: 1 Byte, Default Value: 5
    Parameter 42: Size: 2 Byte, Default Value: 0
    Parameter 45: Size: 1 Byte, Default Value: 0
    Parameter 100: Size: 1 Byte, Default Value: 0
    Parameter 110: Size: 2 Byte, Default Value: 0
    Parameter 111: Size: 2 Byte, Default Value: 30
    Parameter 112: Size: 1 Byte, Default Value: 0
    Parameter 130: Size: 4 Byte, Default Value: Serial Number (Read Only)

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  •  

    Thanks RH_Dreambox for the help. I tried it and it worked very well. Howerver this gets even more confusing.

    As I have mentioned I have three smart meters. In two of these devices I got the following view on parameters

    where I manually set parameters:

     

     

    Please login or register to see this image.

    /monthly_2020_12/693743285_SmartMeter2.jpg.652aa4997ed25af39e1bcaa6bf34d4a2.jpg" />

     

    BUT, on the third Smart Meter I got the following view without haveing adding anything manually:

     

    2097662823_SmartMeter.jpg.ba2409bad77bdb51d24d09194185960d.jpg

     

    Obviously there exist a template but it is only attached to one of the Smart Meters. Furthermore the parameter 42 is set to 0 which

    means it will not report att all. The other two has the default value of 600 seconds. This was why I returned to configure a polling interval

    of 300 seconds as I got nothing form the third Smart Meter. This explains why. As you see above the Use template for parameters

    box i clicked and suddenly you options for chosing device to copy the configuraion. If  I click the same field in the other two Smart Meters

    nothing happens. The save button is grayed out so I can do nothing. Closing and reopening the Parameter section the Use template

    box isi again not clicked.

     

    So, still very confused with this interface.

     

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  •  

    Thanks RH_Dreambox for the help. I tried it and it worked very well. Howerver this gets even more confusing.

    As I have mentioned I have three smart meters. In two of these devices I got the following view on parameters

    where I manually set parameters:

     

     

    Please login or register to see this image.

    /monthly_2020_12/693743285_SmartMeter2.jpg.652aa4997ed25af39e1bcaa6bf34d4a2.jpg" />

     

    BUT, on the third Smart Meter I got the following view without haveing adding anything manually:

     

    2097662823_SmartMeter.jpg.ba2409bad77bdb51d24d09194185960d.jpg

     

    Obviously there exist a template but it is only attached to one of the Smart Meters. Furthermore the parameter 42 is set to 0 which

    means it will not report att all. The other two has the default value of 600 seconds. This was why I returned to configure a polling interval

    of 300 seconds as I got nothing form the third Smart Meter. This explains why. As you see above the Use template for parameters

    box i clicked and suddenly you options for chosing device to copy the configuraion. If  I click the same field in the other two Smart Meters

    nothing happens. The save button is grayed out so I can do nothing. Closing and reopening the Parameter section the Use template

    box isi again not clicked.

     

    So, still very confused with this interface.

     

    Furthermore. I have now set all Smart Meters to report every 300 seconds and disabled all polling intervalls.

    If it will work as I assume I should now get a report avery 5 minutes from all three Smart Meters. However,

    in this work environment, I believe it when I see it. ?

     

    Link to comment
    Share on other sites

    • 0

    Yes it may seem confusing, but it can be as simple as you have different version numbers on your "Smart meters".
    If you look for each unit under the tab "General", you will see which version number each unit has.

     

    Then you will probably see that there are different version numbers, and Fibaro has then chosen to create a template for only one of these versions.
    You can also see this under the "Advanced" tab and "Parameters template:". If there is a number, Fibaro has created a template for that particular device.

     

    EDIT:

    What you find confusing is that you dive deeper into the device's parameters than usual.

    The rest of us just create a scene that asks for the value of the device and settles for the answer we get.

     

    Sometimes you have to adjust a parameter, but most of the time they work as they are.
    But can you describe how you want to use your Smart meters, how you intend to present the results and what your scene looks like.

     

    Regarding copying setting from one device to another I have never done, but it should work.

    Have you selected the device to copy to "Choose device"?

     

    EDIT:

    When I looked at my devices, I saw that if the template is missing, it is not possible to copy any parameters. It only works to copy if there is already a tamplate??!!
    This is extremely strange because it would be extremely good to also be able to copy manually entered parameters.

     

    One tip, search the forum for "Qubino Smart Meter" and you will find more information.

    -

    Edited by RH_Dreambox
    Link to comment
    Share on other sites

    • 0
    2 hours ago, RH_Dreambox said:

    EDIT:

    When I looked at my devices, I saw that if the template is missing, it is not possible to copy any parameters. It only works to copy if there is already a tamplate??!! This is extremely strange because it would be extremely good to also be able to copy manually entered parameters.

     

    that's right, copy works only within same device type and only for these with templates (due to how this has been implemented -> copy doesread selected device params, and applies values to current view).

    If you need to copy settings for lot of devices, do it with small QA or scene (read source device and call setConfiguration for targets) 
     

    Please login or register to see this code.

     

     

    • Thanks 2
    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • On 12/6/2020 at 8:49 AM, RH_Dreambox said:

    Yes it may seem confusing, but it can be as simple as you have different version numbers on your "Smart meters".
    If you look for each unit under the tab "General", you will see which version number each unit has.

     

    Then you will probably see that there are different version numbers, and Fibaro has then chosen to create a template for only one of these versions.
    You can also see this under the "Advanced" tab and "Parameters template:". If there is a number, Fibaro has created a template for that particular device.

     

    Yepp my SmartMeter versions are 6.7, 7.6 and 6.5. It is obviously only the 6.5 version that has a parameter template.

     

    On 12/6/2020 at 8:49 AM, RH_Dreambox said:

    EDIT:

    What you find confusing is that you dive deeper into the device's parameters than usual.

    The rest of us just create a scene that asks for the value of the device and settles for the answer we get.

     

    Sometimes you have to adjust a parameter, but most of the time they work as they are.
    But can you describe how you want to use your Smart meters, how you intend to present the results and what your scene looks like.

     

    Regarding copying setting from one device to another I have never done, but it should work.

    Have you selected the device to copy to "Choose device"?

     

    EDIT:

    When I looked at my devices, I saw that if the template is missing, it is not possible to copy any parameters. It only works to copy if there is already a tamplate??!!
    This is extremely strange because it would be extremely good to also be able to copy manually entered parameters.

    In my case I am not sure if it would be possible to copy a 6.5 template to 6.7 and 7.6 versions of the Smart Meter. There may be changes in these versions. Never the less, I succeeded in setting the reporting intervall to 300 secs in each of the devices.

    On 12/6/2020 at 8:49 AM, RH_Dreambox said:

    One tip, search the forum for "Qubino Smart Meter" and you will find more information.

    -

     

    21 hours ago, tinman said:

     

    that's right, copy works only within same device type and only for these with templates (due to how this has been implemented -> copy doesread selected device params, and applies values to current view).

    If you need to copy settings for lot of devices, do it with small QA or scene (read source device and call setConfiguration for targets) 
     

    Please login or register to see this code.

     

     

    I assume Qubino have templates for all their versions of the Smart Meter. Would it be possible to upload these templates to HC3 or is this something that only Fibari can do?

    Link to comment
    Share on other sites

    • 0
    Quote

    In my case I am not sure if it would be possible to copy a 6.5 template to 6.7 and 7.6 versions of the Smart Meter. There may be changes in these versions. Never the less, I succeeded in setting the reporting intervall to 300 secs in each of the devices.

    I think it's the same parameters on the different versions. The information on their technical specification does not mention any different version numbers.

    Please login or register to see this link.

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • In each smart meter there is parameter 130 which is the S/N-number. When creating the parameter myself it is possible to view this number. When using the template this does not work at all. Also using the template for setting reporting time does not work either. The solutuion that seems to work is to use my own created paramters for the two Smart Meters that did not have a template and setting the third Smart Meter which had a templete not to use that template but using a polling intervall of 300 secs. 

     

    I have made some software using the HC3 REST API to draw 5 minutes values from the phases and got kind of good replacement for the HC2 consumption graphs.

     

    Please login or register to see this attachment.

     

    This while awating Fibaro to implement the consumption graphs directly in the HC3. Just noticed that there is an upgrade for HC3 - 5.061.36 (beta)

    See if it contains some interesting new stuff.

     

    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Answer this question...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

     Share

    ×
    ×
    • Create New...