Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 0

Is there any way to adding RAM of HC3?


rangee
 Share

Question

16 answers to this question

Recommended Posts

  • 0

It's almost as integrated as the Apple M1 :-)

 

 

I'm thinking of allowing fibaroapiHC3.lua to run multiple QAs in parallell - so there you have a way to offload the processing of the HC3 :-)

 

 

 

Link to comment
Share on other sites

  • 0
  • Inquirer
  • 3 hours ago, jgab said:

    It's almost as integrated as the Apple M1 :-)

     

     

    I'm thinking of allowing fibaroapiHC3.lua to run multiple QAs in parallell - so there you have a way to offload the processing of the HC3 :-)

     

     

     

    thx jgab

    sounds interesting.

    Its possible but not an answer...

    QuickApp is too heavy

    • Thanks 1
    Link to comment
    Share on other sites

    • 0

    Yes

    cuz zigbee is doesn’t works on HC3 I have mirroring via QA all 20 devices via z2m

    it cost me 94% of memory 

    it’s really pain

    Link to comment
    Share on other sites

    • 0

    ~1GB RAM on A53 ARM is a lot, and you wasted it for 20 devices? how?

     

    12 hours ago, rangee said:

    Is there any way to adding RAM of HC3?

     

    if you can solder FGBA, MT52L1G32D4PG should be the right replacement. If not, QA optimization or offload are probably good idea as well.

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • 14 hours ago, tinman said:

    ~1GB RAM on A53 ARM is a lot, and you wasted it for 20 devices? how?

     

     

    if you can solder FGBA, MT52L1G32D4PG should be the right replacement. If not, QA optimization or offload are probably good idea as well.

    thx   tinman

     

    I have almost 150 quickapps(9 parents and childs over 130).

    I think I optimized well... but Im not sure  :(

     

    Best way is replace RAM but that would be verrrrrry  difficult    omg.

     

    Is it impossible just inserting RAM like we upgrade PC?

    Edited by rangee
    Link to comment
    Share on other sites

    • 0
    23 hours ago, rangee said:

    I have almost 150 quickapps(9 parents and childs over 130).

    I think I optimized well... but Im not sure  :(

     

    generally the really available memory (was for years) cache + free, it is today

    Please login or register to see this link.

    , this however depends on architecture and use case.

    On HC3, when i check the values, it is about the same as BUI "Cache" + BUI "Free" as really available, before linux starts to swap things.

     

    However, one can check it per QA, simply "take a logs dump and check - or let me check - how much memory is being used by the specific QA" *

     

    http://yourhc3ip/api/service/logsDump

     

    example, my sonos QA:

     

    USER       PID %CPU %MEM    VSZ   RSS TTY      STAT START   TIME COMMAND

    hcserve+  5328  0.8  0.7 186308 15892 ?        Sl   19:48   0:00 /opt/fibaro/LuaEnvironment --log-file /tmp/plugins/106.log -b plugin={mainDeviceId=106} --source-id=plugin-106 -l ipc:///tmp/fibaro/plugin106 main.lua

     

    RSS is ~15k only, so almost "nothing"

     

    * I asked multiple time Fibaro to implement public logs dump (at least hcserver, zwave, memory, ps) for power users and installers, i know it has been placed on "to do", but no idea if it will get ever implemented. It could for sure makes some things easier to debug.

     

    23 hours ago, rangee said:

    Best way is replace RAM

     

    i don't agree, the solution for bad code is not extra memory and additional faster cores ^^

     

    For sure at some time there is no way anymore to optimize, and finally when the linux starts to swap things (or HC3 stops execution due to low memory, not sure if that has been implemented in HC3, it was like that on HCL, but not on HC2) one have to offload things. On the other hand, one can "kill" any cpu with complex code, so offload might be sometimes necessary even with low memory usage.

     

     

    23 hours ago, rangee said:

    but that would be verrrrrry  difficult    omg.

    ...

    Is it impossible just inserting RAM like we upgrade PC?

     

    ehm, we talking about replacement of this chip

     

    image.png.3a6f9bcab0eb5473b67e9524a8524387.png

    image.png.a054f5041c20d96ce6e13cd60b3e9773.png

     

    i can't even tell you if the Snapdragon ARM can properly address QDP chip.

     

    So the simple answer is no, unless you have equipment to rework 178-ball FBGA chips.

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • THX @tinman.

    I just reset the HC3 and re-install everything.

    It's funny.

    before reset > current over 90%,  3X% cache ... no free ram.

    after reset > current 50~60%, 2X% cache .. 40% free ram.

     

    idk why  :)

     

    1 hour ago, tinman said:

    http://yourhc3ip/api/service/logsDump

    I downloaded file, how can open it?

     

    tar -xvf LogsDump-HC3-00001432-07-12-2020_00_11_24.tar.gz

    >>gzip: stdin: not in gzip format
    >>tar: Child returned status 1

     

     

    1 hour ago, tinman said:

    So the simple answer is no, unless you have equipment to rework 178-ball FBGA chips.

    thx. I'll give up... T^T

     

    Edited by rangee
    Link to comment
    Share on other sites

    • 0
    11 minutes ago, rangee said:

    I just reset the HC3 and re-install everything.

    It's funny.

    before reset > current over 90%,  3X% cache ... no free ram.

    after reset > current 50~60%, 2X% cache .. 40% free ram.

     

    ohh that's memory leak somewhere ...

     

    Quote

     

    I downloaded file, how can open it?

     

    tar -xvf LogsDump-HC3-00001432-07-12-2020_00_11_24.tar.gz

    >>gzip: stdin: not in gzip format

     

     

    it's encrypted, send me attache that file here and i will decrypt it for you

     

    Edited by tinman
    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • @tinman Thx for your help

    Here's file.

     

    58 minutes ago, tinman said:

    ohh that's memory leak somewhere ...

    idk what makes memory leak haha

    reboot could not solve the problem.

    I deleted all QuickApp but  idle RAM usage were over 50%.(there was only 10 Z-wave device)

    So I decided to reset the HC3.

    And then, everythings OK. 

     

    Edited by rangee
    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • On 12/5/2020 at 4:17 AM, 10der said:

    Yes

    cuz zigbee is doesn’t works on HC3 I have mirroring via QA all 20 devices via z2m

    it cost me 94% of memory 

    it’s really pain

    It's strange.

    I'm using 52 Zigbee Device and 52 device makes 78 QuickApp.

    With other QuickApp, my RAM status is current 50~60%, 2X% cache .. 40% free ram.

     

    Link to comment
    Share on other sites

    • 0

    from before reset, ~12500 errors created by these 4 devices, these eating your log partition and probably memory (probably http calls to nil address), that might be already the memory leak:


     

    Please login or register to see this code.

     

    Additionally you have lot of property change errors (and they coming every time you update property), which is typical when one use generic or not matching device type to QA, and the QA tries to change unknow property:

     

    EDIT: btw, these ids below are actually from zwave devices, so in this case not yours bug^^, the statement above applies for own QAs.

     

    Please login or register to see this code.

     

    additionally some buttons not defined or something missing there (btnRegist1,btnRegist2,btnRegist3,btnRegist4 .... LGTHINQ)

     

    Definitely room for imporvement there, each every error like these in HCServer takes some space and resources, and definitely sooner or later HC3 becomes unstable with them.

     

    The database on your HC3 is 11M small, so no issues with unnecessary events / consumption things (like for some other users), so at least that ok.

     

     

    CPU load is ok:

    Please login or register to see this code.

     

    memory load is ok, 11%, another 11% is taken with zwave, hcserver, gpio and logs subsystems:

     

    Please login or register to see this code.

     

    in the reality you have used 30% of memory, or 70% are really available.

     

    In the logs there was no zwave log, seems to be kind of bug that zwave stops to log after some time, without hard to say if there is something wrong caused by your zwave devices. However, you can reboot hc3 and take another logsdump after 10-15mins, normally after that time the zwave log should be still there and it should already show problematic devices (if there are any).

     

     

    Edited by tinman
    • Like 2
    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • Thank you so much @tinman

     

    8 minutes ago, tinman said:

    from before reset, ~12500 errors created by these 4 devices, these eating your log partition and probably memory (probably http calls to nil address), that might be already the memory leak:

    Oh, that error occurs after memory leak and they solved already. Just typo error.

    Memory leak occurs -> change something -> type error ~12500 -> edit -> nothing change on RAM -> reset -> re-install -> no problem.

     

     

    10 minutes ago, tinman said:

    Additionally you have lot of property change errors (and they coming every time you update property), which is typical when one use generic or not matching device type to QA, and the QA tries to change unknow property:

    Hmm... can you explain more?

    deviceId 49,59,69,71,57,48 are Z-wave devices.

    In addition, there are no updateProperty "unit" in my code.

     

    thx again.

     

    ps. how to decrypt log file? is it complicated?

    Link to comment
    Share on other sites

    • 0
    3 minutes ago, rangee said:

    Oh, that error occurs after memory leak and they solved already. Just typo error.

    Memory leak occurs -> change something -> type error ~12500 -> edit -> nothing change on RAM -> reset -> re-install -> no problem.

     

     

    normally typo is just typo - not a big deal one see already error, however when it calls net library, it tries to open connection etc., which makes things much more unstable / out of control, if something get written badly due to overflows, system will not get stable again after reboot. In previous firmware version there was additionally bug in event_log partition, when it was full, system got instable. Afaik this is not the case anymore, your HC3 cleaned up lot of old logs, the last time it was out of space on log partition was 30 Nov, before that 31 October. Currently 69% used, so when you HC3 stops producing errors (from typos), not a big deal, it will cleanup in time.

     

     

    3 minutes ago, rangee said:

    Hmm... can you explain more?

    deviceId 49,59,69,71,57,48 are Z-wave devices.

    In addition, there are no updateProperty "unit" in my code.

     

    you right, updated posting above right now, these are rgbw and switches. I was too fast with my statement, i saw already too many such missing property errors on other HC3s created by QAs.

     

    3 minutes ago, rangee said:

    ps. how to decrypt log file? is it complicated?

     

    it's not, but i can't post the password.

    • Thanks 1
    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • @tinman Thanks a lot! :)

     

    9 minutes ago, tinman said:

    normally typo is just typo - not a big deal one see already error, however when it calls net library, it tries to open connection etc., which makes things much more unstable / out of control, if something get written badly due to overflows, system will not get stable again after reboot. In previous firmware version there was additionally bug in event_log partition, when it was full, system got instable. Afaik this is not the case anymore, your HC3 cleaned up lot of old logs, the last time it was out of space on log partition was 30 Nov, before that 31 October. Currently 69% used, so when you HC3 stops producing errors (from typos), not a big deal, it will cleanup in time.

     

    okay I'll check. I hope there are no more problems.

     

     

     

    9 minutes ago, tinman said:

    it's not, but i can't post the password.

    OK I understand.I found out your comment, link.

    yes. it's not, but keypoint is password. (I am wondering if I can find the password.)

    I respect you. Great.

    Edited by rangee
    Link to comment
    Share on other sites

    • 0
    On 12/6/2020 at 5:25 PM, tinman said:

    Additionally you have lot of property change errors (and they coming every time you update property), which is typical when one use generic or not matching device type to QA, and the QA tries to change unknow property

     

    Is it possible to read this information as a user? I mean? Is it logged to the user log we see in the browser? 

    Or can we "normal" users not check this and eventually I have to reset the HC3.

     

    Is a reset a factory reset or a reboot? Factory reset is a pain.

    Link to comment
    Share on other sites

    • 0
    45 minutes ago, Joep said:

    Is it possible to read this information as a user?

     

    no, not from a jedi ... 

     

    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Answer this question...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

     Share

    ×
    ×
    • Create New...