Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 0

Homekit through Homebridge with https error


Jakub
 Share

Question

When setting Fibaro to be working only with https, the Homebridge cannot connect and gives the following error:

[FibaroHC3] Error getting data from Home Center:  Error: unable to get local issuer certificate
    at TLSSocket.onConnectSecure (_tls_wrap.js:1497:34)
    at TLSSocket.emit (events.js:315:20)
    at TLSSocket._finishInit (_tls_wrap.js:932:8)
    at TLSWrap.ssl.onhandshakedone (_tls_wrap.js:706:12) {
  code: 'UNABLE_TO_GET_ISSUER_CERT_LOCALLY'
}

 

I followed the steps in here: 

Please login or register to see this link.

, but still have the same error.

Did anyone manage to get this running?

Link to comment
Share on other sites

5 answers to this question

Recommended Posts

  • 0

cuz you should add Fibaro cert to root auth key path

Please login or register to see this attachment.

 

and install on your systems as trusteed root key

or 

ExecStartPre=export NODE_TLS_REJECT_UNAUTHORIZED=0

actually it's issue NOT HC3 .

  • Like 1
Link to comment
Share on other sites

  • 0
  • Inquirer
  • 54 minutes ago, 10der said:

    cuz you should add Fibaro cert to root auth key path

    Please login or register to see this attachment.

     

    and install on your systems as trusteed root key

    or 

    ExecStartPre=export NODE_TLS_REJECT_UNAUTHORIZED=0

    actually it's issue NOT HC3 .

     

    How to do this on raspberry pi, please? (the first option, as NODE_TLS_REJECT_UNAUTHORIZED=0 doesn't seem to be safe)

    I am running the homebridge with hb-service.

     

    I used this method, but the issue persists..

    1. Copy your CA to dir /usr/local/share/ca-certificates/
    2. Use command: sudo cp foo.crt /usr/local/share/ca-certificates/foo.crt
    3. Update the CA store: sudo update-ca-certificates
    Edited by Jakub
    Link to comment
    Share on other sites

    • 0
    50 minutes ago, Jakub said:

    How to do this on raspberry pi, please?

    nie wiem. i do not know, sorry :(

    @Jakub

    Please login or register to see this link.

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • Well, it actually does not throw that error regarding problem with certificate anymore, it does show fibaro accessories in Apple Home now, but I am not able to control them. It results in "no response". When I switch Fibaro to accept http, all is fine... so still issue with the ssl certificate?

    Link to comment
    Share on other sites

    • 0

    Jakub trying to search by forum , author of fibaro HomeKit bridge here on this forum 

    You can asking this question directly 

    plus you can asking him via GitHub 

    imam not a big expert in HomeKit

    @ilcato

    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Answer this question...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

     Share

    ×
    ×
    • Create New...