Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 0

Home Center 3 with Z-wave 3.0


BrianDS
 Share

Question

Hi all, 

 

I am setting up a new HC3 completely updated for my brother, what I have discovered so far, is that a lot of things doesn't work as expected - even though it doesn't give any complaints. 

 

1. associating more than one device with S2 security enabled will prevent the reporting to other devices to function, e.g. turning on a device from an associated device, will not send the status "turned on" to the third and also associated device - hence double push is needed to turn off the device from the third and also associated device. 

 

2. When using the API (e.g. through Swagger), the parameters and associations are not visible, hence it is also not possible to set parameters from e.g. QA or Scene, and debugging associations is a nightmare. 

 

 

Anyone seen the same issues, and maybe have a solution? 

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Ad1:

Most devices sends associations (also reports in lifeline) after physical interaction with the module - so controlling a device thru associations may not trigger reports with state from this device and won't send associations to other devices if defined.

Ad2.

Parameters and associations API is moved to Z-Wave specific API -> you can use it without a problem.
You will find it in the swagger.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...