Jump to content
  • 0

After downloaded how install XML Template on HC2


Question

Hi All,

 

did someone know how install downloaded template into hc2 gateway?

In brief, after i've added the aeno labs siren gen5, hc2 show a warning alert regarding the siren, the message say that this device is not well configured because, doesn't have a template associated, and link me to download it from directly. After i've downloaded it, it is saved locally on my pc as zip file containing an xml file, maybe the template. But the last miles is miss.

How it's possible to install it, in order to configure the Siren?

 

Any helps is appreciated.

 

ng--

Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Documentation is lacking... You can't really know... It's the other way around. You download the XML, make sure the name is not all zeroes and dashes. If it's ok you search for the technical documentation of the device and send this with the XML to [email protected] Then they'll let you know if they'll include it in a next firmware release.

Link to post
Share on other sites
  • 0

Or receive the standard response from Fibaro Support: "....will be compatible in future releases" which keeps you in suspense and keep trying with each firmware release to see if it has been included since Fibaro does not include a proper change log/release note detailing what devices' template have been added in each new firmware.

Link to post
Share on other sites
  • 0

I would assume adding and removing templates may become a feature in future releases.

 

/ begin rant /

it makes sense to do that however, so it probably wont happen .. we could share our templates then instead of having to wait for an update and hope .. or we could just download the templates released by fibaro for the items as they do them .. all we want to be able to do is utilise the hardware that we have purchased that is zwave compatible to the maximum of it's potential ..

/ end rant /

 

cheers,

al.

Link to post
Share on other sites
  • 0

I would assume adding and removing templates may become a feature in future releases.

 

/ begin rant /

it makes sense to do that however, so it probably wont happen .. we could share our templates then instead of having to wait for an update and hope .. or we could just download the templates released by fibaro for the items as they do them .. all we want to be able to do is utilise the hardware that we have purchased that is zwave compatible to the maximum of it's potential ..

/ end rant /

 

cheers,

al.

Totally agree... wasn't it the case that we were able to use most of these devices in version 3?? My TZ and popp dimmers were working just fine in v3.6 and didn't need any templates.. however with v4, its all in need of templates.. It is mind boggling and the response from Fibaro is even more!! Don't know..

Link to post
Share on other sites
  • 0

Totally agree... wasn't it the case that we were able to use most of these devices in version 3?? My TZ and popp dimmers were working just fine in v3.6 and didn't need any templates.. however with v4, its all in need of templates.. It is mind boggling and the response from Fibaro is even more!! Don't know..

You can still add manual parameters. It is just a new feature. The templates are just xml files so they could be user added if you did happen to have access but not sure why you would not just add the parameters.

That is assuming the device implements the classes the way Fibaro has interpreted the spec. So down to interpretation by device manufacturer and Fibaro being aligned.

Using danfoss valves as an example of the classes http://heating.danfoss.com/PCMPDF/Z_wave_commands_VDFNN202_teamcent.pdf

There are a number of classes that are in the device that Fibaro do not support.

Also if the interpretation of wake up were different in the device to HC2, the device might not function on HC2 as expected. (Sound familiar)

A tweak to the class would then be needed to make everything work. So template is not the only potential issue the device may still need a new class or device specific version of a class. This could also change by version of a device so to support all versions of a device many versions of a device specific class may be needed.

Nice and simple to manage? Evidently not.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...