Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 0
morpheus75

Fibaro Keyfob - quick guide

Question

hi

just got hold of a keyfob and quite like it compared to the other remotes i have had in the past.

the problem i cam across is finding scene activation information so after digging around on different threads and sites got a working solution.

attached is the scene lua code and also a short video demo.....

 

enjoy....

 

 

Please login or register to see this attachment.

  • Thanks 1

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

Hi @morpheus75,

 

thank you very much for your clear explanation.

I'm just curious about one thing.

I've seen the construction fibaro:getSourceTrigger()["event"]["data"] on many different places, but it gives an error on my HC2

 

Please login or register to see this attachment.

 

I'm using a similar code for my keyfob and my remotec ZRC-90:

 

Please login or register to see this code.

This code is without the addition of ["event"]["data"], wih gives me an error and I don't understannd that. I've searched on

Please login or register to see this link.

but couldn't find any usefull explanation.

Any ideas?

 

Share this post


Link to post
Share on other sites
  • 0

Hi @Bodyart,

 

I use this function on 4.130 and don't have any problems:

Please login or register to see this code.

Did you try to replace double quotes with single ones like this:

Please login or register to see this code.

Did this stop working on this latest beta firmware or it was problem also on previous versions?

Share this post


Link to post
Share on other sites
  • 0

I consider to get a fibaro kyefob.

 

I need some feedback from those who already have it.

 

What is the range of it ?  (how far from HCL  or HC2 it is working)

 

 

Share this post


Link to post
Share on other sites
  • 0
8 minutes ago, gucio1234 said:

I consider to get a fibaro kyefob.

 

I need some feedback from those who already have it.

 

What is the range of it ?  (how far from HCL  or HC2 it is working)

 

 

 

I reviewed the keyfob. I tested it to about 20 m.

 

Other useful info in my topic:

 

Share this post


Link to post
Share on other sites
  • 0
5 hours ago, Sankotronic said:

Did this stop working on this latest beta firmware or it was problem also on previous versions?

Hi @Sankotronic,

 

I don't remember exactly on which version FW i started using it, bvut this piece of code always gave me the above error and as far as i'm aware there's no functional difference between single of double quotes, I tried both with no difference.

 

1 hour ago, gucio1234 said:

I consider to get a fibaro kyefob.

 

I need some feedback from those who already have it.

 

What is the range of it ?  (how far from HCL  or HC2 it is working)

 

 

Hi @gucio1234,

 

I'm absolutely satisfied with keyfob. It has remarkable responsivness! Unfortunately i can't tell you about the range, cause i didn't try above ten meters.

I can recomand this product due it's responsivness and it's versatility. :-)

 

Share this post


Link to post
Share on other sites
  • 0
6 minutes ago, petergebruers said:

@Bodyart can you add this at the start of the script and tell me what it prints?

 

Please login or register to see this code.

 

Yes sure @petergebruers

 

this is the result:

Please login or register to see this attachment.

Edited by Bodyart

Share this post


Link to post
Share on other sites
  • 0

So... The script wasn't started by the push of a button. And so the things between [] that you use in your script don't exist. Mayby you clicked the "Start" button? In that case, what do you want your script to do without having an button event?

Share this post


Link to post
Share on other sites
  • 0
15 minutes ago, petergebruers said:

So... The script wasn't started by the push of a button. And so the things between [] that you use in your script don't exist. Mayby you clicked the "Start" button? In that case, what do you want your script to do without having an button event?

Oh sh..., i've  Indeed pressed the start button. Going to test again.... Bad me :-(

 

When I don't press the start button under debug window then nothing happens by pressing the keyfob keys.....

 

this is what happens in my code posted above

 

Please login or register to see this attachment.

 

i don't use there ['event'] ['data'] as you can see. I couldn't find any documentation about thouse ['event'] ['data'] Do you have any idea, where to find it?

 

B.T.W. My Keyfob device in fibaro is reacting correctly on button pressings.

 

 

Edited by Bodyart

Share this post


Link to post
Share on other sites
  • 0

Ah, the [] thin is a Lua thing, not a Fibaro thing. That's probably why you didn't find it. Now I come to think of it, Fibaro could document the table structure but I don't think they ever did.

 

I'm not sure if you are struggling with table structure and syntax, so to be on the safe side, the link below is an excellent introduction.

 

The "fibaro:debug(json.encode(fibaro:getSourceTrigger()))" incantation is a cunning way to print the structure of a table, I always use it to reverse-engineer things like this "trigger" problem.

 

Edited by petergebruers

Share this post


Link to post
Share on other sites
  • 0

I just rebooted HC2 went again to @morpheus75 his code and "(nu breekt mijn klomp") now my bunch breaks..... IT WORKS

 

How coul'd HC2 have so much garbage in the memory.....

40 minutes ago, petergebruers said:

The "fibaro:debug(json.encode(fibaro:getSourceTrigger()))" incantation is a cunning way to print the structure of a table, I always use it to reverse-engineer things like this "trigger" problem.

Now i'm getting further Peter thank you very much for your excellent help. Indeed i'm still struggling with the table a when working with json structure i have @AutoFrank his tutorial to hometable and tutorial to tables open as word document :-)

I'm going to rebuild my code for Keyfob, Remotec and Fibaro Button :-) accordingly, thank you @petergebruers again.

 

Edited by Bodyart

Share this post


Link to post
Share on other sites
  • 0
  • Inquirer
  • hi all

    thanks for your feedback!

    sorry had a couple of days off so not been on forums

    the ['event']['data'] thing when i started scene manually i got the same error so i think @petergebruers is right in saying manually starting scene will give error.

    like i mentioned i used a few threads to come up with that scene above with a bit of trial and error..

     

    @gucio1234 my hc2 is cupboard under stairs and i use the remote around the house, furthest distance is probably 10 to 15 meters away through walls and floors and stairs etc. So far so good, but i do have a lot of modules scattered around the house and i believe that my z-wave mesh network is very strong.

    Share this post


    Link to post
    Share on other sites
    • 0

    Hi All,

     

    the information above is really helpful, Thank You! but I still facing a challenge.

     

    I'm trying to use a sequence of different buttons to disable/switchoff my alarm. 

     

    For activating the alarm or any other actions I can use the "Chose buttons to create sequence" option (see screenshot) on my Keyfob but this does not work to switch of the alarm when triggered. Therfore I'm tring to use a scene, defining the sequence of different buttons and then trigger the task. Is this possible and could somebody show me an example script?

     

    Please login or register to see this attachment.

     

    Please login or register to see this attachment.

     

    Thanks Guys!

    Rolf

    Share this post


    Link to post
    Share on other sites
    • 0
  • Inquirer
  • @namboy1 it looks like that there is no option to 'allow scene to run when fibaro alarm is running' like we see on the other scenes. which is probably why you cannot use the fob for your sequence.

     

    when running the standard functions as per video that will work. but still need to work out the LUA code for the key sequences, then we can incorporate into scenes and then the combo function will work.

     

    thanks

    Share this post


    Link to post
    Share on other sites
    • 0
  • Inquirer
  • @namboy1

     

    hi

    check this update of my video out and i believe it will solve your problem about running a scene using a button combination press.

    enjoy!

     

     

    Share this post


    Link to post
    Share on other sites
    • 0
  • Inquirer
  • 1 minute ago, namboy1 said:

    Thanks! Just tested it and it does solve my Problem!! ;)

    Thanks & best regards

    Rolf

     

    your welcome mate!

    Share this post


    Link to post
    Share on other sites
    • 0

    Hi there, really useful thread for a newbie, thanks.  I have two key fobs running, with one button press for arming the alarm, one for disarming.  We have a door sensor and two motion sensors as part of the alarm group, 30s escape and entry delay on each device to allow arming/disarming on exit/entry.

     

    The arming and disarming work really well.

     

    Unless you wait past the entry delay and trigger the alarm proper.  We have two problems then:

     

    1) The disarm button will not override the alarm (even tho the check box for alarm override is set on the scene), we have to use the mobile app or home centre interface.

     

    2) Once the alarm is disarmed, the arm / disarm scenes no longer work from either keyfob for a period of time or a HCL reboot if forced.

     

    Must be a setting I am getting wrong. Any help greatfully received.

     

    please note I rely on block scenes only! I’m no coder!

     

    thanks

    Share this post


    Link to post
    Share on other sites
    • 0
  • Inquirer
  • hi

    can you post screenshots of your arming and disarming scenes please, this should help in working out why after triggering the keyfob doesnt work.

    also your keyfob scenes.

    thanks

    Share this post


    Link to post
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Answer this question...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.


    ×
    ×
    • Create New...