Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 0

Has anyone a truly working Alexa / HC2 system?


jodohl
 Share

Question

I am hoping for some useful advice from people with at working Alexa / HC2 system. After endless hours of Fibaro Support emails, testing, deleting and restoring my LAN, HC2 and Alexa, my problem still remains the same:

 

Alexa picks up my command (e.g. "Alexa, Turn off Kitchen Table") and one out of three things happen: (1) Light is turned off, Alexa responds "OK" (2) Light is turned off, Alexa responds "Sorry, Kitchen Table is not responding" (3) Light is NOT turned off, Alexa responds ""Sorry, Kitchen Table is not responding". Totally erratic, no pattern. Failure statistics: 1 out of every 4 (25%, N=40). Enough to reduce the WAF to Zero.

 

Fibaro Support finally made me aware that the problem is response time: If the time from command is given to remote Alexa/Fibaro server response is received, exceeds 7 seconds, Alexa times out. Fibaro Support keeps on insisting that the problem is my LAN/Internet connection. I have however gone so far as to disconnect all other devices on my net but for the HC2 and Echo Dot and confirmed my Internet speed is 92 Mbps Up/Down. Even followed the rather extreme Fibaro Support advice of reducing the physical distance between HC2 and the Fibaro Dimmer2 to less than 300 cm (!). I am now starting to suspect that the problem is the Alexa/Fibaro API server integration. 

 

And I have of course upgraded firmware, reconfigured z-wave net, dis/enabled Fibaro skills, deleted and restored my HC2 from Fibaro ID, confirmed Alexa has selected my HC2, reset the Echo Dot, reset the HC2 and restored the system from backup and so on and so forth. Friendly guys at the Fibaro Support desk, but so far advice has not brought me any visible result, except for loosing all my custom Scene/VD icons, which apparent are not part of the HC2 back up file :-(

 

Any wisdom out there?

 

Link to comment
Share on other sites

Recommended Posts

  • 0

@vanni177

Please press  at Alexa (in Devices) "Forget All" and then "Discover" ... 

Same in Scenes section...

Worked for me...

Edited by cag014
Link to comment
Share on other sites

  • 0
On 1/4/2018 at 12:54 AM, jodohl said:

I am hoping for some useful advice from people with at working Alexa / HC2 system. After endless hours of Fibaro Support emails, testing, deleting and restoring my LAN, HC2 and Alexa, my problem still remains the same:

 Fibaro Support keeps on insisting that the problem is my LAN/Internet connection. I have however gone so far as to disconnect all other devices on my net but for the HC2 and Echo Dot and confirmed my Internet speed is 92 Mbps Up/Down. Even followed the rather extreme Fibaro Support advice of reducing the physical distance between HC2 and the Fibaro Dimmer2 to less than 300 cm (!). I am now starting to suspect that the problem is the Alexa/Fibaro API server integration.

Any wisdom out there?

 

Since Alexa uses WiFi connection, did you check the speed of WiFi connection? Please try to configure WiFi connection at you router.

I had same issue and have reconfigured WiFi parameters at router. (it might be enough just to switch to other channel).

Right now the problem reduced to 1 out of 20 tries, but still time to time it happens.

Edited by cag014
Link to comment
Share on other sites

  • 0
7 hours ago, cag014 said:

@vanni177

Please press  at Alexa (in Devices) "Forget All" and then "Discover" ... 

Same in Scenes section...

Worked for me...

Thanks for the input.

:(  I just tried it but it doesn't work for me.

Link to comment
Share on other sites

  • 0
  • Inquirer
  • 19 hours ago, cag014 said:

    @vanni177

    Please press  at Alexa (in Devices) "Forget All" and then "Discover" ... 

    Same in Scenes section...

    Worked for me...

     

    This standard "advice" from Fibaro Support has been tried a dozen times. No progress.

    On ‎04‎.‎01‎.‎2018 at 7:19 PM, wpeeters said:

    @jodohl hi, also my HC2 / Amazon echo 'aka Alexa' integration is working fine. Some delays upto 4 or 5 seconds but nothing more than that. 

    As Robmac is saying, a good wifi connection is required. Here in Belgium at a certain provider we can choose a 'channel' on our internet modem. Some 'channels' on wifi are of better quality in parts of the house than others.

    As far as I could read, you didn't mention if your Alexa is responding correctly on other commands (Joke, weather, news, wikipedia, ....). Is that working fine?

    BTW, I was that happy with my Alexa and HC2 integration that I've created my own skill (house status). It's published but not yet approved. It tells me some status of the house after asking Alexa 'Alexa, Open house status'.

    What puzzles me is that all other Alexa fuctions, except Fibaro, work perfectly and expeditely. News flash, Spotify, Weather forecast....

    Link to comment
    Share on other sites

    • 0

    I do share your disappointment, but till now didn't have any major problems with Alexa (have three devices).

    Everything works as expected and believe me my kids are heavy Alexa users.

    It might be worth to chat with Alexa support, they're extremely useful support. They do have tools to examine Alexa issues...

    Just for testing, I have disconnected HC2 from Alexa and all devices and scenes (including Harmony) have been discovered from scratch w/o any problem.

    Once your issue will be solved, please post your findings.

    Edited by cag014
    Link to comment
    Share on other sites

    • 0
    1 hour ago, jodohl said:

     

    This standard "advice" from Fibaro Support has been tried a dozen times. No progress.

    What puzzles me is that all other Alexa fuctions, except Fibaro, work perfectly and expeditely. News flash, Spotify, Weather forecast....

    it's already told that 'fibaro cloud services is the cause of this, so it will take a few seconds for a device responds.

    you don't want to use a second device (ha) for fibaro to use with Alexa, so it will take a few (4 or5)  seconds every time you use Alexa with fibaro.

    Link to comment
    Share on other sites

    • 0

    I used HA in the past to control Fibaro modules and it works pretty quick.. then tried out Alexa directly with Fibaro Skill and each command takes 3-4 seconds.. decided, it's not worth the wait and have gone back to HA as it is pretty much instant.. Until this delay is resolved, I will stick to running HA. Just a personal view.

    Link to comment
    Share on other sites

    • 0
    On 1/5/2018 at 1:09 AM, jodohl said:

    OK, what I get from these two replies is that Alexa/Fibaro may, - or may not - work.

     

    And nobody, -  including Fibaro - has any ideas whatsoever to why.

     

    "Get a raspberry pi and install HA bridge" may sound simple to some, but as I am not primarily interested into diving into a lot of code or setting up more machines to maintain on my system.

     

    But a thought crossed my mind: I have a Synology NAS running on my LAN. Is it so that this "HA bridge" could run on my NAS? If so, then maybe it is time to develop a friendship with this "HA bridge" animal. 

    Ok, I bought the skarotech automation bridge, which is a Pi with all the HABridge and other customisations installed.  One ethernet cable and it was working.  Also does some nifty Wifi-Zwave integration with my HC2 via plugins, if you own the relevant hardware.  No problems so far with Alexa.

     

    You'll have to Google the link as I don't think Fibaro encourage posting it...

    • Like 1
    Link to comment
    Share on other sites

    • 0
    Guest Dennis
    On ‎8‎-‎1‎-‎2018 at 1:49 AM, vanni177 said:

    Alexa was working with HC2

     

    But now, I don't know why,

    I can't discover any Devices or Scenes!!!

     

    Anyone has a hint what to do?

     

    I did:

    • Reset HC2
    • Reset Alexa
    • Disable and Enable Fibaro Skill
    • Change Alexa WiFi 2.4/5.0GHz

    Nothing works.

    Do I miss some settings?

    I can see my Hue's in Alexa.

     

    please can someone help on that, I'm totally frustrated

     

     

    Same problem here !!!

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • And suddenly Alexa is working. I do not really understand why, neither does Fibaro Customer Support, but two possibilities remain:

    (1) Amazon finally listened to the numerous complaints and did something to their API to allow for longer Fibaro response times before timeout error occurs

    (2) The changes I did to my system were successful, namely making all device and scene names short and unique. That is changing "Kitchen Table" and "Kitchen Bench" to "Table" and "Bench"

     

     

    Link to comment
    Share on other sites

    • 0

    Okay, so the issue is not with Alexa.

    The Amazon API has a timeout of 10 seconds for skills. This means that from the point Alexa has picked up your intent, the HC2 will be called by Amazon's cloud data center and it has 10 seconds max to complete the request and confirm it.

    Again, at this point, the Alexa device is out of the picture, it just waits for a response back from the data center.

    The bottleneck is between you and the Amazon data center. Here's how the connection goes: Amazon -> Fibaro reverse proxy -> your HC2. Even if your HC2 has an excellent connection, any delays between Amazon, the Fibaro hosted reverse proxy and your HC2 will affect execution.

    The reason why you get seemingly random results is because Alexa gives up on the command before the HC2 can confirm it executed it, or gets cancelled before the call is even made, because it exceeds the 10 second maximum execution time.

    I had the same issue with my HC2 and Alexa. I have a Fortigate in front of my HC2 and I used it to monitor the network. Sometimes it took 8-9 seconds after the Alexa intent was sent for the inbound request to hit the controller. Other custom skills hosted on my network directly (not going through Fibaro's proxy) hit within 1 second. This means that either Amazon had a delay with Fibaro's reverse proxy or from Fibaro to me.

    The problem has gone away recently, either Fibaro improved their proxy, or they're using proper geolocated servers for the proxy.

     

     

    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Answer this question...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

     Share

    ×
    ×
    • Create New...