Jump to content
  • 0

Scene ignores TIME when VARIABLE is changed


Question

Hello guys,

 

I have some trouble with creating scene, which has to TURN ON a Fibaro Plug at exact time, but only when variable is met.

 

The problem is, if i tell scene to TURN ON plug at exact time, it works fine. But, when I add variable next to the time with "And", scene completely ignores the time and runs every time the variable is met.

 

5a8720f368d9c_Snmkaobrazovkyz2018-02-1617-12-24_copy.thumb.png.85d9cf21131a28dad19fea669f2ac61c.png

 

So if I or a different scene change variable to OFF, this scene will automatically trigger despite it shouldnt untill 18:00. Anyone knows why please? Thank you!

Link to post
Share on other sites

13 answers to this question

Recommended Posts

  • 0

Hi
You must remove the checkmark by "alarm"

Then the scene will run when the clock passes 18:00 and alarm = off

Edited by hTiger1
Link to post
Share on other sites
  • 0

@hTiger1 Doesnt work anyway :(  Everytime i manually change that variable / or / the variable is changed by different scene, this scene will trigger even with uncheck "ALARM". 

Link to post
Share on other sites
  • 0

See photo, just works, only different variables

turn on.JPG

 

On HC2 and V4.161

 

Edited by samuel
Link to post
Share on other sites
  • 0

@samuel I dont think this is the same case. Fibaro is ignoring Time and the whole scene stands only on Variable, for no reason. If i am not doing something wrong, there must be a bug in the system.

Link to post
Share on other sites
  • 0

Hi
Perhaps we misunderstand each other a little.
The scene should work as in my first response and can not take into account the time when the variable changes.

Link to post
Share on other sites
  • 0

Hi @play3man

Can you untick the variable as a trigger and save .. it's not the trigger .. time is the trigger. .. per @hTiger1

and then tick auto start and automatic run and .. it should all be good.

 

So it should be similar to this test I just ran ..

 

image.thumb.png.25db0e757360a2592838bbadec7ddcfe.png

 

I changed the variable to daytime = 0 and moved the time forward a couple of minutes and it didn't fire at that time, then changed the variable to 0 again and moved the time forward a couple of minutes and it fired again ..

Is whatever is feeding your variable working correctly ?

Cheers,

al.

 

Edited by alandee
Link to post
Share on other sites
  • 0

Thank you guys for help but i contacted support and solved this problem.

 

Yes, the solution is simple - just to uncheck the variable under triggering variables, but Fibaro not always recognize the change and you need to re-add the scene with variable already unchecked.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...