Jump to content

Finally, a HC2 / HCL Workaround to RTSP / H.264 IP Cameras - 100% Working solution


Recommended Posts

On 6/20/2018 at 2:36 PM, Sebdb66 said:

Is there a version of TinyCam Monitor Pro (or some other software) that would run on a Raspberry PI , so the conversion could look a little more professional than having an always on Android phone ?

 

I am running a V10 tiny cam pro version running on raspberry 3 with IoT (internet of things Android distro) that works perfectly stable, making recording backups to Microsoft one drive... It is very stable an Ethernet wire connected. Pretty comfortable to me.

 

It's a bit slow to configure at beginning, as you can't control rpi3 remotely and you need to configure with keyboard and hdmi. The good thing is that your can import your configuration from cloud (at least one drive, Dropbox or drive or own cloud didn't with for me) and then save there your recordings.

 

It's better that you check with Alexey (creator of tiny cam) as this is a premium paid version and I think I can't share it...

 

Good luck!

 

Link to post
Share on other sites
  • Replies 54
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Hi all,   I would like to share a 100% working solution for HC2 / HCL users that want to use new IP cameras working with RTSP, H.264.   Problem: as you know Fibaro doesn't respect

here is script   <?php if (isset($_GET['usr'])) { if (isset($_GET['pwd'])) { $auth = $_GET['usr'].":".$_GET['pwd']; $auth.="@"; } } else { if (!isset($_SERVER['PHP_AUTH_USER'])

Someone please give him an award!  @dimae

Posted Images

On 7/4/2018 at 3:02 PM, Sebdb66 said:

 

 

We decided to go for an off the shelf Android TV box (£25)  and run this headless once we had set it up for the cameras. Very neat solution and more professional than an old android phone

 

I can recommend you that you can configure and test cameras on your usual phone, easily and realtime testing... then EXPORT config to Google Drive.

Then IMPORT config on your Android TV box with ease. Super easy.

 

Please share your hardware (I am still using old phone Huawei P8 lite), I think TV box is best solution as it is wire connected.

 

Thanks

Link to post
Share on other sites
Guest Sebdb66
17 hours ago, dimae said:

 

I can recommend you that you can configure and test cameras on your usual phone, easily and realtime testing... then EXPORT config to Google Drive.

Then IMPORT config on your Android TV box with ease. Super easy.

 

Please share your hardware (I am still using old phone Huawei P8 lite), I think TV box is best solution as it is wire connected.

 

Thanks

 

 

I would but we dont use Android Phones but a handy tip anyway

 

We used a A95X from Amazon

 

https://www.amazon.co.uk/gp/product/B0771L3F93/ref=oh_aui_detailpage_o03_s00?ie=UTF8&amp;psc=1

 

Seb

Link to post
Share on other sites
  • 1 month later...

Hi!

I could read some very interesting solutions and alternatives to set a IP CAM on Fibaro, but its not a professional solution that we can sell for customers.

Is Fibaro Team working to a final solution and system upgrade?

 

As an integrator, I'm not looking for a security system, but it's important to have cameras easily registered at Fibaro system.

Link to post
Share on other sites
  • 1 month later...
  • 3 weeks later...

Hello, I agree also it is better that fibaro update their system, it will help us a lot.

 

 

_______________________________________________________________________________________________

Mini Militia App Lock 7Zip

Edited by ekrem
Link to post
Share on other sites
  • 3 weeks later...

Hi,

thank you for your experience.

Did you have some trouble with Tinycam webserver? I installed Pro version on my Lenovo tab with 7.1.1 os, and it seems that no webserver is runiing, no port open on my tablet, therefore I cannot connect from Fibaro...

Thank you for help

 

Link to post
Share on other sites
  • 3 months later...
In the HC2 web interface, all my cameras are displayed by Tinycam. Only in the Fibaro app not. Does anyone have any idea why?
Edited by Hitman85
Link to post
Share on other sites
  • 3 months later...
On 4/24/2018 at 4:01 AM, 10der said:

Would you help me?
I need to integrate the Intelbras VIP 1120 B cameras with the Fibaro system. They are connected to an Intelbras NVD 1008 recorder however each has its own IP address on the network.
If necessary I can use an external server (from my own site) to create a .php page.
How could I do that? What would the codes look like?

 

 

 

 

hi!

 

alternative solution - use own web server (for example rpi)

 

create php file with content

<?php
header('Content-Type: image/jpeg');
passthru('/usr/bin/ffmpeg -i rtsp://192.168.1.32:554/ch0.h264 -f image2 -vframes 1 -pix_fmt yuvj420p pipe:');
?>

192.168.1.32 your rtsp cam

 

image.thumb.png.68e0336638221ecd8e15a0d7b0a3dbc1.png

 

 

Link to post
Share on other sites
  • 1 month later...

@10der, is that all the code I need?

 

I mean, I need just a file "camera.php" containing:

 

<?php
header('Content-Type: image/jpeg');
passthru('/usr/bin/ffmpeg -i rtsp://192.168.1.158:37789/ch0.h264 -f image2 -vframes 1 -pix_fmt yuvj420p pipe:');
?>

 

 

In my case the port showed by Intelbras system is: 37789. Is it right or i have to use the port 554?

 

Need I another file ".php" or is this enought?

 

Thanks in advance

Link to post
Share on other sites

Each IP cam models are different. But RTSP port is 554 this script expect RTSP stream on this port, please RTFM for your cam and find port for RTSP

Link to post
Share on other sites
  • 4 months later...
On 5/9/2018 at 9:34 PM, 10der said:

Thanks @10der for your script!
Now I don't have to use my Technaxx TX-67 as a letterpress anymore.

Here's how to configure my TX-67 (my PHP file is cam.php):
cam.php?ip=192.168.1.36:554&endpoint=&channel=0&subtype=0

 

What does not work is that the image in Fibaron is frozen and updated only when I click in the image to open the dialog box.
If I click on the camera icon, I get a timely updated image via email, so it works as it should.


Unfortunately, I have not been able to control the camera's positioning in the Fibaro, I can do this through the camera app.
It is really bad because the camera seems to hold a high quality.

 

Link to post
Share on other sites

@RH_Dreambox you can (should) pass the same url in both input lines for JPEG stream and VIDEO

and last [x] check box on param like (sorry I am far from PC) show cam on main dashboard

 

about driving the cam- please find API for your cam (or provide what your cam have) and you can driving cam by Fibaro 

Link to post
Share on other sites
On 5/9/2018 at 9:34 PM, 10der said:

Hi @10der,
Yes, I have the same command for both JPG URL and MJPG stream URL.
"Display camera image on the overview page" is selected and the update interval is 3 sec.


So I get the current updated image in all the dialogs that I open, but then they are not updated until I click the image again.

 

And the commands to turn the camera looks like this:
Left:      cgi-bin/ptz.cgi?action=start&channel=0&code=Left&arg1=0&arg2=1&arg3=0?loginuse=admin&loginpas=admin
Right:   cgi-bin/ptz.cgi?action=start&channel=0&code=Right&arg1=0&arg2=1&arg3=0?loginuse=admin&loginpas=admin
Up:       cgi-bin/ptz.cgi?action=start&channel=0&code=Up&arg1=0&arg2=1&arg3=0?loginuse=admin&loginpas=admin
Down: cgi-bin/ptz.cgi?action=start&channel=0&code=Down&arg1=0&arg2=1&arg3=0?loginuse=admin&loginpas=admin
Stop:   cgi-bin/ptz.cgi?action=stop&channel=0?loginuse=admin&loginpas=admin

 

But nothing happens when I click on the buttons, all buttons are dead.
Fibaro does not seem to be able to handle the authentication.

 

Edited by RH_Dreambox
Link to post
Share on other sites

Your auth in url you not right 

can you show me

1) url in your browser and response from cam

2) screenshot VD of FIBARO cam

Link to post
Share on other sites

1) Both of these are tested in VLC player with an excellent result
rtsp://admin:[email protected]:554
rtsp://admin:[email protected]:554/cam/realmonitor?channel=1&subtype=0
---------------------------------------------------------------
2) Tested in WEB browser (Raspberry + your script) Manually login admin/admin
I got picture, but picture does not update, and I must first delete the login information in HC2
http://192.168.1.83/cam.php?ip=192.168.1.36:554
---------------------------------------------------------------
3) Technaxx command in WEB browser
I got a video stream, but I have to login manually admin/admin (subtype 2 = MJPEG)
http://192.168.1.36/cgi-bin/mjpg/video.cgi?channel=0&subtype=2&usr=admin&pwd=admin (usr and pwd does not work)
---------------------------------------------------------------
4) Commands below for MJPEG stream (subtype 2) that Fibaro should read, but they do not work. (I have tested a lot more than theese.)
But...
If I copy the MJPG command from the HC2 to a new browser page and log in admin/admin, I get a picture in both WEB browser and in HC2!
So it seems that HC2 has problems with the authentication.
Does not work
JPG: cgi-bin/snapshot.cgi?channel=0&user=[admin]&password=[admin]
JPG: cgi-bin/snapshot.cgi?channel=0&user=admin&password=admin
JPG: cgi-bin/snapshot.cgi?channel=0
Does not work
MJPG: cgi-bin/mjpg/video.cgi?channel=0&subtype=2&user=[admin]&password=[admin]
MJPG: cgi-bin/mjpg/video.cgi?channel=0&subtype=2&user=admin&password=admin
MJPG: cgi-bin/mjpg/video.cgi?channel=0&subtype=2
Does not work
Move left: cgi-bin/ptz.cgi?action=start&channel=0&code=Left&arg1=0&arg2=3&arg3=0&user=[admin]&password=[admin]
Move left: cgi-bin/ptz.cgi?action=start&channel=0&code=Left&arg1=0&arg2=3&arg3=0&user=admin&password=admin
Move left: cgi-bin/ptz.cgi?action=start&channel=0&code=Left&arg1=0&arg2=3&arg3=0
---------------------------------------------------------------

 

Technaxx-HC2.jpg

Edited by RH_Dreambox
Link to post
Share on other sites

So about cam moving - yes, we are use proxy for video and this proxy (php) can’t handle command for moving 

so, we should simple add this query Paramus to handling to php file and pass this query to original web cam api 

here is all simple 

 

About pic refresh - I should get some time for additional investigation cuz for example my cam via my proxy now also not displayed lol 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...