Jump to content

Finally, a HC2 / HCL Workaround to RTSP / H.264 IP Cameras - 100% Working solution


Recommended Posts

fibaro issues.

alas. 

fibaro Ui do not update cam state anymore. 5 cams + 1cam with my proxy with same behavior.

that's' all folks.

Link to post
Share on other sites
  • 2 weeks later...
  • Replies 54
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Hi all,   I would like to share a 100% working solution for HC2 / HCL users that want to use new IP cameras working with RTSP, H.264.   Problem: as you know Fibaro doesn't respect

here is script   <?php if (isset($_GET['usr'])) { if (isset($_GET['pwd'])) { $auth = $_GET['usr'].":".$_GET['pwd']; $auth.="@"; } } else { if (!isset($_SERVER['PHP_AUTH_USER'])

Someone please give him an award!  @dimae

Posted Images

@10der
Have you managed to fix the problem of not updating the video image?

Thanks to your script, I get video (still image) from my TX-67 and I can also take snapshots.
But I miss moving pictures (and controlling the camera). My Raspberry cameras are updating properly so there is probably no error in the GUI.

I now also know why the TX-67 can no longer be integrated into Fibaro, see below.

Quote

Dahua IP cameras are NOT supported anymore.

In fact, most IP cameras with latest firmware will stop working very soon.
Here's why:
- Recent vulnerabilities have forced manufacturers to REMOVE basic authentication.
- Digest authentication has become the LOWEST security mechanism - its one step above plain text authentication (visible in packet capture).
- In Dahua firmware from early 2017, basic authentication is blocked.
- Dahua has BLOCKED the ability to downgrade to firmware with basic authentication (firmware is signed).

Fibaro MUST add digest authentication for IP cams to keep us at the current level.

 

  • Like 1
Link to post
Share on other sites
4 minutes ago, RH_Dreambox said:

Have you managed to fix the problem of not updating the video image?

I am not Fibaro developer.

Edited by 10der
Link to post
Share on other sites

@ 10der
I know :-)
But you mentioned that you would look at your php script to see what was wrong.
Or do you mean that Fibaro fails to update your script? My Pi cameras are updating properly.

Link to post
Share on other sites

@RH_Dreambox OMG. dear. please read:

 

 
Quote

 

fibaro issues.

alas. 

fibaro Ui do not update cam state anymore. 5 cams + 1cam with my proxy with same behavior.

that's' all folks

 

.

i have the same behavior

Link to post
Share on other sites
  • 2 months later...
On 4/24/2018 at 9:15 AM, 10der said:

http://192.168.1.15:88/cgi-bin/CGIProxy.fcgi?cmd=snapPicture2&usr=admin&pwd=admin

 

Awesome! This I think is good enough for me thanks! I just set the refresh to 1 or 2 seconds and I get the just of what is going on.

I might get up a Pi at a later date to serve.

 

Cheers,

Jon

Link to post
Share on other sites
  • 3 months later...

Hi, I can load my IP Cam images in browser via local connection with IP address.

 

However, I can't load any images from remote access via browser or APP.

 

Here are some of my IP Cam info:

  • IP address : 192.168.0.105
  • JPG, MJPG route : cgi-bin/hi3510/snap.cgi?&-getstream&-chn=2

The route is copied from the IP Cam's inspect from browser.

Link to post
Share on other sites
  • 3 weeks later...
On 7/15/2020 at 8:50 AM, Brendanlim said:

Hi, I can load my IP Cam images in browser via local connection with IP address.

 

However, I can't load any images from remote access via browser or APP.

 

Here are some of my IP Cam info:

  • IP address : 192.168.0.105
  • JPG, MJPG route : cgi-bin/hi3510/snap.cgi?&-getstream&-chn=2

The route is copied from the IP Cam's inspect from browser.

 

Do you have a IP gateway set in the camera?

Link to post
Share on other sites
  • 2 weeks later...

Hello :) 

Is this still working or not?

 

I managed to install TinyCam Pro, it's running on an old Android tablet and I can see the camera from there.

If i start the webserver, and i go to tablet IP:port i can see the webinterface with cams.

 

Also if I check via chrome adress "http://192.168.0.8:8083/axis-cgi/mjpg/video.cgi?camera=1" I can see the images (i found this link in the API manual section of Tinycam).

image.thumb.png.6a60cb295acf38ec08bdeeb5241589f2.png

 

Link with axis-cgi/jpg/image.cgi?camera=1 it's not working at all. No trace of plain JPG link in api manual.

 

image.thumb.png.386d501b08855a272d70c5fc249f57d3.png

 

Of course this is not working at all in FIBARO HC2 (will not work even using MJPG in both links and selecting MJPG in "Display camera image at Your House, advanced options:".)

 

image.png.8bbef7cd1919d57f57797b3338a8e6a5.png

 

Is this still working for some of you guys or it's broken?

 

Tnx for Help :)

 

Nicola

 

Edited by freespirits
Link to post
Share on other sites

Oh well... I found out the solution of the problem by myself.... :D 

 

As I said i was using an old tablet. Looks like Android version matters for APIs :)

 

API and webinterface are completely different in old tablet (i guess playstore is giving me an old version of tinycam since it has to run in JellyBean).

 

This is API manual with tablet:

image.thumb.png.e23af92958e2e011a3f30b4f122d9ce4.png

 

And this is with my phone :)

 

image.thumb.png.a950808b6e6878402f4d9d5259fd5906.png

 

 

Of course is now working prefectly on Fibaro : )

 

 

Edited by freespirits
Link to post
Share on other sites

@freespirits You need to add the camera's IP address and port number to your HC2. Then it should work.

Is a username and password not required for you to access the camera?

Link to post
Share on other sites

I bought an Automationbridge pro, with that you can add ip cameras (rtsp).

Link to post
Share on other sites
26 minutes ago, RH_Dreambox said:

@freespirits You need to add the camera's IP address and port number to your HC2. Then it should work.

Is a username and password not required for you to access the camera?

Ye, IP was just missing on the screenshot.

 

As I said it was an app version issue due to tablet being too old. I have resolved now. Thanks for reply tho :)

Edited by freespirits
Link to post
Share on other sites
  • 1 month later...
On 8/14/2020 at 8:37 PM, texan said:

I bought an Automationbridge pro, with that you can add ip cameras (rtsp).

 

Tell us more!  What does it enable in HC2?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...