Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,


as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.


As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!



Smart Home Forum by FIBARO Team

  • 0

Alarm triggering with delay on doors



I have created different scenes in the block scene editor. These are all working except for the one that should do the following:

1. When I arm the alarm, the door sensor is armed.

2. When I open the door it should give me 10 seconds before the alarm goes off. 

3. If I disarm the alarm, therefore disarm the door sensor within 10 seconds the alarm should not go off. 


This all works fine with a minor detail: if I shut the door within 10 seconds the alarm does not go off, while it should go off unless I have disarmed the alarm. 


I have tried the following block scene:

Please login or register to see this image.

/monthly_2019_06/image.png.345f7cde98245097eee195f4a34bab29.png" alt="image.png.345f7cde98245097eee195f4a34bab29.png" />




First I tried stating at the device that if it's armed and breached it should trigger and I put a 10 second delay at the end. That did not work. 

Then I tried the above method checking if the door is device is triggered while armed and breached AND if after 10 seconds the device is NOT disarmed. 

By the way I also tried the statement if after 10 seconds it IS armed. Both with the same result: If I close the door quickly enough, I'm inside and the alarm is not triggered.


Then I thought that maybe it just does not work that well within the block scenes. So I transfered it to LUA (automatic method by Fibaro). The LUA code I get, looks horrendous though. I'm not a developer, but this does not look as very well written code to me. 


Please login or register to see this code.


So here I am, with the big question to you out there: is there anyone who has this working and what code do you have?



Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0

It sounds like your sceneis still running, even when the devices are disarmed. Use the abort or killscene function to stop the scene, when the alarm is disarmed

Link to comment
Share on other sites

  • 0
  • Inquirer
  • Maybe I should have stated it more clearly. My issue is that the alarm is NOT activated. 

    I have opened the door, closed it again and did not disarm in time. The alarm SHOULD now be triggered. Unfortunately it is not. 


    The only way I can trigger the alarm is by leaving the door open for more than 10 seconds. 

    Link to comment
    Share on other sites

    • 0

    Hi @Azkikr ,


    I think that the best way is to use alarm panel.

    First you have to add delay to the sensor for the door. Open door sensor for changing parameters and go to Advanced tab:

    Please login or register to see this spoiler.


    Here you can setup what lights will turn on or send pictures from cameras, send notifications and to turn on sirens you will have to make simple scene that does that (no triggers needed) and then click on Add action button on alarm panel and select that scene as additional action. Of course this scene must have checked option "Don not allow alarm to stop scene.."


    Of course if sensor has delay set like this it should still activate alarm after delay time if alarm is not disarmed. Test it and let us know if it works.

    It was working for me in the past, but now I'm writing more sophisticated alarm system for UHAS so at this moment old code is removed.



    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • Works like a charm. 

    I dismissed the alarm panel quite a while ago as I wasn't able to arm a different set of devices when I was away and when I was at home. 


    Now I see I can use the devices in the alarm panel (remove checkbox). Then I have the option to set the delay (in and out). Still I am able to use my own scenes to arm devices as I like. I don't have to arm the system completely through the alarm panel. 


    Thanks for your respons Sankotronic!

    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Answer this question...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

    • Create New...