Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,


as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.


As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!



Smart Home Forum by FIBARO Team

  • 1

"Requesting neighbours, please wait": eternal loop



When I tried to include a new device (a Sensative Strip), the HC2 responded by displaying the message "Requesting neighbours, please wait" every 5 seconds. The device was not included. I have been through this twice now, once with "Network wide inclusion" checked, the other without. The only way to terminate the loop is to restart the HC2. What is going on? 

My software version is 4.600. I re-meshed the entire network between the first and second attempt, to make sure that the z-wave mesh is OK.

What else can I do?

Link to comment
Share on other sites

Recommended Posts

  • 0

Having the same issue with several new components (thermostats, energy meters, dimmers, relays +++), i really hope the Fibaro Team releases a new update or a guide to fix this problem. I want to integrate more gadgets, but currently it seems nearly impossible.


(HC2, running 4.620)

Link to comment
Share on other sites

  • 0

I'm now experiencing always this issue for any new device added.

Latest devices have been Fibaro RGBW controller, Fibaro Dimmer2, Qubino Roller Shutter, Fiabro Smart implant

Sometimes the adding process get stuck on "Requesting neighbors, please wait" message, sometimes the adding device process end with an unconfigured device.

For the time being the only solution I found is to:

  1. restart the HC2
  2. remove the device if added and not configured
  3. reset the device
  4. restart the HC2
  5. try to add the device again
  6. get back to point 1 in case of fail

 In my specific case I noted this behavior once the amount of connected devices has increased over 40-50 modules.

Latest FW version  4.630 has not fixed the issue

Link to comment
Share on other sites

  • 0

The issue is related to not getting the neighbor list from the included node - due lost communication or falling asleep in case of battery operated devices (sleeping slaves). 
Generally we could implement the timeout which will allow to try again the inclusion but it won't solve not adding a device to the system correctly and there is nothing we can do about this - this is something on protocol level and we do not have any way to altering this behavior. 

We will investigate this one more time and we will try to implement some redundancies there. 

I will let you know if I will know something more.

  • Like 1
Link to comment
Share on other sites

  • 0
17 hours ago, m.roszak said:

this is something on protocol level and we do not have any way to altering this behavior.

I can confirm this with Zniffer: often when neighbours update fails, the communication of the neighbours just isn't okay and from HCs perspective there is not much you can do. IMHO actually the only things you can do is retry this operation (not automatically, but when users asks.... It loads the network). Or Exclude and Include the node, but that might not be ideal either because it might be difficult in its location. It is very difficult to recommend a solution without knowing more about the situation.


I an just saying this because @m.roszak mentioned "it is a protocol thing" which means it is not a HomeCenter issue, if you owned a "Hubitat Hub" in the same network and same circumstances, I am 99% sure it would fail "neighbour update" too.


Note that a device may work without correct update, it can do "direct" communication and "explorer frame". Againm It is very difficult to estimate the impact of the failure without knowing more about the situation.


On 11/6/2020 at 5:18 PM, knuth said:

What else can I do?

Get a long ethernet cable and bring your HC2 closer to the device to include it.

Link to comment
Share on other sites

  • 0

I had the same issue with Fibaro Smart Implant FGBS-222. I removed it from its location and brought it really, really close to my HC2. Only 10 cm apart. It worked without problem. Inclusion was completed in less than 30 sec.

Link to comment
Share on other sites

  • 0

BTW, my experience is that for my system this is a frequent problem with new Fibaro thermostats, but more rare for others. The current workaround I use is to set learning mode to a long time like 900 seconds and for some not fully understood reason it works.


My current suspicion is that if learning mode time-outs while the sometimes really long neighbour requests are still ongoing, then adding devices fails, otherwise it works. I kind of remember that I had really long (infinite?) loops of requesting neighbours before, but I don't have them any more.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...