Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,


as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.


As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!



Smart Home Forum by FIBARO Team

  • 0

Button strange behaviour

Damir Popovic


I have several Fibaro Buttons attached to HC3 and all but one work as expected.


First on all of them whatever I do I have  problem to see whether there is action set on particular event. For example when I go in configuration and set scene on +1 event when I come back to same screen it is always empty. I mean there is no scene title next to +1 icon. It is not huge problem because button works and activates exact scene when I press button. On HC2 it was obvious in the user interface that particular scene is set on particular event.


Second problem is related to particular button. Whenever I set scene to particular event in configuration and wake button, it works only first time when I press it. After that in UI I see only message "Device is awake" and "Transfer OK" but button doesn't show +1 in user interface. I can repeat process as many times as I want and it is always the same. First time works and after that I see only these messages "Device is awake" and "Transfer OK".


When it failed to work with scenes, I tried with associations. To be honest associations would be better choice for me but I have problem with them too. I'm not sure that I understand how these associations should be set and how configure them for +1 or +2 event.


I did soft reconfiguration of the device several times but it didn't help.


Anyway, any advice should be appreciated.


I've always had issues with buttons on my installation but ever since I migrated to HC3 it became very annoying.


Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0

I have a similar problem with two buttons.
It seems that something helped the deflection of the plate inside the button on the side, which I did for the test, but I do not know if this is the problem.
One of the 4 buttons after a soft reconfiguration is no longer visible to the control panel and lies in a cabinet drawer.
There are 3 left of which 2 work.
It seems to me that this is a design flaw of these buttons.
Maybe this plaque flexion will help you because the symptoms are the same as mine.

Link to comment
Share on other sites

  • 0
  • Inquirer
  • I agree with you. I played a bit with this plaque flexion and now button sometimes works and sometimes not.

    We can conclude then that button is not well designed device.


    I also struggle with associations. With second group association I easily can TurnOn SmartImplant Switch but when I configure third group associations on +2 clicks nothing happens in any combination of parameters.


    Do you have experience with these associations?

    Link to comment
    Share on other sites

    • 0

    Hi all,


    Just responded on another post in these forums about the button behavior.


    Try and get the bottom housing spring out, the one that sits below the ( - ) of the battery. You can easily pull it out from the housing by pulling the top metal part.

    Try and carefully expand that bottom spring about 3-5mm so the battery when inserted sits higher in the housing.

    Put it back the same way you took it out.


    Exclude the button from HC and include it again with the usual procedure.


    That solved all my issues with these buttons, they have been consistently working for over 2 months now.


    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Answer this question...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

    • Create New...