Jump to content
Guides for the Forum Read more... ×
Poradniki na Forum Read more... ×
FIBARO Home Center App 1.0.0 - release Read more... ×
FIBARO Home Center App 1.0.0 - wydanie Read more... ×
  • 1
10der

Yet Another lastWorkingRoute visualiser

Question

Please login or register to see this image.

 

fibaro.zip 

   * load.php - please change your credentials to HC2
   * index.html - leave as is

 

 

PS: "Violet" nodes - nodes what have empty routes for some reasons

 

*19/10/2018 17:27  - typo + some minor changes.

*14/09/2018 20:00 - you may search node by masterId or device name / load.php - ignore not -z-wave devices. (thnx @tinman)

*13/09/2018 16:00  - batt & FLiRS devs are marked as gray

* 07/09/2018 01:00 - bugfix with a node orders

* 06/09/2018 23:00 - some minor UI updates

 

 

 

 

 

example load.settings  for load.php

Please login or register to see this code.

 

 

 

 

 

 

 

 

 

 

Please login or register to see this attachment.

Please login or register to see this attachment.

Edited by 10der
  • Like 4
  • Thanks 4

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

An empty frame with this text below.

Relations between the characters of "Les miserables".

Do I need to install something for it to work?

Share this post


Link to post
Share on other sites
  • 0
  • Inquirer
  • php powered http server.

    apache / ngnix /etc

    Edited by 10der

    Share this post


    Link to post
    Share on other sites
    • 0
  • Inquirer
  • @RH_Dreambox Hi!

     

    a have updated html code.

    now you do not need any php.

    but you should get manually devices.json and rooms.json.

    simply save this requests and put with index.html

     

    http://192.168.1.36/api/rooms

    http://192.168.1.36/api/devices

     

    where 192.168.1.36 HC2 ipAddress 

     

    Please login or register to see this image.

     

     

    Edited by 10der

    Share this post


    Link to post
    Share on other sites
    • 0

    Sorry 10der, but it will not work for me :-( What can I do more to get it to work?

     

     

    Please login or register to see this attachment.

    Please login or register to see this attachment.

    Share this post


    Link to post
    Share on other sites
    • 0
  • Inquirer
  • browser console can say more than you :)

    Edited by 10der

    Share this post


    Link to post
    Share on other sites
    • 0

    In Firefox and Edge OK,

    Chrome and IE don't work

     

    thanks!

     

     

    Edited by petrkl12

    Share this post


    Link to post
    Share on other sites
    • 0
  • Inquirer
  • fixed!

     

    Please login or register to see this image.

    Chrome OK!

     

    Edited by 10der

    Share this post


    Link to post
    Share on other sites
    • 0
  • Inquirer
  • now I am trying to call load.php

    load.php - generate devices.json & rooms.json

    index.html load it.

    if load.php not found (404) index.html ignore this event and trying to load devices.json & rooms.json hope what these files already exists

     

    load.php attached as well

     

     

     

     

     

    Edited by 10der

    Share this post


    Link to post
    Share on other sites
    • 0

    Tested latest version...

    Chrome :-(                  Version 68.0.3440.106 (Officiell version) (64 bitar)

    Internet Explorer :-(   Version 11.228.17134.0

    Edge :-D                        Microsoft Edge 42.17134.1.0

    Share this post


    Link to post
    Share on other sites
    • 0
  • Inquirer
  • 1 minute ago, RH_Dreambox said:

    Tested latest version...

    Chrome :-(                  Version 68.0.3440.106 (Officiell version) (64 bitar)

    Internet Explorer :-(   Version 11.228.17134.0

    Edge :-D                        Microsoft Edge 42.17134.1.0

     

    you stll not providing more information from developer JS console!!!!

    Share this post


    Link to post
    Share on other sites
    • 0

    Sorry, but I would just do it :-)

     

    jquery-3.3.1.min.js:2 Failed to load file:///E:/Fibaro/Fibaro%20route/load.php: Cross origin requests are only supported for protocol schemes: http, data, chrome, chrome-extension, https.
    send @ jquery-3.3.1.min.js:2
    jquery-3.3.1.min.js:2 Failed to load file:///E:/Fibaro/Fibaro%20route/devices.json?format=json: Cross origin requests are only supported for protocol schemes: http, data, chrome, chrome-extension, https.

    Share this post


    Link to post
    Share on other sites
    • 0
  • Inquirer
  • lol!

    you trying to open index.html  without http server? just by click and open file in browser?

    lol! mega lol.

    Share this post


    Link to post
    Share on other sites
    • 0

    lol, he he

    But i have devices.json and rooms.json in the same directory (manually created).

    But I will try to move the PHP-file.

    Share this post


    Link to post
    Share on other sites
    • 0
  • Inquirer
  • Please login or register to see this link.

    Share this post


    Link to post
    Share on other sites
    • 0

    Hmmm, I think this goes beyond my capacity.
    I will try installing web server and PHP server on a Raspberry and see if it works.
    Otherwise, I'll use Edge when I want to check the routing :-P

    Share this post


    Link to post
    Share on other sites
    • 0
  • Inquirer
  • 4 hours ago, RH_Dreambox said:

    Hmmm, I think this goes beyond my capacity.
    I will try installing web server and PHP server on a Raspberry and see if it works.
    Otherwise, I'll use Edge when I want to check the routing :-P

    btw,

     

    windows.

     

    1) download 

    Please login or register to see this link.

    2) unpack (for example C:\PHP)

    3) create dir (as I can see you already) fibaro. copy files from this thread

    4) run at current dir c:\php\php -S localhost:8000
    6)

    Please login or register to see this link.

     ta da! 

     

    Edited by 10der
    • Thanks 1

    Share this post


    Link to post
    Share on other sites
    • 0

    10th, thanks for all the help to a novis man :oops:
    Now it works perfectly. I have two HC2 so I had to make double files index-11.html, load-11.php, index-18.html and load-18.php.
    It took a while before I understood what you mean and how it would be, but after some hard work in the garden everything worked out for me :-D

    This was amazingly good! It should have been integrated into HC2 a long time ago.
    But unfortunately, Fibaro's development department does not recognize what features are needed and what we users want.

    Thank you very much for this!

    Share this post


    Link to post
    Share on other sites
    • 0

    Thanks a lot @10der !

     

    Question about the violet ones. What do you mean with "empty routes" ?

    The violet ones seems to have a connection to the HC2 like others, whats the differents?

     

    Share this post


    Link to post
    Share on other sites
    • 0
  • Inquirer
  • Just now, Remi said:

    Thanks a lot @10der !

     

    Question about the violet ones. What do you mean with "empty routes" ?

    The violet ones seems to have a connection to the HC2 like others, whats the differents?

     

     

    []

     

    Please login or register to see this image.

    Share this post


    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

    ×