Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 0

HC3-HTTPS access


cag014
 Share

Question

Is anyone has succeed to use https connection?

 

I did follow Fibaro's procedure to install certification

  1. Download the certificate.
  2. In the Windows Start menu search for mmc app and open it.
  3. In the MMC (Microsoft Management Console) app go to File > Add/Remove Snap-In.
  4. Add Certificate Snap-in:
  5. Certificates > Select “Computer account” > Next > Next > OK.
  6. Now go to Certificates > Trusted Root Certification Authorities and right-click on “Certificates”
  7. Import the certificate.
  8. Find the certificate downloaded from the FIBARO Home Center 3.
  9. Import it.
  10. Done.
  11. Your connection with the gateway is now secure.

but doesn't work on FIrefox. (Expiration date ?)

Please login or register to see this spoiler.

 

Any extra steps required to install certification?

Interesting it does work with Chrome !!??

Edited by cag014
Link to comment
Share on other sites

11 answers to this question

Recommended Posts

  • 0

just set in Firefox to not ask bt to chose automatically the certificate

 

 

Edited by tinman
Link to comment
Share on other sites

  • 0
  • Inquirer
  • 2 minutes ago, tinman said:

    just set in Firefox to not ask bt to chose automatically the certificate

    Did it doesn't help. See below

    Please login or register to see this spoiler.

     

    Edited by cag014
    Link to comment
    Share on other sites

    • 0

    security.enterprise_roots.enabled to true on the about:config 

    • Like 1
    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • Thaaaaaaaaaaanks... now it works.

    Looks like you're expert on security, may I ask how can I use https on my mobile phone using browser? (I have fixed IP and don't use fibaro's remote access). I believe it now router security issue, right?

    Fibaro should add this instruction to their procedure...

    Edited by cag014
    Link to comment
    Share on other sites

    • 0

    Yes, Fibaro could create something in faq, but actually on mobile devices one can use Fibaro app, which is secure(d). When using mobile browser apps, it depends on OS/app/verison … so not easy to describe "the working" Setup. One can of course download the certificate from http://HC3-IP/api/settings/certificates/ca on any device and install it, on ios actually twice (install, agree, install  in Settings, similar to Fibaro Intercom certificate Installation). However, depends on the mobile browser app/device type, you might have no chance to autoaccept Fibaro's cert in the mobile browser app (which is not a real issue, but it 'sucks' to click twice). Brave is sometimes OK; Firefox as always the last s**, Safari ? not using anymore ^^ 

     

    The additional problem might be DNS Resolution on mobile devices,  when accessing remotely  you might not be able to resolve your HC3 with the name, and when you go over IP the certificate will be displayed as not valid, which means extra 1-2 clicks necessary to use it anyway. Now having https "one could" left the hc3 open to internet, i still prefer vpn. The Home Center App, which is necessary to work with HC3, does not save local connections, so again one need to click/type bit more, Luckily there are other apps available.

     

     

     

    Edited by tinman
    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • @tinman

    Thanks for sharing that.

    Eventually it works fine (except security warning on mobile browser) by forwarding port on router to https port (443).

    Now HC3 configured to accept https connection only and it works on LAN and WAN.

    Thank you again.

    Link to comment
    Share on other sites

    • 0

    Hi, Same problem here,

    installed the ca.cer and set the secure connection to https.

    Where can I find that  about:config?

    Link to comment
    Share on other sites

    • 0

    Ok,? hmmm. Thanks.

    I think my problem is MS-edge.
    even edge://
    about:config is not possible.

     

    In edge://settings/privacy there is a certificate section. 
    in there I see the Fibar cer. But still no https.

     

    Open the HC3 not by IP but by is name (like the HC3 manual explaned) helped.

    like : '

    Please login or register to see this link.

    '

    now its a secured line..

     

    Edited by NLWaard
    login by name
    Link to comment
    Share on other sites

    • 0

    Hi, has there been any change? I can not find the ca.cer .  I use Edge. 

    thanks for the help

    Please login or register to see this image.

    /monthly_2021_06/Unbenannt11.PNG.3a141482fcee6924540fb25aa5cca913.PNG" />

    Edited by Berti
    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Answer this question...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

     Share

    ×
    ×
    • Create New...