Jump to content

Recommended Posts

  • Replies 167
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

hi!   here is my new node-red node for FIBARO HCx   https://flows.nodered.org/node/node-red-contrib-fibaro-devices   now you can use finaroSenor node - for any sensors in

.41 nothing new just "glamour"      

hi @petrho you get the status with Actornode when you enable the "event passtrough" 

Posted Images

docs

Thermostat heating temperature
http://api/callAction?deviceID=1483&name=setThermostatSetpoint&arg1=1&arg2=28

so

{
    "TurnOn25": {
        "name": "setThermostatSetpoint",
        "arg1": 1,
        "arg2": 25
    },
    "TurnOff17": {
        "name": "setThermostatSetpoint",
        "arg1": 0
    }
}

 

Link to post
Share on other sites

I send as string but, I don't why its not work after upgrade to 0.18. Before work fine. 

Link to post
Share on other sites
4 minutes ago, drboss said:

I send as string but, I don't why its not work after upgrade to 0.18. Before work fine. 

[{"id":"f0b09729.674408","type":"inject","z":"e79a9ba6.0d0a38","name":"","topic":"1483","payload":"TurnOn25","payloadType":"str","repeat":"","crontab":"","once":false,"onceDelay":0.1,"x":240,"y":520,"wires":[["687a2a29.e3cee4"]]},{"id":"687a2a29.e3cee4","type":"fibaroXActor","z":"e79a9ba6.0d0a38","name":"Ololo","deviceID":"1483","server":"5792011b.3ca98","events":false,"payload":"{\"TurnOn25\":{\"name\":\"setThermostatSetpoint\",\"args\":[1,25]},\"TurnOff17\":{\"name\":\"setThermostatSetpoint\",\"args\":[1,25]}}","outputs":0,"x":430,"y":520,"wires":[]},{"id":"5792011b.3ca98","type":"fibaro-server","z":"","name":"HC2","ipaddress":"192.168.1.36"}]

be careful after import node-red added fake HC2 server with empty params - please remove it and choose rigth!

Edited by 10der
Link to post
Share on other sites

not work :(

[{"id":"2725cd3e.d26af2","type":"inject","z":"c4f9a476.cffd58","name":"","topic":"1612","payload":"TurnOn25","payloadType":"str","repeat":"","crontab":"","once":false,"onceDelay":0.1,"x":820,"y":1300,"wires":[["f9489b07.21836"]]},{"id":"f9489b07.21836","type":"fibaroXActor","z":"c4f9a476.cffd58","name":"Ololo","deviceID":"1612","server":"f5f483ca.24db28","events":true,"payload":"{\"TurnOn25\":{\"name\":\"setThermostatSetpoint\",\"args\":[1,25]},\"TurnOff17\":{\"name\":\"setThermostatSetpoint\",\"args\":[1,17]}}","outputs":1,"x":1010,"y":1300,"wires":[["4407bf9a.b7fd5"]]},{"id":"2040cdf9.39b89a","type":"inject","z":"c4f9a476.cffd58","name":"","topic":"1612","payload":"TurnOff17","payloadType":"str","repeat":"","crontab":"","once":false,"onceDelay":0.1,"x":820,"y":1340,"wires":[["f9489b07.21836"]]},{"id":"4407bf9a.b7fd5","type":"debug","z":"c4f9a476.cffd58","name":"","active":true,"tosidebar":true,"console":false,"tostatus":false,"complete":"true","targetType":"full","x":1170,"y":1300,"wires":[]},{"id":"f5f483ca.24db28","type":"fibaro-server","z":"","name":"HC2","ipaddress":"192.168.1.200"}]

 

Link to post
Share on other sites

przyjacielu

image.png.59eff6982ba82415375f51468f781412.png

 

 

image.png.a56bfff25c6ef16c594260271f76dca4.png

 

is any diff?

 

 

 

 

Edited by 10der
  • Thanks 1
Link to post
Share on other sites

When I open forum topic to write that I find error:

{
    "Test1": {
        "name": "setThermostatSetpoint",
        "arg1": 1,
        "arg2": 25
    },
    "Test2": {
        "name": "setThermostatSetpoint",
        "arg1": 1,
        "arg2": 17
    }
}

I read that You find my problem too. Thanks ;-)

I confirm for thermostat it's work, but in the older version (before 0.18) I sure that list of args [ ] work fine because I use it :-) in "production"

 

Second observation for thermostat "sensor" - module "type": "com.fibaro.operatingMode" . If module change property.state ex from 1 - heating to 0 - off or from 2 - cooling to 0 the "Sensor" report changing of property.mode to 0. But when you check in HC2 (via api or www) the mode stay set to 1 (for heatnig) or 2 (if you set before cooling)

The same situation is happen if  module "type": "com.fibaro.operatingMode" start working and change property.state to heating or cooling. In this case "sensor" report that "mode" set to 1 or 2 on place to report "state" change.

image.png.042c2dd5f3a32ee396028765d2291ef5.png

         state                              heating

this happen if "Handle additional events" is uncheked, but if you check this box the reports is ok.

 

image.png.2d4cf70b2c5494a0769bd5ba3b55df67.png

 

Tested on version .20

ps. I have read that You will abandon HC2 :-(, when I after starting use your project I decided to keep using it.

To what platform are you migrating your HA? I started testing the RPI with z-wave module, but I not ready to migrate yet. Ofcorse I stay with z-wave in my home and apartments of parents because I have more z-wave devices that others but time to time I test zigbee, BLE etc.

Stay with as ;-)

 

 

Edited by drboss
Link to post
Share on other sites

Version 0.20

When I connect a Fibaro wallplug and toggle on or off - I get a lot of true/falses (8 times) and also a bunch of undefined (>10 times)

Is it still code debug info?

 

 

Annotation 2020-01-17 134050.png

Edited by petrho
Link to post
Share on other sites
On 1/17/2020 at 2:43 PM, petrho said:

on or off - I get a lot of true/falses (8 times) and also a bunch of undefined (>10 times)

Is it still code debug info?

OMG :( it’s wrong behavior 

something wrong!
i am can’t help you right not I am in work trip and back to home at Friday 

sorry. You can as to help @drboss he is professional here he knows how it should work 

Link to post
Share on other sites

"undefined" happen if device haven't property "VALUE" ex garage door controllers, some thermostats who reported state by property STATE , or if device send status unknow. In this situation fibaro raport for VAULE = nil, not 0 or false or not report VALUE via API.

Link to post
Share on other sites
11 hours ago, drboss said:

undefined" happen if device haven't property "VALUE"

Query node by default check “value” but we can pass to in property “mode” etc and this node can check any properties for device 

JFYI

Link to post
Share on other sites

thx, in next week I will start read your source for understanding 

  • Thanks 1
Link to post
Share on other sites

This is strange. I still get 8 debug messages when I toggle my wallplug...

C0DA49F0-40FC-4BDF-86CE-C0C0649728FE.jpeg

Link to post
Share on other sites

@10der Hi, i have the same behavior with multiple messages.  After first deploy the sensor node and first time trigger they are eight.

But after multiple trigger the count of messages varies from one to eight  . Sometimes is only one msg  for ON and multiple for OFF, 

and next time reversely.

 

Link to post
Share on other sites

It’s crazy. You are on latest version?! 
can you turn on debugging 

I wanna to know how many messages in output 

In version < 25 was a bug 

messages occurred according to count devices you use 

for example if you have 5 devices with ID 123 messages will be 5

its was a very strange bug what  fixed in .25 version 

Edited by 10der
Link to post
Share on other sites
2 hours ago, petrho said:

This is strange. I still get 8 debug messages when I toggle my wallplug...

C0DA49F0-40FC-4BDF-86CE-C0C0649728FE.jpeg

 btw - golvlampa - torchere = Торшер ZUMALINE  (Польша) 78403 в стиле модерн. Тип источника света: светодиодные led, энергосберегающие, накаливания. Цвета плафонов и подвесок: серый. Материал: металл.  Фото 1

 

i'ts NOT a SENSOR like you use! it's ACTOR!!!!!

image.png.8806506a3c402c4a8969d890cbb45194.png

 

sensor is - humidity sensor / temperature sensor or dorr window sensor but sensor is NOT a swithc / lamp / etc - it's actor!

 

 

 

Edited by 10der
Link to post
Share on other sites

sorry  @10der now is this clear for me . i used a switch for testing too, not sensor.

with the  sensor it works .  

thanks

Link to post
Share on other sites
19 minutes ago, 10der said:

 btw - golvlampa - torchere = Торшер ZUMALINE  (Польша) 78403 в стиле модерн. Тип источника света: светодиодные led, энергосберегающие, накаливания. Цвета плафонов и подвесок: серый. Материал: металл.  Фото 1

 

i'ts NOT a SENSOR like you use! it's ACTOR!!!!!

image.png.8806506a3c402c4a8969d890cbb45194.png

 

sensor is - humidity sensor / temperature sensor or dorr window sensor but sensor is NOT a swithc / lamp / etc - it's actor!

 

 

 

Ok I thought it was possible to use this component to get status of the switch...

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...