Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


  • 0

Home Center 3 - issues with accepting the HC app?


P77
 Share

Question

Hi there,

 

I know that this question may be better suited under the Home Center mobile application section, but at the same time - not.. I'll explain throughout the post why!

 

The background (to start with);

 

I recently bought one Home Center 3 device to try the new unit after having a great configuration with three HC2 units at my house and two appartments that I own.

The first issue was of course the migration from HC2 to HC3. Frustrated over the fact that I needed to se up everything. Rooms and Sections should have been easy to move. The devices - ok.. I get why.. I can take that I needed to add them in the new system.

 

So - to make a long story short(er)..

I added everything, and got my house configured fine - and I've even managed to rewrite all the scripts except for one detail (a pause which could be used in the LUA-script before was used to wait for five minutes before turning bathroom lights off automatically when no motion detector had detected any new movement in the room). But other than that - I've managed to get everything up and running quite ok. So - to the problem description:

 

As the Fibaro Home Center mobile app is not working for Home Center 3, I had to overcome the fact that I was forced to use the "new" Home Center app. Horrible as that is, it's just a fact.

But - regardless if I have my Android devices which are; Samsung Z Flip, Huawei P30, Huawei P10 Plus, Samsung Galaxy S20 or the apple device; iPhone 10 - I get the same problem. 

 

The problem:

 

The first time I start the Mobile App, everything works just fine, and I can use it as expected. But..

The second time I start the app I get stuck with this screen. I know.. In Swedish, but if you ever used the app, you know that this screen is when you would expect the application to log in to your system.

 

Please login or register to see this image.

 

When I start up the app for the first time after installing the app - everything works just fine as I said.

The second time though.. not so functional as this is all I get. Regardless of which phone I use. But - this ONLY refers to Home Center 3 - which is why I think it's a HC3 issue rather than the mobile app - as this is regardless of Apple or Android. When I use the app with my Home Center 2 devices that I still have, everything works just fine. Time after time when I log in on HC2, it just works as expected. But as soon as I switch to HC3 - the screen above is all I see.. for the rest of my life (or until I choose to scrap all data for the app/or reinstall the app).

 

So, the solution thus far;

1. Open the apps in the mobile phone settings and delete ALL data (not just the cache)

2. Start the app again, and do all the initial settings and choose "Skip" for the welcome wizards that are shown just as if the app was freshly installed

3. Operate the app as normal

4. But.. When I close the app, or don't use it for 15 minutes or so - I have to start over with number 1 in this solution to be able to use the app. Frustrating!!!

 

Or...

 

1. Uninstall the app

2. Install the app.

3. Do all setup-things (login, skip wizards etc)

4. Operate as normal

5. Start over on 1 in this solution.. (frustrating... again)

 

So - Is there anyone that have the same issue?

Or - does anyone have HC3 functioning properly with the Home Center mobile app?

 

Because - I'd think that it just may be my device that needs an upgrade or something?

 

The MOBILE app (Android) is version: 1.6.0

The Home Center 3 software/firmware version is: 5.020.60

 

Appreciate any thoughts/tips about this issue.

 

Thanks for reading!

 

/Peter

 

 

 

Please login or register to see this attachment.

Link to comment
Share on other sites

13 answers to this question

Recommended Posts

  • 0

I haven't had the issue you describe (iOS app, though), but the app is seriously buggy. Hopefully they will release a new app together with the long overdue update of the HC3 firmware.

Edited by robw
  • Like 1
Link to comment
Share on other sites

  • 0
  • Inquirer
  • 1 hour ago, robw said:

    I haven't had the issue you describe (iOS app, though), but the app is seriously buggy. Hopefully they will release a new app together with the long overdue update of the HC3 firmware.

     

    Right - but your environment works that is?

    iOS Home Center app together with Home Center 3 device?

     

    I have one iPhone (iOS device) using Home Center 3 with this issue happening. 

     

    What version of the HC3 do you have installed? (ie. Did you update the HC3 right after installation?)

     

    Link to comment
    Share on other sites

    • 0
    17 minutes ago, P77 said:

     

    Right - but your environment works that is?

    iOS Home Center app together with Home Center 3 device?

     

    I have one iPhone (iOS device) using Home Center 3 with this issue happening. 

     

    What version of the HC3 do you have installed? (ie. Did you update the HC3 right after installation?)

     

     

    Yes, my environment works. The firmware on the HC3 is 5.020.60. It came installed with that firmware, and there is no new firmware when I checked (and I've checked a lot, hoping the new delayed firmware would come). IOS app version 1.8.0.

     

    But there are several know bugs, like it does not scale to fit tablets, Quick apps does not show up correctly (or at all), Hue lamps does not show at all to name those I know of. Then I think there is a lot to do about the UI in itself - it is not so user friendly IMHO. The most critical wish for me, is that I want to be able to pin Favorite scenes in the UI and make them stick there in the order I want to.

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • 12 minutes ago, robw said:

     

    Yes, my environment works. The firmware on the HC3 is 5.020.60. It came installed with that firmware, and there is no new firmware when I checked (and I've checked a lot, hoping the new delayed firmware would come). IOS app version 1.8.0.

     

    But there are several know bugs, like it does not scale to fit tablets, Quick apps does not show up correctly (or at all), Hue lamps does not show at all to name those I know of. Then I think there is a lot to do about the UI in itself - it is not so user friendly IMHO. The most critical wish for me, is that I want to be able to pin Favorite scenes in the UI and make them stick there in the order I want to.

     

    Right - so we use the same software versions. Then this has to do with something else obviously - as you're able to use your setup without problems.

    I had to upgrade to a newer version of the firmware of the HC3 box when it came though. Can't remember which version I had - but that was done during the setup of the controller.

     

    Yeah, I know what you mean by the UI limitations. It's of course important for them to fix - and I guess they will.. sometime.. I'd like a massive redo on the entire UI.. But - first I need to be able to use it. Currently it's a bit frustrating to not be able to log in at all if not clearing all data first. It's a very strange issue for me.

     

    I will try Homeseer in the meantime. Seems to be better suited for me now when they have done such a big mess of everything. :/

     

    Link to comment
    Share on other sites

    • 0
    3 minutes ago, P77 said:

     

    I will try Homeseer in the meantime. Seems to be better suited for me now when they have done such a big mess of everything. :/

     

     

    If things are not going better with Fibaro, I will test to move things to Home-assistant. I've got myself a new Pi4, and a Zigbee USB stick. I already have a Zwave USB-stick for the Pi. In that way I can use both Zwave and Zigbee (which HC3 was supposed to have - was marketed to have), but failed to deliver so far. I know, it will come later, but later is later. Having bought a 600 euro home controller which was marketed to have Zigbee functional, only to see that it does not work when I got it home, made me quite upset.

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • 1 minute ago, robw said:

     

    If things are not going better with Fibaro, I will test to move things to Home-assistant. I've got myself a new Pi4, and a Zigbee USB stick. I already have a Zwave USB-stick for the Pi. In that way I can use both Zwave and Zigbee (which HC3 was supposed to have - was marketed to have), but failed to deliver so far. I know, it will come later, but later is later. Having bought a 600 euro home controller which was marketed to have Zigbee functional, only to see that it does not work when I got it home, made me quite upset.

     

    Good call I'd think. And you could use Homeseer on the Pi4 as well if you'd like. I think you may enjoy it. ;)

     

    • Like 1
    Link to comment
    Share on other sites

    • 0
    3 minutes ago, P77 said:

     

    Good call I'd think. And you could use Homeseer on the Pi4 as well if you'd like. I think you may enjoy it. ;)

     

     

    Might check out Homeseer, too :)

     

    • Like 1
    Link to comment
    Share on other sites

    • 0

    @P77  if you have your HC3 connected via WiFi to your network, the fix has already been developed and will be available in version 1.7.0

    If you are willing to test it right now, you are more than welcome to join the Beta Program. Just use one of your Android devices, and select "Join to beta" in app description in Google Play.

    Link to comment
    Share on other sites

    • 0

    Please login or register to see this link.

     

    Please login or register to see this link.

    I would like to take part in the beta program for the iOS version so that all German translations are correct. I also actively participated in Homey.

    Link to comment
    Share on other sites

    • 0
    19 minutes ago, K.Drozynski said:

    @P77  if you have your HC3 connected via WiFi to your network, the fix has already been developed and will be available in version 1.7.0

    If you are willing to test it right now, you are more than welcome to join the Beta Program. Just use one of your Android devices, and select "Join to beta" in app description in Google Play.

     

    Is there a beta for the iOS app? If so, I'd like to beta test that. Been doing some betatesting for various companies.

    Link to comment
    Share on other sites

    • 0

    In comparison to Android Beta program, iOS Beta Testing is a more complex process. At this point we won’t be able to provide you with an early access to iOS version of the app. We appreciate your commitment and we will try to change that in the future.

    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • 2 hours ago, K.Drozynski said:

    @P77  if you have your HC3 connected via WiFi to your network, the fix has already been developed and will be available in version 1.7.0

    If you are willing to test it right now, you are more than welcome to join the Beta Program. Just use one of your Android devices, and select "Join to beta" in app description in Google Play.

     

    GREAT!! Thanks!!

    I appreciate the quick response - and that the solution was in reach. That helped a lot!

     

    /Peter

     

    Edited by P77
    Link to comment
    Share on other sites

    • 0
  • Inquirer
  • 19 hours ago, robw said:

     The most critical wish for me, is that I want to be able to pin Favorite scenes in the UI and make them stick there in the order I want to.

     

    Hi again robw,

    I think you will be able to enjoy version 1.7.0  when it comes. I tested the new favorites configuration options, and they will meet your hopes I think. ;)

    • Like 1
    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Answer this question...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

     Share

    ×
    ×
    • Create New...