Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


iOSLocator


Recommended Posts

  • Topic Author
  • Have you set the QA property in the configuration for the users?

    HomeStatus works ok for me. Have you set the home property in the config?

    Are you sure it's not just an UI update bug?

    Link to comment
    Share on other sites

    9 hours ago, ChristianSogaard said:

    some comment for this version.

    Im getting "Home status: Unknown" all IOS users has polled successfully.

    My 4th user (Marius) is not counted in - only the 3 primary IOS accounts are here.

    And - It created all the childs, when importing the QA - but when i replaced the users with my own. The QA cleaned up the Childs, but did not create new ones for my users.

     

    HC3USERS = {
      {deviceName='OtherPhone', name='Marius', id=949, home=true}
    }

     

    Please login or register to see this attachment.

     

     

    Also have the same problem. Only 1 user/phone was registered.

    Link to comment
    Share on other sites

  • Topic Author
  • 18 hours ago, ChristianSogaard said:

    some comment for this version.

    Im getting "Home status: Unknown" all IOS users has polled successfully.

    My 4th user (Marius) is not counted in - only the 3 primary IOS accounts are here.

    And - It created all the childs, when importing the QA - but when i replaced the users with my own. The QA cleaned up the Childs, but did not create new ones for my users.

     

    HC3USERS = {
      {deviceName='OtherPhone', name='Marius', id=949, home=true}
    }

     

    So Marius doesn't have the QA key so he will not get an QA.

    Marius doesn't have an iOS account (he's only a HC3 user) so he's not listed among the accounts.

    Because users are kind of disconnected to iOS accounts  (one iOS account can have several users, and some users don't belong to an iOS account but is only HC3 users) the reported accounts is not the number of users.

    I guess next version could report number of users too.

     

    Do you see in the log that the iOS users are polled correctly?

     

    I just realised that if Marius don't get any HC3 location events he will be at an unknown place until he moves.

    The problem I have is that I can't read any location data for HC3 users - I need to wait for the events.

    • Thanks 1
    Link to comment
    Share on other sites

    2 hours ago, jgab said:

     

    So Marius doesn't have the QA key so he will not get an QA.

    Marius doesn't have an iOS account (he's only a HC3 user) so he's not listed among the accounts.

    Because users are kind of disconnected to iOS accounts  (one iOS account can have several users, and some users don't belong to an iOS account but is only HC3 users) the reported accounts is not the number of users.

    I guess next version could report number of users too.

     

    Do you see in the log that the iOS users are polled correctly?

     

    I just realised that if Marius don't get any HC3 location events he will be at an unknown place until he moves.

    The problem I have is that I can't read any location data for HC3 users - I need to wait for the events.

    IOS Users are polled correctly

    02.07.2022] [11:17:50] [DEBUG] [QUICKAPP1653]: Matched device silje :)(iPhone X) for user Silje
    [02.07.2022] [11:18:19] [DEBUG] [QUICKAPP1653]: Next polling in 30s
    [02.07.2022] [11:18:20] [DEBUG] [QUICKAPP1653]: Matched device Ea iPhone 11(iPhone 11 Pro) for user Ea
    [02.07.2022] [11:18:49] [DEBUG] [QUICKAPP1653]: Next polling in 30s
    [02.07.2022] [11:18:50] [DEBUG] [QUICKAPP1653]: Matched device Dr. Søgaard(iPhone 13 Pro Max) for user Christian

     

    Marius don't get any HC3 location. - this seems correct. Is is probably a bug at Fibaro, he is using Android.

     

    Still the Child sensors are missing. I tried saving the QA again to restart, but no luck for creating the childs

     

    Link to comment
    Share on other sites

  • Topic Author
  • 3 hours ago, ChristianSogaard said:

    Marius don't get any HC3 location. - this seems correct. Is is probably a bug at Fibaro, he is using Android.

    Ok

    3 hours ago, ChristianSogaard said:

    Still the Child sensors are missing. I tried saving the QA again to restart, but no luck for creating the childs

     

    Did you change Marius config to

    HC3USERS = {
      {deviceName='OtherPhone', name='Marius', id=949, home=true, QA='Marius'}
    }

    ?

    Link to comment
    Share on other sites

    1 hour ago, jgab said:

    Ok

    Did you change Marius config to

    HC3USERS = {
      {deviceName='OtherPhone', name='Marius', id=949, home=true, QA='Marius'}
    }

    ?

    somehow the QA paramenter slipped for me - now i get that part .-) Now i have childs for all users

    Link to comment
    Share on other sites

    17 hours ago, jgab said:

    Have you set the QA property in the configuration for the users?

    HomeStatus works ok for me. Have you set the home property in the config?

    Are you sure it's not just an UI update bug?

    I changed information about users and iCloud account. Code about another users was deleted. Need I do anything else? In console phone was detected at first time (1-2h), after that QA was “fall in sleep” and not done anything. Also Home status was identified as unknown at all time. I’m beginning, so may be I do something wrong( Thanks!

    Please login or register to see this attachment.

    Please login or register to see this attachment.

    Link to comment
    Share on other sites

  • Topic Author
  • Yep there was a bug with all at home detection. Fixed in v0.44

    The QA issue I can't find what it is. Works for me as long as you set the QA property of the user

    The HC3-only user is still not optimal... probably needs to wait for a better HC3 location handling

    Please login or register to see this attachment.

     (0.44)

     

    So, the Hue app can give location for users but it's still not implmented in the v2 api...

    • Thanks 1
    Link to comment
    Share on other sites

  • Topic Author
  • So, a possible hack for android users would be to use the IFFFT application.

    Set up a IFFFT applet that call a fibaro scene when it enters the home and when it exits the home.

    and use it from the IFFFT application on Android.

    In the fibaro script post a fibaro geofence event

    Ex.
        return api.post("/events/publishEvent/GeofenceEvent",
          {
            deviceId = 99, -- QA id
            userId    = userId, -- user ID, ex 2 for admin
            locationId    = locationId,  -- location id, usually 219 for home
            geofenceAction = "enter",  -- or "leave"
            timestamp = os.time()
          })

    Link to comment
    Share on other sites

    Jan, how can I use the total home=true  number of users?

    Also the home=false total number of users?

    Both to check if occupation is correct if we have guests or not.

    Thanks in advance,

    //Sjakie

    Link to comment
    Share on other sites

  • Topic Author
  • 7 minutes ago, Sjakie said:

    Jan, how can I use the total home=true  number of users?

    Also the home=false total number of users?

    Both to check if occupation is correct if we have guests or not.

    Thanks in advance,

    //Sjakie

    Well, there is no easy way to do it today (need to loop through the Users quickVar and recount) , but I will add it in the next release.

    Link to comment
    Share on other sites

    Thanks Jan I am not in a hurry.

    Nice weekend

    Link to comment
    Share on other sites

    Posted (edited)
    3 hours ago, jgab said:

    Yep there was a bug with all at home detection. Fixed in v0.44

    The QA issue I can't find what it is. Works for me as long as you set the QA property of the user

    The HC3-only user is still not optimal... probably needs to wait for a better HC3 location handling

    Please login or register to see this attachment.

     (0.44)

     

    So, the Hue app can give location for users but it's still not implmented in the v2 api...

    Is it possible to use value of user and home globalvar in block scene?

    If I check this globalvar in console, it determines correctly.

    For example this scene not working:( 

     

    {                                                                            fibaro.call(305, 'turn on')
      conditions = { {
          isTrigger = true,
          operator = "==",
          property = "iOSHome",
          type = "global-variable",
          value = "all_home"
        } },
      operator = "any"
    }

     

    3 hours ago, jgab said:

    Yep there was a bug with all at home detection. Fixed in v0.44

    The QA issue I can't find what it is. Works for me as long as you set the QA property of the user

    The HC3-only user is still not optimal... probably needs to wait for a better HC3 location handling

    Please login or register to see this attachment.

     (0.44)

     

    So, the Hue app can give location for users but it's still not implmented in the v2 api...

    Now home status works correctly, thanks.

    Edited by Ievgenii
    Link to comment
    Share on other sites

  • Topic Author
  • Posted (edited)
    52 minutes ago, Ievgenii said:

    Is it possible to use value of user and home globalvar in block scene?

    If I check this globalvar in console, it determines correctly.

    It's kind of a bug - it remembers the old homeState when starting up and will not send a trigger when the variable changes  "all_home" again.

    The fix is to clear the HomeVar when the QA starts.

    I will add it to the next version.

    For now you can go into the QA and the iOSLocation file and on line ~454 add one line

    Please login or register to see this code.

    It will be there in the next version -probably tomorrow.

    Edited by jgab
    • Thanks 1
    Link to comment
    Share on other sites

    6 hours ago, jgab said:

    So, a possible hack for android users would be to use the IFFFT application.

    Set up a IFFFT applet that call a fibaro scene when it enters the home and when it exits the home.

    and use it from the IFFFT application on Android.

    In the fibaro script post a fibaro geofence event

    Ex.
        return api.post("/events/publishEvent/GeofenceEvent",
          {
            deviceId = 99, -- QA id
            userId    = userId, -- user ID, ex 2 for admin
            locationId    = locationId,  -- location id, usually 219 for home
            geofenceAction = "enter",  -- or "leave"
            timestamp = os.time()
          })

    Unfortunatelly even IFTTT did not solve it. I have set up a simple IFTTT applet that should run my scene when I enter the geofencing area, but the applet had never triggered so far. I have tried to link it with some device (not a scene), just to be sure, that there is no problem with the scene itself, but nothing happened. Once I could see a notification that yubii has asked for location, but it was only once for all.

    And even in that case, this notification has come 6 hour after i actually entered the area.

    Link to comment
    Share on other sites

  • Topic Author
  • It’s the IFTTT app on the mobile that sends the location

    Link to comment
    Share on other sites

    2 hours ago, jgab said:

    It’s the IFTTT app on the mobile that sends the location

    Yes ofcourse

    Link to comment
    Share on other sites

    Hi Jgab

     

    One thought - now you are spending time on the iOSLocator 

    The lowest line - saying "User Ea at Home" - perhaps you want to add status of all users here? 

    Only 1/3 users is shown here, or you could list the users at home :-)

     

    2022-07-04_13-39-23.png.7810e819768bfaeac6a2058bffd9222c.png

     

    Link to comment
    Share on other sites

    Posted (edited)
    On 7/3/2022 at 1:58 PM, jgab said:

    It's kind of a bug - it remembers the old homeState when starting up and will not send a trigger when the variable changes  "all_home" again.

    The fix is to clear the HomeVar when the QA starts.

    I will add it to the next version.

    For now you can go into the QA and the iOSLocation file and on line ~454 add one line

    Please login or register to see this code.

    It will be there in the next version -probably tomorrow.

    Thanks, it working. Can you do the same for user status?

    Edited by Ievgenii
    Link to comment
    Share on other sites

    there is another “bug” I was detected. If location of users can’t be detected (phone or geolocation turned off) the home and user status don’t change to “unknown”. Seems like QA shows last status.

    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Reply to this topic...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

     Share

    ×
    ×
    • Create New...