Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


iOSLocator


Recommended Posts

Hi 
QA works but suddenly stopped, now i get this error

Please login or register to see this code.

 

Edited by marczu_83
Link to comment
Share on other sites

  • Topic Author
  • 30 minutes ago, marczu_83 said:

    Hi 
    QA works but suddenly stopped, now i get this error

    Fix v0.45 - I hope... let me know.

    Please login or register to see this attachment.

    • Thanks 1
    Link to comment
    Share on other sites

    2 godziny temu, jgab napisał:

    Fix v0.45 - I hope... let me know.

    Please login or register to see this attachment.

    Looking good :)

    • Thanks 1
    Link to comment
    Share on other sites

    Hi @jgab

     

    For me the 0.45  seems to tease me a lot

    I got an error when initiliazing

    [14.07.2022] [08:44:04] [DEBUG] [QUICKAPP1670]: Matched device Dr. Søgaard(iPhone 13 Pro Max) for user Christian
    [14.07.2022] [08:44:04] [ERROR] [QUICKAPP1670]: in Event({"type":"checkPresence"}) => ..: /usr/share/lua/5.3/common/device.lua:49: attempt to index a nil value (field 'properties')

     

    Polling seems to run fine

    [14.07.2022] [08:47:03] [DEBUG] [QUICKAPP1670]: Matched device Dr. Søgaard(iPhone 13 Pro Max) for user Christian
    [14.07.2022] [08:47:33] [DEBUG] [QUICKAPP1670]: Next polling in 30s
    [14.07.2022] [08:47:33] [DEBUG] [QUICKAPP1670]: Matched device silje :)(iPhone X) for user Silje
    [14.07.2022] [08:48:03] [DEBUG] [QUICKAPP1670]: Next polling in 30s
    [14.07.2022] [08:48:03] [DEBUG] [QUICKAPP1670]: Matched device Ea iPhone 11(iPhone 11 Pro) for user Ea
    [14.07.2022] [08:48:33] [DEBUG] [QUICKAPP1670]: Next polling in 30s

     

    But the Children are not being updated.

    Eg when screenshot was taken 1675 was away for more that one hour. And testing running 0.44 is parallel shows difference

    Please login or register to see this image.

    /monthly_2022_07/2022-07-14_08-50-03.png.b4e2a6ad426994343e51e61b389a51ff.png" />

     

     

    Link to comment
    Share on other sites

  • Topic Author
  • 6 minutes ago, ChristianSogaard said:

    Hi @jgab

     

    For me the 0.45  seems to tease me a lot

    I got an error when initiliazing

    [14.07.2022] [08:44:04] [DEBUG] [QUICKAPP1670]: Matched device Dr. Søgaard(iPhone 13 Pro Max) for user Christian
    [14.07.2022] [08:44:04] [ERROR] [QUICKAPP1670]: in Event({"type":"checkPresence"}) => ..: /usr/share/lua/5.3/common/device.lua:49: attempt to index a nil value (field 'properties')

     

    Polling seems to run fine

    [14.07.2022] [08:47:03] [DEBUG] [QUICKAPP1670]: Matched device Dr. Søgaard(iPhone 13 Pro Max) for user Christian
    [14.07.2022] [08:47:33] [DEBUG] [QUICKAPP1670]: Next polling in 30s
    [14.07.2022] [08:47:33] [DEBUG] [QUICKAPP1670]: Matched device silje :)(iPhone X) for user Silje
    [14.07.2022] [08:48:03] [DEBUG] [QUICKAPP1670]: Next polling in 30s
    [14.07.2022] [08:48:03] [DEBUG] [QUICKAPP1670]: Matched device Ea iPhone 11(iPhone 11 Pro) for user Ea
    [14.07.2022] [08:48:33] [DEBUG] [QUICKAPP1670]: Next polling in 30s

     

    But the Children are not being updated.

    Eg when screenshot was taken 1675 was away for more that one hour. And testing running 0.44 is parallel shows difference

    Please login or register to see this link.

     

     

    Very strange error that I can't find a reason for at the moment. Can you just delete the children and restart the QA so the children are created again and see if it helps?

    • Like 1
    Link to comment
    Share on other sites

    4 minutes ago, jgab said:

    Very strange error that I can't find a reason for at the moment. Can you just delete the children and restart the QA so the children are created again and see if it helps?

    thank you. - that worked ?

    Link to comment
    Share on other sites

    • 2 weeks later...

    Hi @jgab

     

    Thank you for this IOSLocator - its really awsome

     

    Finally we are getting location feedback from our Android

    Android = User Marius

    Rest of the users is IOS

    Status in the QA is "Some at home", real status is All is Home

    Also the Children for Marius is not updated .but screenshot show he is home

     

    Any thoughts?

     

     

    Please login or register to see this attachment.

     

     

    Edited by ChristianSogaard
    P
    Link to comment
    Share on other sites

    Hello Christian,

    I have the same issue Debug> some_home in real all_home.

    Perhaps an error in IOS Location???

    If I do it manual all are home

    Did you made your own $iOSHome?

    fa userA_home | userB_home => $iOS= 'some_home ???

    should be 

    userA_home & userB_away => $iOS= 'some_home

    Edited by Sjakie
    add data
    Link to comment
    Share on other sites

    20 hours ago, Sjakie said:

    Hello Christian,

    I have the same issue Debug> some_home in real all_home.

    Perhaps an error in IOS Location???

    If I do it manual all are home

    Did you made your own $iOSHome?

    fa userA_home | userB_home => $iOS= 'some_home ???

    should be 

    userA_home & userB_away => $iOS= 'some_home

     

    Hi Sjakie

     

    Im using the build in iOSHome or do I misunderstand what you ask?

    I looked for the "userA_home | userB_home => $iOS= 'some_home" in the code 

    I only found

    Please login or register to see this code.

     

    could you elaborate ?

     

    I saw this error yesterday, but only once.

    Please login or register to see this code.

     

     

    Link to comment
    Share on other sites

    OK it could be possible you created your own rule some_home.

    I have one phone with difficulties I saw yesterday location was resented to off.

    Redid the location and will see if we go away today what it will do.

    On two phones I also have error

    Please login or register to see this code.

    the error is much longer but I have no clue what info is embedded.

    Despite this error (a few times a day) location is working.

    Link to comment
    Share on other sites

    • 1 month later...

    Hi Jan

    I have issues with my IOS locator - i tried reinstalling the QA - with same issue.

    I dont thing i had i working probably since version 033 - but it had focused on other things so i am not 100% sure,


    I have four IOS users, all are being authenticated at correct at iCloud.
    User Silje home=false, rest is true.

     

    [27.08.2022] [14:26:16] [DEBUG] [QUICKAPP1726]: iOSLocator deviceId:1726, v0.45
    [27.08.2022] [14:26:16] [TRACE] [QUICKAPP1726]: Home set to ‘HC3-xxxx'
    [27.08.2022] [14:26:16] [TRACE] [QUICKAPP1726]: Global variable for home status: iOSHome
    [27.08.2022] [14:26:16] [TRACE] [QUICKAPP1726]: Name of home place: 'Home'
    [27.08.2022] [14:26:16] [TRACE] [QUICKAPP1726]: Name of AWAY place: ‘Away'

    [27.08.2022] [14:26:18] [DEBUG] [QUICKAPP1726]: XXXXX, Device type:iPhone 13 Pro Max, battery:0.50%, Latitude:55.6775, Longitude:12.4073, Altitude:0.0000, Floor level:0
    [27.08.2022] [14:26:18] [DEBUG] [QUICKAPP1726]: ----------------------------------------------
    [27.08.2022] [14:26:18] [DEBUG] [QUICKAPP1726]: Matched device XXXXX(iPhone 13 Pro Max) for user Christian

     

    This is error is shown first time for this user only, every time QA restarts.
    [27.08.2022] [14:26:18] [ERROR] [QUICKAPP1726]: in Event({"type":"checkPresence"}) => ..: /usr/share/lua/5.3/common/device.lua:49: attempt to index a nil value (field 'properties’)
    ...
    [27.08.2022] [14:26:41] [DEBUG] [QUICKAPP1726]: Devices for [email protected]:
    [27.08.2022] [14:26:41] [DEBUG] [QUICKAPP1726]: Name:silje :), Device type:iPhone X, battery:0.43%, Latitude:55.0611, Longitude:10.6514, Altitude:0.0000, Floor level:0
    [27.08.2022] [14:26:41] [DEBUG] [QUICKAPP1726]: ----------------------------------------------
    [27.08.2022] [14:26:41] [DEBUG] [QUICKAPP1726]: Matched device silje :)(iPhone X) for user Silje
    ..
    [27.08.2022] [14:27:04] [DEBUG] [QUICKAPP1726]: Devices for [email protected]:
    [27.08.2022] [14:27:04] [DEBUG] [QUICKAPP1726]: Name:Marius Phone, Device type:iPhone 13 Pro Max, battery:0.88%, Latitude:55.6775, Longitude:12.4071, Altitude:0.0000, Floor level:0
    [27.08.2022] [14:27:04] [DEBUG] [QUICKAPP1726]: ----------------------------------------------
    [27.08.2022] [14:27:04] [DEBUG] [QUICKAPP1726]: Matched device Marius Phone(iPhone 13 Pro Max) for user Marius
    ..
    [27.08.2022] [14:27:27] [DEBUG] [QUICKAPP1726]: Devices for [email protected]:
    [27.08.2022] [14:27:27] [DEBUG] [QUICKAPP1726]: Name:Ea iPhone 12, Device type:iPhone 12, battery:0.75%, Latitude:55.6775, Longitude:12.4072, Altitude:0.0000, Floor level:0
    [27.08.2022] [14:27:27] [DEBUG] [QUICKAPP1726]: ----------------------------------------------
    [27.08.2022] [14:27:27] [DEBUG] [QUICKAPP1726]: Matched device Ea iPhone 12(iPhone 12) for user Ea

    [27.08.2022] [14:26:17] [TRACE] [QUICKAPP1726]: Global variable for user: 'Marius' is 'iOS_Marius'
    [27.08.2022] [14:26:17] [TRACE] [QUICKAPP1726]: Global variable for user: 'Christian' is 'iOS_Christian'
    [27.08.2022] [14:26:17] [TRACE] [QUICKAPP1726]: Global variable for user: 'Silje' is 'iOS_Silje'
    [27.08.2022] [14:26:17] [TRACE] [QUICKAPP1726]: Global variable for user: 'Ea' is ‘iOS_Ea'

     

    Then after this ... Polling is successful for all users
    Neither IOS variables or the QA Childs are being updated. I also tried let the QA recreate the QA. but noluck.

     

    Any ide what this could be?


     

    Link to comment
    Share on other sites

    Christian,

    Reminder? If user is "home" he should physically leave home before status change in away.

    User need to open Yubii app to activate

    to force "home"

    Please login or register to see this code.

    I hope it will help you.

    Link to comment
    Share on other sites

    On 8/10/2022 at 9:08 PM, jgab said:

    The integration with ER€ will come - just need ti make sure that the basics works first.

     

    1 hour ago, Sjakie said:

    Christian,

    Reminder? If user is "home" he should physically leave home before status change in away.

    User need to open Yubii app to activate

    to force "home"

    Please login or register to see this code.

    I hope it will help you.

    Thank you @Sjakie always helpful :-)  

    - Unfortunate its not that. QA and Var simply dont update.

     

    I why should user open Yubii app ? - i think with IOS locator you dont need the Yubii app

     

    Now i tried 0.46 from Github but is getting

    [27.08.2022] [20:57:22] [ERROR] [QUICKAPP1726]: in Event({"type":"start"}) => ..: ./include/iOSLocator.lua:59: ./include/ ./include/ bad argument #6 to 'format' (no value)(debugf)(debugf)

     

    Edited by ChristianSogaard
    P
    Link to comment
    Share on other sites

    1 hour ago, ChristianSogaard said:

     

    Thank you @Sjakie always helpful :-)  

    - Unfortunate its not that. QA and Var simply dont update.

     

    I why should user open Yubii app ? - i think with IOS locator you dont need the Yubii app

     

    Now i tried 0.46 from Github but is getting

    [27.08.2022] [20:57:22] [ERROR] [QUICKAPP1726]: in Event({"type":"start"}) => ..: ./include/iOSLocator.lua:59: ./include/ ./include/ bad argument #6 to 'format' (no value)(debugf)(debugf)

     

    Very strange - but really good.

    I deployed again, but this time from ZBS and version v.046 direct

    Now variables and QA updates right away. Finally.

     

     

    Link to comment
    Share on other sites

    Sorry log in at HC3 or Yubii app to (re)activate user

    Link to comment
    Share on other sites

    I am only getting one update per user, and then status is not updated.

    Polling for all users works

    [30.08.2022] [17:52:15] [DEBUG] [QUICKAPP1737]: ----------------------------------------------
    [30.08.2022] [17:52:15] [DEBUG] [QUICKAPP1737]: Matched device Seagaard(iPhone 13 Pro Max) for user Christian
    [30.08.2022] [17:52:16] [TRACE] [QUICKAPP1737]: User Christian at Home (0.02 km from home)

     

    This TRACE is only showed once per user in QA lifetime - 

    User Christian at Home (0.02 km from home)

     

    Deleting all Childs, triggers the "User Christian at Home (0.02 km from home)" again and location is updated.

    Running 0.46

    Link to comment
    Share on other sites

    Hi @jgab

     

    I could really use some assistance for the IOSLocator.

     

    I have reinstalled the QA multiple times, re-entered credentials, i tried multiple versions of the QA .

    Now is running 0.46, fibaro.FIBARO_EXTRA = "v0.950"

    No matter what i do, I only gets the GEO information for the user, when initializing the QA.

    Polling for all users works for each schedule

    [30.08.2022] [17:52:15] [DEBUG] [QUICKAPP1737]: ----------------------------------------------
    [30.08.2022] [17:52:15] [DEBUG] [QUICKAPP1737]: Matched device Seagaard(iPhone 13 Pro Max) for user Christian

     

    This TRACE is only shown once per user, and only after the initializing of the QA. 

    [30.08.2022] [17:52:16] [TRACE] [QUICKAPP1737]: User Christian at Home (0.02 km from home)

    User Christian at Home (0.02 km from home)

    and for all for users the..."Matched device xxxxxx" is showed for every interval

     

    Deleting all Childs, triggers the Childs to be recreated and "User Christian at Home (0.02 km from home)" will show again and location is updated once.

     

    Looking at the variables - tonight they seems right.

    I understood that you don't need the Yubii app for this, and the communication is with icloud direct.

    Please login or register to see this attachment.

     

    And the corresponding Childs are not in Sync with the variables

    Please login or register to see this image.

    /monthly_2022_08/2022-08-30_21-37-39.jpg.dfd8e4278a8771e164d6596cae45c15b.jpg" />

     

     

     

    Link to comment
    Share on other sites

  • Topic Author
  • On 8/30/2022 at 9:45 PM, ChristianSogaard said:

    Hi @jgab

     

    I could really use some assistance for the IOSLocator.

     

    I will try to have a look this weekend. It requires for me to setup something similar and requires a bit of work (I have prioritized answering easy questions this week ;-) )

    Link to comment
    Share on other sites

    3 minutes ago, jgab said:

    I will try to have a look this weekend. It requires for me to setup something similar and requires a bit of work (I have prioritized answering easy questions this week ;-) )

    sounds to me a good thing to prioritize all easy stuff, then you get a lot more done ;-)

    I have IOSLocator running in both HC3 and ZBS TQAE, so let me know if there logs can can provide or test 

    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Reply to this topic...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

     Share

    ×
    ×
    • Create New...