Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team


iOSLocator


Recommended Posts

  • Topic Author
  • 30 minutes ago, Sjakie said:

    Jan,

    I changed green into blue

    My wife's devices are one in red (iPad) and one in blue(iPhone)

    I copied her "user data" with my credentials and I have two devices in blue

    You use .deviceName and .deviceType to match the device that you want to track.

    Link to comment
    Share on other sites

    Morning Jan.

     

    An observation for IOSLocator

    This morning I had user Silje (home=false) - both Var & Child is "home" but she left home yesterday at eg 15.00 .  

    I rebooted IOSLocator QA, and now it looks right again.

     

    Edited by ChristianSogaard
    Typo
    Link to comment
    Share on other sites

  • Topic Author
  • 11 minutes ago, ChristianSogaard said:

    Morning Jan.

     

    An observation for IOSLocator

    This morning I had user Silje (home=false) - both Var & Child is "home" but she left home yesterday at eg 15.00 .  

    I rebooted IOSLocator QA, and not it looks right again.

     

    Is Silje an iPhone user? or just a HC3 user?

    Do you see if in the log if Silje is polled correctly?

    Link to comment
    Share on other sites

    Please login or register to see this code.

    Still both MacBook and iPhone listed blue in debug

    Link to comment
    Share on other sites

    25 minutes ago, jgab said:

    Is Silje an iPhone user? or just a HC3 user?

    Do you see if in the log if Silje is polled correctly?

    Silje is an Iphone user - and is polled correctly

    Please login or register to see this code.

     

    Link to comment
    Share on other sites

  • Topic Author
  • 46 minutes ago, Sjakie said:

    Please login or register to see this code.

    Still both MacBook and iPhone listed blue in debug

    Sorry, yes all devices that are locatable are green/blue. Your MacBook is locatable.

    It will log 

    "Matched device X for user Y" for the device that it's using.

    39 minutes ago, ChristianSogaard said:

    Silje is an Iphone user - and is polled correctly

    Please login or register to see this code.

     

    Ok, but does it say something after that? Like

    Please login or register to see this code.

     

    Edited by jgab
    Link to comment
    Share on other sites

    13 minutes ago, jgab said:

    Sorry, yes all devices that are locatable are green/blue. Your MacBook is locatable.

    It will log 

    "Matched device X for user Y" for the device that it's using.

    Ok, but does it say something after that? Like

    Please login or register to see this code.

     

     

    Hi Jan - 

    I did a QA restart twice 

    Logs for both times where like this.

    No "Matched device X for user Y" for user Silje

     

    Please login or register to see this code.

     

    Link to comment
    Share on other sites

  • Topic Author
  • 43 minutes ago, ChristianSogaard said:

     

    Hi Jan - 

    I did a QA restart twice 

    Logs for both times where like this.

    No "Matched device X for user Y" for user Silje

     

    Please login or register to see this code.

     

    Ok, then it didn't got a match. What is the .deviceName and .deviceType configured to for Silje?

    Sorry, you got a match.

    Could you post here or PM me your configuration for Silje (without the credentials :-) ) 

    Edited by jgab
    Link to comment
    Share on other sites

    23 minutes ago, jgab said:

    Ok, then it didn't got a match. What is the .deviceName and .deviceType configured to for Silje?

    Sorry, you got a match.

    Could you post here or PM me your configuration for Silje (without the credentials :-) ) 

    Done - used a old communication thread

    Edited by ChristianSogaard
    Typo
    Link to comment
    Share on other sites

    Jan, we both left home and came back.

    Till now I used my own rules based on user enters and leaves weird is that it has worked good but last weeks it's not working for my wife.

    Before we left I added email notification to figure out what is going wrong.

    The email surprised me we both left my wife came back according the email.

    Observations:

    If I look into your iOSLocator debug it's more to the reality! She did't left

    So perhaps the difference is you are polling and HC3 act only if position changes?

    In the passed I added some positions in the HC3, I see them coming back in your iOSLocator.

    Now I must change my locations in ER.

    Will your iOSLocator ask much of the phone batteries?

    I will let you know where I am stuck

    Well done with this QA!!

    Link to comment
    Share on other sites

    Jan See file for observation

    For me strange is that if we are away next second we are back home!

    The route we did is at crossroad point of marination and the route is only away from home. Perhaps thesis a normal practice but I see it for the first time.

    I never had a delay in arming my house but now I need to set minimum 2 minutes okay I know the change somebody will break in will be 0.0.....%

     

    Please login or register to see this attachment.

    Link to comment
    Share on other sites

  • Topic Author
  • 10 hours ago, Sjakie said:

    Jan See file for observation

    For me strange is that if we are away next second we are back home!

    The route we did is at crossroad point of marination and the route is only away from home. Perhaps thesis a normal practice but I see it for the first time.

    I never had a delay in arming my house but now I need to set minimum 2 minutes okay I know the change somebody will break in will be 0.0.....%

     

    Please login or register to see this attachment.

    Ok, I believe that you and @ChristianSogaard may suffer from the same bug. I think I have an idea what it can be....

    • Like 1
    Link to comment
    Share on other sites

    Jan I am. not suffering but seeing light at the end of the tunnel

    Link to comment
    Share on other sites

  • Topic Author
  • Ok, pushed v0.51.

    I think the problem was conflicting positioning between iPhone and HC3's own positioning.

    (I guess I thought they would complement each other... ;-) )

    Link to comment
    Share on other sites

    1 hour ago, jgab said:

    Ok, pushed v0.51.

    I think the problem was conflicting positioning between iPhone and HC3's own positioning.

    (I guess I thought they would complement each other... ;-) )

     

    Hi Jan

     

    The is still some stange things - look at user Ea in GUI - and compare with logs

    Ea is , away, home and unknown at the same time,

     

    2022-09-06_09-53-34.jpg.6ae95c7ded1988e5f3db210d6f36ae40.jpg

    2022-09-06_09-46-17.jpg.7d292316cc2b0e7abf6731f5911d9ed5.jpg

     

     

    Please login or register to see this spoiler.

     

    Edited by ChristianSogaard
    Typo
    Link to comment
    Share on other sites

  • Topic Author
  • Well, I think Ea away but the first time there is nothing to be away from (no last place) - so nothing is updated for Ea...

    I think I fixed it now so she would be set to 'away' first time around.

    Pushed v0.52

    Edited by jgab
    Link to comment
    Share on other sites

    Jan, please

     Name of home place: 'Home' Name of AWAY place: 'away'

    'Home' and 'Away' or 'home' and 'away'

    Link to comment
    Share on other sites

    47 minutes ago, Sjakie said:

    Jan, please

     Name of home place: 'Home' Name of AWAY place: 'away'

    'Home' and 'Away' or 'home' and 'away'

    I have the same OCD ;-) 

    You can set you own names...

    i remember that from a former version - looking in my logs i also have - it used to be at the Variables site

    [06.09.2022] [11:12:39] [WARNING] [QUICKAPP1760]: Variable  HomeVar not found
    [06.09.2022] [11:12:39] [WARNING] [QUICKAPP1760]: Variable  HomeName not found
    [06.09.2022] [11:12:39] [WARNING] [QUICKAPP1760]: Variable  AwayName not found

    Edited by ChristianSogaard
    Typo
    Link to comment
    Share on other sites

  • Topic Author
  • Please login or register to see this code.

     

    They are quickAppVariables now.

    Link to comment
    Share on other sites

    Hi Jan

     

    it looks great and it works great, and i has started creating Alarm rules. 

     

    - i have two observations

    If you are using several locations like the screenshot below - the user will be mapped to the relevant location, this is cool.

    In this example - Ea is at ATO.

    But when Ea is leaving ATO as you see in the logs, her location is sticky to ATO - and don't change to away.

    I have only testet 600m away from ATO - where HC3 location radius is set for 150m. 

    I will do some more testing, but if you already know, it by design, i will not test more on this.

     

    Also Marius left home

    the two GUI is showing different , and Child is not updated

    Correct is Ude/AWAY

    This is the same error as before with Ea

     

     

    Please login or register to see this image.

    /monthly_2022_09/2022-09-06_12-58-23.jpg.2cb5d96dfb5c8829f10807081d3296b2.jpg" />

     

    2022-09-06_14-03-11.jpg.a4fbda1e3f1c35b4dcc78fd01a439809.jpg

    2022-09-06_13-14-47.jpg.69c152025b37d01b6670fc3fda61521e.jpg

     

    Please login or register to see this spoiler.

     

    Edited by ChristianSogaard
    Typo
    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Reply to this topic...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

     Share

    ×
    ×
    • Create New...