Jump to content

Welcome to Smart Home Forum by FIBARO

Dear Guest,

 

as you can notice parts of Smart Home Forum by FIBARO is not available for you. You have to register in order to view all content and post in our community. Don't worry! Registration is a simple free process that requires minimal information for you to sign up. Become a part of of Smart Home Forum by FIBARO by creating an account.

 

As a member you can:

  •     Start new topics and reply to others
  •     Follow topics and users to get email updates
  •     Get your own profile page and make new friends
  •     Send personal messages
  •     ... and learn a lot about our system!

 

Regards,

Smart Home Forum by FIBARO Team



jgab

Recommended Posts

  • Topic Author
  • 1 hour ago, Sjakie said:

    Good morning Jan,

    Old error back?

    In Supervisor its not mentioned!

     

    Please login or register to see this attachment.

     

    It means that the ER scene has stopped or the ER scene has crashed  (the main event-loop in ER). The reason could be that something has stopped the scene.

    If it has crashed I can't see from your log. I would need the log prints from when the "bad logs" started.

    Link to comment
    Share on other sites

    Jan,

    the beginning of the log was aborting server thats why I could not post it or is there anotherway to get that info?

    //Sjakie

    Link to comment
    Share on other sites

  • Topic Author
  • 2 minutes ago, Sjakie said:

    Jan,

    mmh probally you are right because in NR there was nothing listed at all. This scene is my arming scene.

    I will convert all Sonos into usage of VD so I dont need NR in this scene and avoid errors..

    I use Sonos here to change volume, play and stop in case of alarm

    Can you refresh my mind cmd in ER to set slider in %?

    445:btn=3 is stop

    Thanks in advance

     

    Rule.eval("slider(445,'slVolume')=50") -- set slider to 50%

    Link to comment
    Share on other sites

  • Topic Author
  • 20 minutes ago, Sjakie said:

    Jan,

    This does not work,

    Please login or register to see this attachment.

    Sorry, don't understand why that fell off my code...

    Pushed v3,B63 that fixes it.

    • Like 1
    Link to comment
    Share on other sites

    Jan,

    Thanks will try your fix later, all NR Sonos messages are now with VD.

    If you have time can you help me with the following:

    I like to accomplish if alarm is triggered;

    hue lights in red on/off

    if hue light is off the white lights on

    So the view will be red/white

    the time on/off to be set separately.

    Hue red lights will not be used for the white color

    HUe color lights 6x,  Hue white lights 7x, normal lights 12x

    I tried with some lua available on the forum but that is not what I like.

    Your color show is great, I receive many positive reactions, that is why I want to ask you.

    Thank you very much in advance,

    //Sjakie

     

     

    Link to comment
    Share on other sites

  • Topic Author
  • 39 minutes ago, Sjakie said:

    Jan,

    Thanks will try your fix later, all NR Sonos messages are now with VD.

    If you have time can you help me with the following:

    I like to accomplish if alarm is triggered;

    hue lights in red on/off

    if hue light is off the white lights on

    So the view will be red/white

    the time on/off to be set separately.

    Hue red lights will not be used for the white color

    HUe color lights 6x,  Hue white lights 7x, normal lights 12x

    I tried with some lua available on the forum but that is not what I like.

    Your color show is great, I receive many positive reactions, that is why I want to ask you.

    Thank you very much in advance,

    //Sjakie

     

    Sorry, I'm not sure I understand fully.

    1. Your 6 hue color lights you want to blink red-off-red-off-red-off-...

    2. Your 7 hue white lights. What should they do? All turned on? 

    3. Your 12 normal lights (I assume they are not Hue). What should they do?

    Link to comment
    Share on other sites

    Hello Jan,

    Thanks,  error slider disappeared must test if volume act as slider order.

    IOS locator disabled today de-arming the house (out of the blue!) I hope it will stay on working.

     

    Normal light is not Hue

    Cycle: All normal lights, all Hue red, all Hue white >>>starting again

    endless till stop cmd

    Brightness max

    Color Hue>> red

    Hue white>>white

    I hope its clear

    Thanks

    //Sjakie

     

    Please login or register to see this image.

    /monthly_2019_09/image.png.91537f411fa41ff06253e04413524901.png" />

    Link to comment
    Share on other sites

    Good morning Jan,

    Please login or register to see this image.

    /monthly_2019_09/image.png.6d9436744305b174828684b21823aaa4.png" />

    Link to comment
    Share on other sites

  • Topic Author
  • 15 minutes ago, Sjakie said:

    Good morning Jan,

    Please login or register to see this link.

    Seems like that scene is not updated to v3.B63

     

    Link to comment
    Share on other sites

    Jan,

    I am fully lost:

    Sonos player Krikrof slider goes to 50 but volume stay where it was

    Sonos player  no effect at all

    Sonos min controller slider goes to 50 but volume stay where it was

    Any idea?

    Please login or register to see this attachment.

    Link to comment
    Share on other sites

  • Topic Author
  • 2 hours ago, Sjakie said:

    Jan,

    I am fully lost:

    Sonos player Krikrof slider goes to 50 but volume stay where it was

    Sonos player  no effect at all

    Sonos min controller slider goes to 50 but volume stay where it was

    Any idea?

     

    Please login or register to see this attachment.

    I'm not familiar with Krikrof's Sonos player. (I'm using NR you know :-) )

    Is the problem you can't set the slider value from ER?

      rule("slider(35,'Slider1')=45")

    35 is the id of the VD, '"Slider1" is the "ID:" of the slider control in the VD.

    Link to comment
    Share on other sites

    @jgab where to start looking for error?

     

    [DEBUG] 11:30:36: NodeRedER3 - EventRunner v3.0 B64[DEBUG] 11:30:36: Fibaro software version: 4.550

    [DEBUG] 11:30:36: HC2 uptime: 660 hours

    [DEBUG] 11:30:36: Sunrise 06:37, Sunset 19:32

    [DEBUG] 11:30:36:

    [DEBUG] 11:30:36: Loading rules

    [DEBUG] 11:30:36: Error loading rules:/usr/share/lua/5.2/json/decode/util.lua:35: unexpected character @ character: 1 0:1 [V] line:
    [DEBUG] 11:30:36: V


    [DEBUG] 11:30:52: Aborting: Server not started yet
     
     

    Please login or register to see this image.

    Kopiera sc

     

    Edited by FrankT
    Solved - error in HomeTable?
    Link to comment
    Share on other sites

  • Topic Author
  • 2 minutes ago, FrankT said:

    @jgab where to start looking for error?

     

    [DEBUG] 11:30:36: NodeRedER3 - EventRunner v3.0 B64[DEBUG] 11:30:36: Fibaro software version: 4.550

    [DEBUG] 11:30:36: HC2 uptime: 660 hours

    [DEBUG] 11:30:36: Sunrise 06:37, Sunset 19:32

    [DEBUG] 11:30:36:

    [DEBUG] 11:30:36: Loading rules

    [DEBUG] 11:30:36: Error loading rules:/usr/share/lua/5.2/json/decode/util.lua:35: unexpected character @ character: 1 0:1 [V] line:
    [DEBUG] 11:30:36: V


    [DEBUG] 11:30:52: Aborting: Server not started yet
     
     

    Please login or register to see this image.

    Kopiera sc

     

     

    It's in the built-in json decoder. I would suspect it's when decoding something coming in from an external service, like Nodered.

    Do you make any external calls?

    You can try to patch json.decode just before 'main()' to see if you can get a better error message.

    Please login or register to see this code.

    The 'level' may need to be adjusted for error to report the interesting line number.

    Link to comment
    Share on other sites

    58 minutes ago, jgab said:

    It's in the built-in json decoder. I would suspect it's when decoding something coming in from an external service, like Nodered.

    Do you make any external calls?

    You can try to patch json.decode just before 'main()' to see if you can get a better error message.

    Yes I make a lot of calls to NR but I think it was my HomeTable which got corrupted. I regenerated HT and now it's working again. 

     

    Link to comment
    Share on other sites

    Hello Jan

    I bought recently some smoke sensors.

    In my scene I am using those two rules but I doubt if this is okay? Must it be armed first? Am I covering all possibilities with this, please advice.

    --smoke

              Rule.eval("woonkamer.rookmelder:breached => post(#smokeAlarm); Telegram.msg(TID,'woonkamer rookmelder - rook'); notify('woonkamer rookmelder - rook')")
                  

    --tamper
               Rule.eval("woonkamer.rookmelder:tamper => post(#sabotageAlarm); Telegram.msg(TID,'woonkamer rookmelder losgemaakt - sabotage'); notify('woonkamer rookmelder losgemaakt - sabotage')")

    Thanks in advance,

    //Sjakie

     

    Link to comment
    Share on other sites

    Good morning Jan,

    I saw that one of my sceness had the message  Aborted not started yet (full debug window)

    Supervisor shows nothing only when restarted the scene.

    Is it possible Supervisor sends telegram if a scene stops?

    Please advice,

    //Sjakie

    Link to comment
    Share on other sites

  • Topic Author
  • 6 hours ago, Sjakie said:

    Good morning Jan,

    I saw that one of my sceness had the message  Aborted not started yet (full debug window)

    Supervisor shows nothing only when restarted the scene.

    Is it possible Supervisor sends telegram if a scene stops?

    Please advice,

    //Sjakie

    At the moment only push messages (fibaro:call(<phoneID>, "sendPush",<msg>) )

    You can add your phone ID in the beginning of Supervisor.lua's main() and it will notify you of restarts of scenes.

    local phonesToNotify = {<phoneID>}

     

    Link to comment
    Share on other sites

    Hello Jan,

    When I was away today Telegram dit not send any message to my phone or computer?>> wierd

    Can I send from ER an email in case we have an alarm?

    If yes please give me an example.

    Thanks in advance

    //Sjakie

    Link to comment
    Share on other sites

    Hello Jan,

    Sometimes when I want to see what happens in a scene  I cant because the scene renenwed the debug window and started with the next event.

    Is it possible to keep the last listed lines instead(lets say half of the debug window) off blank?

    Thanks in advance,

    //Sjakie

    Please login or register to see this image.

    /monthly_2019_09/image.png.a9c4fe6e8437c9a6515443f096161fa8.png" />

    Link to comment
    Share on other sites

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.

    Guest
    Reply to this topic...

    ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

    ×
    ×
    • Create New...